News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15505
Latest: jduncc
New This Month: 13
New This Week: 5
New Today: 5
Stats
Total Posts: 127161
Total Topics: 15602
Most Online Today: 61
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 2
Guests: 46
Total: 48

Pi FPP Master V2.x-283xxxx bugs

Started by AAH, April 08, 2019, 10:19:47 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

AAH

I am currently testing with Version V2.x-283-g7bbb77bf (master branch) on a Pi.I have a few issues that may be me not holding my tongue right or could be actual bugs.I updated to the master branch from a 2.4 (I think) install and the settings for channels etc were set on the earlier install.
-When in bridge mode and with "auto update" set (and presumably without it set) for the packet/channels display there is no display of channels or packets until after a manual update or there are some packets received. I'm pretty sure this is a change from earlier builds where you could at least see what universes were configured to get data regardless of whether any was coming in.
-On the bridge universes setup page I had 3 universes configured when I made the update. I can't seem to get it to increase above 1 universes now. I have deleted all universes, tried cloning universes, tried adding 4 universes from scratch and tried adding more universes on the channel outputs page in case there was something tied to that.
-On the GPIO input triggers page I don't seem to be able to select any sort of event. When I hit the arrow for the pulldown menu there is no option for anything other than "no event". I haven't played with the GPIO inputs for a few years so I might be missing something but it's not obvious to me. On a related note is it possible to configure the Pi pullups (or pulldowns) via FPP?
thanks in advanceAlan

tbone321

Do you have any events created and if so, can you still see them in the scheduler?

CaptainMurdoch

The ability to add universes is broken in the master branch right now since the patch to allow multiple universes per line in the Channel Output code.  I have a patch which fixes this and will try to get it committed tonight.

The auto-update is working fine for me in the master branch, can you look at the F12 debug Console and see if there are any JavaScript errors listed?  I also have a related patch to fix another issue I found while looking into the above problem, but I don't think that would cause what you are seeing.
-
Chris

AAH

Quote from: tbone321 on April 09, 2019, 06:57:26 AMDo you have any events created and if so, can you still see them in the scheduler?
I didn't have anything configured. I posted the above before diving into a bunch of videos to learn how to handle GPIO inputs.

tbone321

Once you start working with them, you will find that they are pretty easy to work with.  I use events to control my landscape lights thru a GPIO trigger and saw that same issue until I created the needed events.

AAH

Quote from: CaptainMurdoch on April 09, 2019, 11:46:18 AM
The ability to add universes is broken in the master branch right now since the patch to allow multiple universes per line in the Channel Output code.  I have a patch which fixes this and will try to get it committed tonight.

The auto-update is working fine for me in the master branch, can you look at the F12 debug Console and see if there are any JavaScript errors listed?  I also have a related patch to fix another issue I found while looking into the above problem, but I don't think that would cause what you are seeing.
I did an update which seems to have fixed the universes screen. A screenshot of what I was seeing before that update is below.
The add universes is still broken on : v2.x-304-g2dcd0c13 and I found another bug/quirk while I was trying to do a workaround. I needed more than 1 universe so I could test P10 panel outputs at the same time as 2811 outputs and also DMX. I knew that my HE123 backup was configured for 48 universes so I restored that. That was my brain fart issue which showed a bug/quirk. I had successfully pulled in a BBB FPP backup into a Pi. I did get the 48 universes but there was a few weird settings on panel and FPP global screens.

I tried pressing F12 but what I saw was all gibberish to me. It's a moot point now as the universes appear to being displayed at reboot.

AAH

Another bug/quirk showed up while I was adding scripts. Thanks to LawrenceDriveLights for link on FB and encouragement on ACL chat and to ListenToOurLights on YT for video. I mostly followed the video but used a couple of the built in scripts but was initially confused. On the video at about 12:30 in the event is saved. With  v2.x-304-g2dcd0c13 (master branch)  when you save it's not populating the events list. You can see it if you hit refresh or change screens and come back and it's there. Another quirk is that you can save an event with no name.

AAH

And another bug. This was also on the latest master build.I had stopped FFPD as I thought that may have been the cause of me not seeing the events that I created. I created all 3 events that I wanted to play with and when I went back to the Status page I wasn't seeing the universes and there was other issues. The attached screenshot shows what I saw. There was no status listed for FPPD, the radio button to start and stop FPPD was greyed out and FPP was essentially in mumble mode on that screen until I rebooted.

CaptainMurdoch

I created a couple github bug reports for these so they don't get missed.
-
Chris

Support FPP

+- Recent Topics

Falcon V4 Player by K-State Fan
Today at 07:40:14 AM

Linking FPP Run Command to a Button by tynmar
Today at 06:52:05 AM

Setting Color Order by K-State Fan
Today at 05:59:19 AM

BRP Voting Plugin - Allow others to vote for your songs! by Barkers Random Projects
December 03, 2022, 11:55:24 PM

loading playlist by rangerdan
December 03, 2022, 11:54:31 PM

BBB running 3-4 seconds ahead by MATTS
December 03, 2022, 09:41:41 PM

Remote Pi connection issues by JonD
December 03, 2022, 08:51:55 PM

FPP not releasing control to WLED when idle by cabrio
December 03, 2022, 08:24:43 PM

Setting up new Falcon f16v4 noob question by Scouser10231
December 03, 2022, 03:45:54 PM

Sequence freeze by jnealand
December 03, 2022, 02:51:04 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod