News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15474
Latest: Sobal44
New This Month: 96
New This Week: 11
New Today: 8
Stats
Total Posts: 126880
Total Topics: 15557
Most Online Today: 105
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 7
Guests: 70
Total: 77

"Jumper to power BBB"

Started by dloftis, May 20, 2019, 08:29:53 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

dloftis

On the F8-B (latest version from the group buy) - I assume if this jumper is connected, this means that the F8-B will provide power to the BBB, so the BBB doesn't have to have it's own power source?


Does it matter if the F8-B is being fed by 5V or 12V? In other words, can I power the F8-B with 12V and still have this jumper connected to provide power to the BBB?


Thanks

dkulp

Quote from: dloftis on May 20, 2019, 08:29:53 AM
On the F8-B (latest version from the group buy) - I assume if this jumper is connected, this means that the F8-B will provide power to the BBB, so the BBB doesn't have to have it's own power source?

Does it matter if the F8-B is being fed by 5V or 12V? In other words, can I power the F8-B with 12V and still have this jumper connected to provide power to the BBB?


As long as you set the voltage jump correctly (5V or 12V), then it won't matter.  The Buck converter will provide up to 2amps of 5V power from the 12V input.   The reason this jumper is there is there are some (obscure) cases where the 2amp might not be enough.   The onboard differential chips and buffer chip are powered from that 2amp so the BBB really only gets about 1.6amp.   Normally, that is far more than needed, but if you have a bunch of USB things plugged in that draw a bit, there might be issues. The jumper allows you to power the BBB from a separate 5V power source (barrel connector on the BBB) if more power is really needed.  Like I said, very few people would need it. 
Daniel Kulp - https://kulplights.com

dloftis

Thanks, just wanted to make sure I wasn't going to inadvertently send 12V to the BBB.


A couple more questions, if you don't mind.


The OLED on the F8-B isn't working. It's working fine on the F40, and I tried swapping the OLEDs and both OLEDs appear to work, but neither works on the F8.


In FPP, in the output settings, I have Cape Type set to F8-B (No Serial). For Version, I'm having some problems. Regardless of which version I select (1.x, 2.x, 3.x), after saving and restarting FPPd, the setting reverts to 1.x... if I select 2.x, save, restart FPPd, and go to display testing, I get a good result (lights!) - but if I choose 3.x, save, restart FPPd, and go to display testing, I'm getting nothing. (Same if I choose 1.x)


Last - not sure what I should expect here, but wanted to confirm it's correct. On the F40, I can see that FPP is detecting the cape and getting some info about it. On both the PocketScroller and F8-B, the same is not happening. Is this expected behavior? (See attached)




dkulp

#3
The PocketScroller: yes.   There isn't an eeprom on there to hold any information. 


For the F8-B, that's a problem.   Can you go to the troubleshooting page and see if anything is found in the "i2cdetect" section?   (or run "sudo i2cdetect -r -y 2)" from the command line)  If not, can you try removing the battery and trying again?   One other person is having a problem with the i2c bus on an F8-B, but I haven't been able to reproduce it on any of the boards I've tested here.    I sent that person a new board to see if the problem follows the board or the BBB, but I don't think it has arrived yet.
Daniel Kulp - https://kulplights.com

dloftis

Here's the i2cdetect output. Also noticed that hwclock doesn't see the RTC. Removing the battery makes no difference.


I can get you SSH and/or http access to this device if you'd like?




Poporacer

Not related to the issue, but you might want to change your host names on your devices to something meaningful and unique. Don't leave them all at FPP.
If to err is human, I am more human than most people.

dloftis

Quote from: Poporacer on May 20, 2019, 10:44:18 AM
Not related to the issue, but you might want to change your host names on your devices to something meaningful and unique. Don't leave them all at FPP.


I will, just playing with them at the moment. In 'production' they'll be on a separate vlan, and once I move them there I'll set static IPs and give them meaningful hostnames.

twooly

I'm seeing some of the very similar stuff mentioned in this thread.  Cant get the OLED to work and trying to do display testing with lights doesnt work either.

--- OLED doesn't work
--- F8-B cape always shows at 1.x no matter of me changing it to v3 and saving....always reverts.

Removed the battery and I'm seeing the same stuff.



     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          -- -- -- -- -- -- -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
40: -- -- -- -- -- -- -- -- 48 -- -- -- -- -- -- --
50: 50 -- -- -- UU UU UU UU -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- 68 -- -- -- -- -- -- --
70: -- -- -- -- -- -- -- --




hwclock: Cannot access the Hardware Clock via any known method.
hwclock: Use the --debug option to see the details of our search for an access
method.

mighty_mace

Any updates to this?  I am having trouble getting my Oled to display anything as well, and no luck in testing.   Running 2.5, currently downloading newest image to see if anything changes.

dkulp

OLED support wasn't added until 2.7.   It wouldn't display anything with 2.5.
Daniel Kulp - https://kulplights.com

mighty_mace

Quote from: dkulp on November 16, 2019, 05:40:33 PMOLED support wasn't added until 2.7.  It wouldn't display anything with 2.5.
Roger that, all is well on 3.5.

Dennismz51

I can't seem to create a new post, but do any of you have an idea of how damaged a F8-B+ board will be damaged by applying 12 volts when the jumper is set to 5 volts? Yep, I had a senior moment this morning and did it.

Thanks
Dennis

dkulp

Most likely removing the zenner diode would allow it to work again. Just be very careful to not do it again or everything would really blow.
Daniel Kulp - https://kulplights.com

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod