News:

LATEST RELEASE:  FPP 6.1 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/6.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15524
Latest: fighteriris
New This Month: 32
New This Week: 20
New Today: 3
Stats
Total Posts: 127343
Total Topics: 15630
Most Online Today: 135
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 10
Guests: 63
Total: 73

400khz pixels with GPIO

Started by benborden2, October 12, 2019, 01:41:49 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

benborden2

How does one change the signal output frequency in falcon pi player?

I am running WS2811's directly out of GPIO on the RPi0W.  When I hook up 800khz pixels it works just fine but when I switch to an older set that requires 400khz they do not light up.  I know the pixels work because I have a python script that runs them just fine at 400khz, however I am trying to switch to Falcon Player so that I can sync them with my other Pi.

AAH

Are you running the pixels direct from the output or are there other pixels in the same string? Worldsemi who make the WS2811 in their infinite wisdom changed the specs of WS2811 a few years ago and it led to a compatibility issue. If you put old pixels prior to new pixels everything works fine. If however you put new pixels prior to old ones all the old ones will stay turned off. I think I'm remembering the order correctly. It's either that way or the reverse and it's highly frustrating. Generally a pixel controller can drive both vintages fine but because each pixel regenerates the timing it only takes 1 "wrong" pixel to stop data transmission.

benborden2

The string I am having trouble with is just old pixels.  I haven't tried putting both kinds together because I didn't expect it to work.  It is nice to know that I might be able to put them together however, the old ones currently don't work by themselves.

Support FPP

+- Recent Topics

What am I doing wrong? FPP I’m ZCCP? by rudybuddy
Today at 09:01:26 AM

FPP Playlist by dkulp
Today at 07:14:42 AM

Setting up LOR to serial of F16v3 and configure in xLights by brmeadows
Today at 05:46:42 AM

FPP not releasing control to WLED when idle by Poporacer
December 06, 2022, 10:39:18 PM

1 player/2 remote by Poporacer
December 06, 2022, 08:07:48 PM

K8-PB Network Issue by Kensington Graves
December 06, 2022, 07:40:50 PM

Failed V1.03 diff receiver boards by bud29
December 06, 2022, 07:13:38 PM

XLights Variant by Poporacer
December 06, 2022, 06:56:52 PM

FPP Oddness. Remote not remoting, schedule not scheduling??? by Poporacer
December 06, 2022, 06:27:33 PM

Text inverted by dreiman
December 06, 2022, 06:12:17 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod