News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15659
Latest: PaulDzRGB
New This Month: 9
New This Week: 3
New Today: 0
Stats
Total Posts: 128433
Total Topics: 15791
Most Online Today: 48
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 0
Guests: 30
Total: 30

P10 Resolution, Separate vs Combined

Started by cmndr brain, November 04, 2019, 06:28:12 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

cmndr brain

I'm still new and testing some P10 Panels.  My front windows is made up of 12 (4x3) small panes.  A 3x1 matrix of P10's fit in the small window panes.  There is about a 2in gap in between the panes.  For this reason, I've decided to setup 2, 3x1 matrices vs. 1, 6x1.  This way, when setup in xLights, it will take in consideration the gap between panels and render the pattern correctly.  The image will not leave the first matrix and immediately show up on the second.  It should render the image in a nice straight line with a gap "in front" of it (I hope that makes sense).  I setup 2 separate matrices in xLights 32x48.  I also setup a group that only has the 2 matrices in it.  That way I can apply a pattern across the matrix as a whole.  When applying a pattern onto each matrix, the pattern looks great.  But, and here's the problem, when I use the group to apply a pattern, the resolution is extremely poor.  It's like comparing 8-bit 1980's graphics to modern day computers.  The fire pattern when using the group looks like it came straight from Minecraft.  I've attached 4 images, 2 of the patterns applied to the panels separately and 2 when applied as a combined group.  How can I fix the group resolution?

Emuney18

How are your panels attached to the controller driving them?  And what are you using to control them, FPP and cape or color light card?  Attach some of those screenshots and I think someone will be able to help more. From my limited panel knowledge I don't think this is related to your xlights modeling directly but how your controller is processing the data.


Sent from my iPhone using Tapatalk

dkulp

You would need to provide the xLights packaged sequence.  This is likely a render style issue.   You likely need to set the render style to Stacked Horizontal for the effect.
Daniel Kulp - https://kulplights.com

cmndr brain

#3
First, thank you guys for responding.
Emuney18:  I'm using a BeagleBone w/ octoscroller set as "remote".  FPP is setup as a 3x2 (64x48Led) matrix.  I setup xLights as 2, 3x1 (32x48Led) matrices. 1st two images.  I don't think the problem is with the hardware because, the rest of the images show that xLights want to render the images "incorrectly" in the preview window.

Dan:  Thank you for your suggestion.  I've tried every render style and don't get the results I'm looking for.  When I use the Horizontal Stack, it "virtually" pushes the panels together and because the panels are physically separated by a 2" gap, the result looks funny.  Trying to express a situation in words proves to be very difficult, so I hope the following images will help explain what I'm trying to accomplish.  If it's not possible, then I'll try to find a work around.  Imagine if you will, 1 long panel placed between 2 windows.  A scrolling image will be physically blocked by the obstacle between the windows.  To the human brain it looks smooth because it sees the obstacle and the gap.  What xLights does when the Horizontal stack is applied it pushes the panels together, in memory, as 1 long panel and doesn't take in consideration of the "gap".  So, the image leaves the edge of one panel and immediately shows up on the next.  The further away the panels are physically the worse the effect looks. 

I hope this all makes sense.  Maybe my setup is wrong and I'm approaching this the wrong way.
Images:
1: BBB LED Panel Setup (3x2 matrix)
2: xLights Matrix Setup (1st panel start channel 12241, 2nd panel start channel 16849)
3: xLights Render of single panel (Lookin' good)
4: xLights Render of Group panels (Blocky Minecraft graphics)
5: xLights Horizontal stack render style (Pushes panels together and causes a jagged edge in what should be a straight line)
6: xLights Default render style (Straight line, but back to blocky rendering)

cmndr brain

I think I've solved my problem.  With some insight from Gilrock on the xLights forum.  I created a custom model that was larger than my actual panels by 4 pixels (approx 2").  So, the custom model is a matrix of 100x32.  Then, I used Excel to generate the grid with the channels where I wanted and copied and pasted the channel grid into xLights.  I followed this by creating sub-models to make my individual Left Right panel panes.  I'll test this some more, but first tests seem to have solved my problem.  Thank you all for bearing with me and all the newer members and helping this community and hobby to be fun.

Support FPP

+- Recent Topics

F16V3 with 2 expansion boards at 40 fps MAX PIXELS per output? by BirdingPix
Today at 02:49:02 PM

Warning/Error: Network incomplete frames hit 250. by JonD
Today at 10:59:15 AM

F48V4-NS at 40 fps using all 48 pixel output ports? by Poporacer
February 06, 2023, 10:27:09 AM

Unable to update RPi 5.5 to latest version by JonB256
February 05, 2023, 07:23:16 PM

help getting started, next step? by rayster
February 05, 2023, 04:24:09 PM

F48v4NS - Pi or No Pi? by joeyblasko
February 05, 2023, 09:15:33 AM

Huidu Controllers LED matrix by CaptainMurdoch
February 04, 2023, 10:18:47 AM

FPP6.2 universes by darylc
February 03, 2023, 08:48:57 PM

F16v4 Ports vs Universe Configuration Question by k6ccc
February 03, 2023, 09:32:48 AM

Need Expert Advise on F16v4 Ports vs Universe Configuration by Kairus
February 03, 2023, 09:32:33 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod