News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15526
Latest: stooge
New This Month: 34
New This Week: 22
New Today: 1
Stats
Total Posts: 127398
Total Topics: 15640
Most Online Today: 111
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 3
Guests: 41
Total: 44

Pocket Scroller Problems

Started by adamsoncal, September 27, 2020, 11:46:17 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

adamsoncal

I have a Pocket Scroller that I just purchased to run a tune to sign with 4 P5 panels, I also have a problem with the OLED not functioning at all, I have checked the "System" page and the OLED is listed as 128 x 64 12C (SSD 1306), I can access the pocket beagle with a micro USB cord and  FPP seems to work OK, I looked at the "About" page and I don't see any mention of the OLED there, the Kulp Lights Logo is on the about page and at the top right of the FPP page.

My bigger problem is that the USB on the cape doesn't seem to work so no way to control this unit.
I have got the panel outputs to work partially I figured out that output "J1" is closest to the micro sd card but for some reason the sequence skips the first 32 rows of LED's and picks them up at the end of the sequence, also the image is spaced down about 8 rows of led all the way down the 4 panels.
I thought that maybe the sequence was messed up , so I tried the same sequence on the BBB Octoscroller and it works perfectly.
So what did I do wrong because I am at a loss and out of Ideas

Kensington Graves

With respect the OLED, if you have a panel plugged into output 6, the OLED won't work.

Do you have a USB WiFi dongle or USB Ethernet port?  If it's wireless, you may simply have it set up incorrectly.

The rest sounds like a configuration problem.  Post screen shots of you right LED panel tab, the E1.31 tab, and your network settings tab.

adamsoncal

#2
Thanks in advance for taking time to help a newbie with a problem that may be self inflicted.

I have tried to get the OLED to work with all outputs disconnected, I was aware of the conflict with output 6 and the OLED but I only need 2 outputs so that shouldn't be a problem.

I have a USB Ethernet dongle (TP Link UE300) that  I can't get it work with the pocketscroller, consequently I am not able to setup the ethernet network in network settings tab, I have tried to add a static network address and DNS but no success with that. As a last ditch effort to get this to work I loaded the sequences on the uSD card and I did get some output but not what I was expecting.

I have attached a few screen shots of different things , there is no e1.31 data as there is no network connection, it is really hard to try to control this unit as you are blind without the OLED or a network connection, I can access FPP with the computer but can't power up the Cape with the computer hooked up.You cannot view this attachment.You cannot view this attachment.You cannot view this attachment.You cannot view this attachment.You cannot view this attachment.

Kensington Graves

#3
It sounds like your hardware isn't set up correctly.  Nothing connected to the cape draws power from the PocketBeagle, iirc, which is why your Ethernet dongle isn't working and why the PocketScroller isn't powering up when connected to the computer.  I'm setting up a new PocketScroller right now.  Here's the step-by-step with some pictures.

0. Image latest version of FPP onto microSD card.

1. Insert microSD card into Pocket Beagle.

2. Connect PocketScroller to 5v power supply ("PSU") through the cape, NOT the Pocket Beagle micro-usb.  I used some bell wire (red and white 20 gauge wire in the picture) to connect the cape to the PSU.  Connect the data cables between the PocketScroller and the panels.  Connect panel power cables to the panels and PSU.

3. Connect USB Ethernet dongle to PocketScroller cape USB port.  Connect Ethernet cable between dongle and router.

4. Power up PSU. 

5. Wait a couple of minutes before you try to access FPP.  The PocketScroller boots more slowly than full BBB or Pi platforms.

6. Using Chrome, access FPP by typing "fpp.local" into the browser.  When the user interface comes up, you should see a message in red that the SD card has unused space.  Click on the "Advanced Settings" link in the message, then click the button to expand the file system, click "yes" to accept the change, and then click the "reboot" button.

7. When FPP comes back up, go to "Channel Outputs" under the Input/Output tab.  Click on the LED Panels tab.  Set up your matrix, then click the "save" button found just above the panel orientation section, then click "restart fppd".

8. Note the number of channels that are calculated on the LED Panels page, then click the "enable LED Panel output" check box.

9-11 Deleted

12. Go to the "display testing" option under the "status/control" menu option.  The "channel range" should default to all channels you have defined.  Choose a test pattern (I use Cycle: R-G-B-All-None), and check the "enable test mode" box, and watch for lights. 

If the test pattern displays correctly, then your hardware works and is correctly set up and you have eliminated hardware as an issue.  YOU WILL NEED TO CHANGE THE SETTINGS ABOVE TO MATCH YOUR SEQUENCE SETTINGS! 

If you don't get a test pattern, check you power and data connections.

Also, if your panels and PocketScroller are connected to a power distribution board and the PocketScroller shuts down when the panels switch on, you probably need heavier-gauge wire from the PSU to the distro board.

k6ccc

Quote from: Kensington Graves on October 04, 2020, 12:05:34 PM9. Check the "enable E1.31/Artnet/DDP Output". 

10. In the "output count" box, enter 1 and click the "set" button.  A line will appear below with several headings on it.

11. In the "output type" drop down, select 'E1.31 multicast".  Then go to the "Universe" heading and in the "count" box enter the  quotient obtained by dividing your channel count by 512.  Under the "FPP Channels" heading you should see a start channel of 1 and an end channel equal to the total channels you set up on the led panels tab.  Click the "save" button, then restart fppd when prompted.

Flag on the play.  Unless I'm missing something, why are you outputting E1.31?  Unless you are outputting E1.31 data from the PocketBeagle to some other device (another controller for example), you don't need to be outputting E1.31 at all if all this FPP instance is doing is driving a matrix.

I am running exactly the same configuration with a PocketBeagle and PocketScroller to drive a matrix (different matrix size), and do not have E1.31 output enabled.

Am I missing something here?
Using LOR (mostly SuperStar) for all sequencing - using FPP only to drive P5 and P10 panels.
My show website:  http://newburghlights.org

Jim

jnealand

You only congifure e1.31 outputs if, big IF, some other device is connected to the eth0 port.
Jim Nealand
Kennesaw, GA all Falcon controllers, all 12v Master Remote Multisync with Pi and BBB P10 and P5

Kensington Graves

I know.  For some reason, I couldn't get my new setup to work this morning without defining the E1.31 outputs, so I posted it just in case something changed in 4.2 that I didn't catch.  On the first half of the matrix, everything was perfect.  Adding the second half mucked up things.  The test page was adding channels beyond those I had defined, test was freezing up, and general weirdness ensued until I manually removed the extra channels from the test range and I defined the E1.31 outputs.  I'll go back into it tomorrow, look at it with a fresh set of eyes (been building and testing matrices for three days straight), and will start breaking it down in FPP.

pixelpuppy

#7
Quote from: Kensington Graves on October 04, 2020, 12:05:34 PM9. Check the "enable E1.31/Artnet/DDP Output". 
No no no.  PLEASE do NOT do that on a Pocket Scroller.
IF it is checked, UNCHECK it.  You do not want E1.31/Artnet/DDP Output enabled when running LED panels with a PocketScroller

Quote from: Kensington Graves on October 04, 2020, 08:47:56 PMI couldn't get my new setup to work this morning without defining the E1.31 outputs, so I posted it just in case something changed in 4.2 that I didn't catch. 

IF that is true, then V4.2 is broken.  That is absolutely not how it should work.  You should not enable E1.31 outputs when all you are controlling is a locally attached cape/hat/cap.  It can actually make things worse if its enabled when it shouldn't be
-Mark

Kensington Graves

Yep, I get it.  Didn't make much sense to me when I was setting it up, but it got it working.  I don't discount the probability that it was operator error due to sleep deprivation.

I went back and stripped it down to the base configuration tonight and it worked without defining E1.31, exactly per what you indicated.  I did manage to break it by setting up E1.1, then switching to DDP.  That prevented test mode from running.

I edited my prior post to remove the E1.31 info.

adamsoncal

Alright Guys, thanks for taking the time to try to help a noob get my pocketscroller working, after following the steps to reload the BBB image and resetting everything I got to step 6 on Kensington Graves list, and there is no communication through the USB dongle to the network, although the network actually see's the connection, on port 3 of the office switch, but can't access FPP to do anything. 
I know that the cable and dongle work as I have tested on other BBB devices and the router will give them a DHCP address.
I can access the pocket beagle through the micro USB on the pocket beagle and setup FPP but still no communication with pocketscroller when powered by 5 volt PSU.

With no communication with the pocketscroller when powered by 5 volt PSU and the OLED doesn't work, and the test sequences don't display correctly I'm pretty sure that the pocketscroller cape has a problem.
I think it is time to get it replaced

adamsoncal

I purchased an other pocketbeagle cape and a new OLED, now able to get network working and all is good ;D
Many thanks to all that helped a very green newbie with a problem.
Merry Christmas

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod