News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15486
Latest: Cousin_Eddie
New This Month: 108
New This Week: 22
New Today: 6
Stats
Total Posts: 126958
Total Topics: 15571
Most Online Today: 108
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 5
Guests: 50
Total: 55

Master remote sync latency

Started by aa4pack, February 08, 2021, 01:50:37 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

aa4pack

With all the time at home, I have been messing around with adding another FPP (or two) to my light display.  I have a simple homemade GPIO-595 24 channel output setup on each raspberry pi.  The two systems are right next to each other on the floor so I can see a slight lag between the two sets of sainsmart relay lights when they are both running the same sequence with one as master and the other as remote.  The two are both connected wirelessly to my router.  I clicked the "ping" button in network setup to the gateway on each, one was 4ms one was 12ms.  This seems lower than the visible lag between the two, so I don't think that is the issue.  Please let me know what I need to do to get them better in sync as I am stuck.
Also, thank you to everyone working on and supporting this project.  My kids and I have done a lot of hands-on learning over the last few years with FPP and raspberry pi.

Poporacer

Is it possible that you have the Outputs enabled on one or both Fpp devices?
If to err is human, I am more human than most people.

aa4pack

Thanks for the suggestion.  I checked and all other outputs are off on both devices.  Just the GPIO-595 output is on.
For what it's worth I can see the difference in timing on the sequence "time remaining" clocks as well.  They are just off by a quarter second or so, just like the lights on the relays.
I can try going to a wired network temporarily if that will help narrow it down to (or rule out) my wireless network.

pixelpuppy

On your "Remote" FPP, go to Status/Control -> FPP Settings -> Playback
Adjust the Remote Media/Sequence Offset to compensate for network lag between Master and Remote.

This is an "Advanced" setting, so you need to have Advanced User Mode enabled under the UI tab first.

You cannot view this attachment.
-Mark

dkulp

You can also try using unicast for remote sync instead of multicast.  Some crappy/cheap access points and routers will treat multicast like broadcast and only send it out every 300ms which can cause all kinds of issues.  If the wifi is generally reliable, then unicast might work better for you.
Daniel Kulp - https://kulplights.com

aa4pack

Thanks @pixelpuppy I adjusted the offset on the remote and I think that got me most the way to synchronizing the master and remote.  But there still seemed to be some lag to the remote even if I cranked it all the way up to 1000ms.
dkulp, my wifi is solid, so I will look into unicasting tonight.  I am also wondering if the wifi usb sticks I am using in my FPP's are the problem.  One of them is pretty old and me be causing some issues.  I think the Router should be ok as it is an asus AC86U running Merlin.  Thank you all for the help, I think you have helped me narrow it down to my network so I will focus on that tonight.

pixelpuppy

#6
Quote from: aa4pack on February 09, 2021, 12:53:20 PMThanks @pixelpuppy I adjusted the offset on the remote and I think that got me most the way to synchronizing the master and remote.  But there still seemed to be some lag to the remote even if I cranked it all the way up to 1000ms.
1000ms (1 full second) is way too long.  Something else is wrong.   You mentioned pinging the gateway, but that is somewhat meaningless in this context.  What you need to do is ping the Remote from the Master and see what kind of delay that reports.  You'll need to go into the SSH command shell to issue the ping command (FPP -> Help -> SSH Shell).

Quote from: aa4pack on February 09, 2021, 12:53:20 PMmy wifi is solid, so I will look into unicasting tonight. 
I find that unicast works much better than multicast when the WiFi network is solid.  Multicast over WiFi is a hack.  But it wont get bogged down with retransmissions if the WiFi network is really noisy and/or congested where multicast just gets sent without acknowledgement.
-Mark

aa4pack

Solved: I switched to Unicast and that fixed the problem.  @pixelpuppy I pinged to remote from master and vice versa and both were averaging about 13ms.  So, I set up a Unicast output to the remote IP address and that pinged at 5-6ms, and visible latency was eliminated with a very small offset.
Thank you very much for the help!
Now that I have 2 synced I'm thinking about adding a third set and maybe a fourth for video projection.  If I get that ambitious I may just set up a dedicated (outside) wifi router so I don't have to worry about other traffic interfering and should have better signals.  Fun project - thanks again.

aa4pack

Hey guys, this may be a bug or I may just be missing something.  But I have a second remote fpp set up now with the same 24 channel configuration.  I am using unicast to connect both remotes to the master (by clicking the unicast check boxes on the multisync screen).  I was then messing around with the remote media/sequence offset on each of the remotes.  I set one to +500 and one to -500 just to see if there was any difference in light sequence timing between the two remotes and there was none.  (I bumped it up to +1000 and -1000 and restarted them all and there still was no perceptible difference in light sequence timing on the two remotes.)  I tried messing around with the master open/start delay too and it had no impact.  I'm wondering if the remote media/sequence offset is working as intended and I'm missing something or if something might be off.  I also tried moving everything to a dedicated wireless router last night and got the same result, the remote media/sequence offset seemed to have no impact on the timing of the light sequence relative to the master or relative to the other remote.  Thanks!

k6ccc

Yes, it does work as far as I read - but I don't use that capability, so I can't help you much.
Using LOR (mostly SuperStar) for all sequencing - using FPP only to drive P5 and P10 panels.
My show website:  http://newburghlights.org

Jim

pixelpuppy

#10
Sounds like a bug.  What version FPP?

Also, when you enabled Unicast for the remotes did you also DISABLE Multicast and Broadcast in the checkboxes at the bottom of the multi sync page.

You cannot view this attachment.
-Mark

Support FPP

+- Recent Topics

Christmas 2022 Lights by ShadowLight8
Today at 05:54:00 PM

FPP and projector by morrydavis
Today at 05:42:57 PM

Remote Relay Control by MGHaff007
Today at 05:42:01 PM

E1.31 data not getting to WLED controller by morrydavis
Today at 05:41:06 PM

Does FPP include an operating NTP server? by breese
Today at 05:11:29 PM

Wiring Diagram for the RJ45 port for DMX by dkulp
Today at 04:52:18 PM

GPIO by darylc
Today at 04:44:02 PM

FPP Settings dropdowns not populating by Poporacer
Today at 04:07:18 PM

USB Wifi Adapter by jem5136
Today at 02:15:45 PM

FPP 6.x Matrix Issues by cmndr brain
Today at 01:41:55 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod