News:

LATEST RELEASE:  FPP 6.1 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/6.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15473
Latest: vb
New This Month: 95
New This Week: 10
New Today: 9
Stats
Total Posts: 126843
Total Topics: 15549
Most Online Today: 74
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 2
Guests: 53
Total: 55

5V Power Supply with no power to BBB on K16A-B

Started by Sigmarelief, November 03, 2021, 08:20:38 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Sigmarelief

I have a "working" K16-B that ran nicely on a variable bench supply @5V and its migration to an enclosure with a generic 300W 5V power supply ran for several days of testing with no issues.  I ran in-place OS upgrade from 4.x to 5.3 and now the cape does not transfer 5V to the BBB (no LEDs on BBB, DMM confirms no power on header).  Jumpers did not move and are confirmed correct.  the 5V reads 5.03V and is stable with some relatively small dummy loads.  Switching to 2 diferent lab grade variable supplies works like a charm and everything runs nicely.

I fully understand the risks involved in using generic power supplies and will be purchasing a name brand unit, but wanted to better understand what types on onboard protection the cape has to design around this in the future.  Voltage ramp may be an issue, my Fluke 188 shows it takes ~1.5s to go from 0-5.03V, but it this may be more related to refresh rates of the meter and I don't have a scope handy.  Ripple or other high frequency noise could also be an issue, but the RMS voltage is stable to .01V so it isn't wholesale instability.  The OS upgrade seems entirely superfluous, but does not explain the reliable performance initially.

Any thoughts from the community?

bloojoop

check out the time delay relay on Kulplights.com web site.  Some powersupplies dont come up to a full 5v immediately and may not be full voltage at time of BBB boot.  The time delay relay was created for this specific purpose. 

https://kulplights.com/product/5v-time-delay-relay/
--Ron A.

dkulp

1.5s to get to 5V is an eternity.     The beagles themselves will not power on if it takes too long to get up to 4.8V.   The onboard power management on the beagles handles that.

One thing you can try:   set the power supply voltage to 5.2-5.3V and set the jumper on the K16 to the 12V position.   That will send it through the onboard buck which will drop the voltage by about 0.3/0.4V (thus, ~4.9V which would be OK for the beagle).  However, it may provide enough of a delay and capacitance in sending power to the Beagle  to allow things to boot up.
Daniel Kulp - https://kulplights.com

tbone321

Upgrading from 4.X to 5.3 should have absolutely NO effect on power up.  The Beagle needs to power up prior to loading any OS so that is not an issue.  If you are using the same power supply that you used on the bench prior to migrating them to an enclosure, I would take a serious look at your wiring and the PS and make sure that you didn't accidentally wire its plug up incorrectly or switch the PS to 220V mode.  1.5 seconds is way too long for any power supply to get to its rated voltage.

Sigmarelief

Thanks Bloojoop, this seems to be a known issue... just not known by me.  The 12V workaround also seems like a nice short term hack while I wait for more parts.

I agree that the OS should have no affect and 1.5s is forever(and using a digital DMM to time ramp up is bad form), but I still have no idea why it worked fine before...

Sigmarelief

Now I'm confused.  I installed a Mean Well RSP-320-5 and it worked great for 2 days, then when I brought everything outside, it refused to boot the BBB.  I tried "jump starting" it by connecting the +5V wires hot as well as pulling and re-installing the "power from board" and "5/12V" jumpers thinking they would apply power instantly, but no luck.

I plan to scavenge a barrel connector and add a time delay relay tomorrow to bypass board provided power, but I'm really curious what is going on.

tbone321

Have you checked the outlet for your outside power and make sure that everything is good?  It seems that all of your issues are when you connect to this outside outlet.  I would do a voltage check on this outlet and also make sure that the hot, common, and ground connections are correct.

stk21

I am also experiencing the same issue with a K8-B.   The 12v hack worked for me this morning.  

I too was working just fine for several days, then it just stopped booting.  I am using a meanwell LRS 350-5.

Support FPP

+- Recent Topics

show locks me out of falcon player by breese
Today at 04:11:38 AM

F48 with Daisy Chained Smart Receivers by Starry
Today at 03:18:05 AM

Unable to get DHCP after FPP install by Jlwright325
November 27, 2022, 11:31:30 PM

What is the second best way to get rid of pixel gap errors? by k6ccc
November 27, 2022, 10:32:34 PM

FPP connect by LedMutt
November 27, 2022, 09:29:34 PM

FPP Scheduler duplicate by Aaron Maue
November 27, 2022, 09:24:20 PM

Audio Stalls on 8th music sequence by JonD
November 27, 2022, 08:09:16 PM

Kulp 32A-B setup by tgeorges
November 27, 2022, 05:54:31 PM

MultiSync copying of Show Files not working in FPP 6.1.1 by jnealand
November 27, 2022, 05:27:32 PM

Pixel strands change color halfway through the string by jnealand
November 27, 2022, 05:18:57 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod