News:

LATEST RELEASE:  FPP 6.1 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/6.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15290
Latest: eatumup
New This Month: 36
New This Week: 5
New Today: 0
Stats
Total Posts: 125022
Total Topics: 15230
Most Online Today: 72
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 2
Guests: 46
Total: 48

help needed - effect lagging when played from fpp or xlights

Started by austrisv, December 18, 2021, 02:39:30 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

austrisv

The Bar effect sometimes freezes, then runs faster. Similar behavior from both -  FPP on Raspberry Pi 3B+ or Xlights on laptop. 
though the subjective feeling the freeze is 'more' freezing when running from FPP.  
https://share.icloud.com/photos/0dc4t1JkjE6P7x4oQ9IU2mK8A
Don't recall seeing the lag on spirals or few of other effects (but others might be less "animated").

About the setup
ws2811 leds connected to WLED on esp32. Wled says wifi signal strength >55%
In total 720 leds configured (during the candy cane bars only 4x100 are used).

20fps sequence at xLights side (though wled info is showing as 30-40fps(depending on effect)).

Will appreciate any hints or directions on how to debug. 
Does it look more like wifi/network issue (or clearly network)? Or two many leds on wled/esp? Any configuration tweaks I can try?  Have ordered esp32-poe from olimex for experiment, but will take some time before I get it.

Thank You in advance!

JonD

The Wifi feature is designed for management and master/remote solutions where you copy the programming to a SD card on the controller.  Trying to play a show directly from xlights or FPP from a wireless connection will usually lag.  Try connecting with a copper ethernet connection if you are not already and that should resolve your problem.

pixelpuppy

Quote from: austrisv on December 18, 2021, 02:39:30 PM20fps sequence at xLights side (though wled info is showing as 30-40fps(depending on effect)).
Something seems very fishy there. If the sequence it really set for 20fps (50ms) then WLED should not be getting data at 30-40fps

Are you sure the sequence is not set for 40 FPS?   I don't think WLED can keep up at that rate and that would explains seeing variable 30-40fps rates and also lagging
-Mark

austrisv

Quote from: JonD on December 21, 2021, 05:37:47 PMThe Wifi feature is designed for management and master/remote solutions where you copy the programming to a SD card on the controller.  Trying to play a show directly from xlights or FPP from a wireless connection will usually lag.  Try connecting with a copper ethernet connection if you are not already and that should resolve your problem.
ha, this is a good point and easy to fix. I was somehow so concentrated on thinking of how to make my ESP32 wired that forgot of RPi beeing wifi as well. Will give it a try tonight and report back. Thank You!

Spottedbb

Also check that Disable Wifi sleep is checked under Wifi Setup. I was having the same problem with the show and this was not checked.
I am running 9 WLED ESP32s and after checking this, they all run pretty smoothly now.

austrisv

@Spottedbb disable Wifi is checked, that I found&tried as first thing.

I lost y-day night trying to figure out why FPP is not playing when I disable wlan0 and leave it on eth0 only ... was considering looking for firewall rules or smtg ... took a while before I spotted the "source interface" dropdown in the channel outputs screen. ha :D
Had a spare Mikrotik hap ac lite. RPi connected over LAN. WLED's over WiFi interface.
The effect lag is still there - both, on 4x100 pixel candy canes with 'bar' and on 126px snowman with 'fan'.
Maybe it's more noticeable on the snowman (in past those were canes). Will attribute it to routers position and thus wifi network coverage ("snowman" has the lowest signal strength). Can't await olimex esp32-poe to try out wired wled.

austrisv

@pixelpuppy your comment about fps don't let me sleep. It is set per sequence (entire .fseq file) and not effect by effect, right? Here are screenshots from four wled instances. Three are around 19-22 frames/second while one (the one with canes) is always at higher numbers, 35-45. All played from the same .fseq (xLights->Sequence Settings->Sequence Timing=50ms). Gut feeling says it's not the cause for the lag (as "snowman" shows ~20fps and does the same), but nevertheless would love to understand what's different.

Support FPP

+- Recent Topics

WiFi RGB Light Bulbs (Wiz or phillips) by dkulp
Today at 08:40:33 AM

Email Setup 6.1 by jem5136
Today at 08:16:21 AM

Sequencing timing... by JonB256
Today at 06:47:30 AM

Pi Top on sale by JonB256
Today at 06:42:14 AM

K16a-b FPP setup by Dunkelzahn
September 26, 2022, 10:59:22 PM

Adding Audio by perigalacticon
September 26, 2022, 10:41:51 PM

Red is Green and Green is Blue and Blue is Red...... by JonD
September 26, 2022, 08:45:53 PM

OrangePi 3 LTS wifi by ctmal
September 25, 2022, 05:27:37 PM

no Lights by Poporacer
September 24, 2022, 06:47:12 PM

exceding 24000 starting channels by Poporacer
September 24, 2022, 05:53:25 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod