News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15526
Latest: stooge
New This Month: 34
New This Week: 22
New Today: 0
Stats
Total Posts: 127420
Total Topics: 15642
Most Online Today: 111
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 4
Guests: 57
Total: 61

MultiSync Issues encountered after 6.1 upgrade

Started by jpkroeker, September 20, 2022, 06:44:53 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

jpkroeker

Hi,
I upgraded my Raspberry Pi 3 Model B's from FPP 5.5 to 6.1 a couple of days ago and I'm having problems getting MultiSync to work.  

Background: I did the upgrade using the image files.  I backed up the 5.5 configuration data and restored the data once I had 6.1 up and running.  

I uploaded a sequence file to both the master and remote FPP and played it on the master.  None of the effects I was expecting to see on the remote were displayed.  Attached are the MultiSync screens from the master and the remote.  You can see that the remote considers the master to be "unreachable".    I checked that both the master and remote could "see" each other by running "ping" commands from the shell on both systems.  

Just to be sure that the sequence was working, I changed the remote to player mode and the sequence played as expected. 

On the status screen of the remote, the only stat that is updating is Ping.  I get 3 pings after a reboot of the master and 2 more pings every hour after that.  

I checked through the log files and didn't notice any error messages.  I even changed a couple of the log levels to debug (sync, sequence) to see if that would show anything, but no luck. 

Any help debugging this would be appreciated. 

John

P.S Don't worry about the error about the 192.168.2.51 device.  It's another controller that wasn't hooked up during this test. 

(Poporacer - took your advice and started this as a new topic.  Hope the screenshots help.)You cannot view this attachment. You cannot view this attachment.



  

rudybuddy

On the mutli-sync page try putting a check in the box after the IP address for FPP1 (remote).

jpkroeker


Quote from: rudybuddy on September 20, 2022, 07:37:43 PMOn the mutli-sync page try putting a check in the box after the IP address for FPP1 (remote).
Thanks, that did the trick.

I was a bit confused because whenever I checked the box, a message popped up saying that "Having Unicast checked when Multicast is enabled is discouraged".  I figured this meant I should leave the box unchecked.   Now I realize that this just means I should unselect the Multicast option in the settings. 

Thanks again!!

bloojoop

checking that box next to IP will set multisync to use unicast network communication.  you want to also go to the settings button and turn OFF the second check that enabled Multicast.  you do NOT want both selected at the same time as the message stated. 
--Ron A.

jpkroeker

Good to know.   

Just curious, when might I want to use multicast and what would that configuration look like?

Poporacer

Quote from: jpkroeker on September 21, 2022, 09:41:46 AMJust curious, when might I want to use multicast and what would that configuration look like?
Multicast is usually the preferred method, but like you found out, not all home routers handle the Multicast correctly. To configure it for Multicast, you would not have the Unicast box checked next to the controller and have the Multicast box checked in the settings.
If to err is human, I am more human than most people.

k6ccc

As a networking person, multicast is evil and should be avoided unless there is a really good reason to use it...
Multi-sync packets MIGHT actually qualify as a reason (although we're talking microseconds).
Using LOR (mostly SuperStar) for all sequencing - using FPP only to drive P5 and P10 panels.
My show website:  http://newburghlights.org

Jim

Support FPP

+- Recent Topics

FPP Connect Limiting Uploads to 16V4 by drpiotro
Today at 06:28:01 PM

Falcon V4 Player by drpiotro
Today at 05:29:09 PM

f16v4 wont play in Player or Master Mode by Poporacer
Today at 05:07:37 PM

FPP 6.2 ColorLight Issues by dennismccreery
Today at 05:06:39 PM

snmpd interference with FPP by Setarcos
Today at 03:55:29 PM

FPP v6.2 Beaglebone Black/Green WiFi at startup by egenoup
Today at 03:46:11 PM

I can't get FPP to work with F16v4 by aquinones3
Today at 03:08:26 PM

K8-PB does not recognize SB Play 3 by Poporacer
Today at 01:58:46 PM

K40D-PB by dkulp
Today at 01:04:36 PM

Text inverted by dreiman
Today at 12:44:05 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod