News:

LATEST RELEASE:  FPP 6.1 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/6.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15301
Latest: magicx
New This Month: 4
New This Week: 2
New Today: 2
Stats
Total Posts: 125131
Total Topics: 15248
Most Online Today: 86
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 2
Guests: 46
Total: 48

BBB Display

Started by TracyDockter, August 09, 2022, 04:01:19 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

TracyDockter

My K16A-B is not displaying in info on the OLED. It was working a few weeks ago. I tested all 16 ports. I've reseated the SD Card and also reloaded the SD card with FPP 6.0.2. I can access FPP via browser just fine and upload controller configs from within xlights. No display on the OLED.....I'm not sure how to troubleshoot any further.  Any  assistance would be very much appreciated. 


Poporacer

Quote from: dock24_1@hotmail.com on August 09, 2022, 04:01:19 PMNo display on the OLED.....I'm not sure how to troubleshoot any further.
How about a screenshot of your FPP Settings page....It will look something like this:
You cannot see attachments on this board.
If to err is human, I am more human than most people.

TracyDockter

Thanks-Mine does look the same.  See Attached

TracyDockter

The controller worked when I first received it back in June.  It's been sitting with no power in the box until I just tried it again a few days ago. There hasn't been any config changes, so I'm at a loss! I have a feeling it maybe faulty, but don't have any idea how to get assistance to determine that. Any additional advice is greatly appreciated.  

CaptainMurdoch

Can you go to the Troubleshooting Commands page under the main Help menu and click the 'i2cdetect' link and past the contents of that section here so we can see if the OLED is being detected by the OS?
-
Chris

TracyDockter

This is what it shows:

Loading...


TracyDockter

Then finally this:
Failed to query command:

Error: Unable to query for i2cdetect

CaptainMurdoch

Quote from: TracyDockter on August 11, 2022, 05:18:12 PMThen finally this:
Failed to query command:

Error: Unable to query for i2cdetect

I'm not sure why you are getting this error, but we should be able to get the same info from the logs zip.  Can you go to the FPP File Manager and the Logs tab and download the logs zip and attach it here.  Also, as another test, I believe the OLED is detachable on the cape.  Can you try powering the system off, removing the OLED, and powering on, and seeing if the same i2cdetect error shows in the Troubleshooting page in the UI.  Do any other sections of that page also display a similar query error or is it only i2cdetect?
-
Chris

TracyDockter

I have reseated the OLED, but that didn't change anything. I'm looking how to upload the zip file.  I'm not seeing that as an option when I reply to this message. 

Poporacer

Quote from: TracyDockter on August 17, 2022, 06:44:29 PMI'm looking how to upload the zip file.  I'm not seeing that as an option when I reply to this message.
Quick Reply doesn't give you the option to attach files. You have to go to the preview screen before you can add attachments.
If to err is human, I am more human than most people.

TracyDockter


CaptainMurdoch

The i2cdetect output in the logs zip is empty, so it means the OLED is not being detected for some reason.  Can you try powering off, removing the OLED, and rebooting without the OLED installed?  I see some errors in the messages log file like this:

Mar 20 15:12:11 FPP kernel: [ 1025.007584] omap_i2c 4819c000.i2c: timeout waiting for bus ready

Also, the i2cdetect output in the logs zip isn't showing anything.

Title  : i2cdetect
Command: sudo i2cdetect -y -r 2
-----------------------------------
     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:                         -- -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
70: -- -- -- -- -- -- -- --

We should see at least something in the output like this:

root@rpi18:~# i2cdetect -y -r 1
     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:                         -- -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- -- -- -- 3c -- -- --
40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
50: UU -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- UU -- -- -- -- -- -- --
70: -- -- -- -- -- -- -- --                         

After you reboot without the OLED installed, view the 'messages' file in the File Manager Logs tab.  If the 'waiting for bus ready' entries are not shown, then shutdown and reinstall the OLED and boot again and check the log again.
-
Chris

TracyDockter

I'm still seeing: (without the OLED) 

20 14:55:34 FPP kernel: [  12.179136] omap_i2c 4819c000.i2c: timeout waiting for bus ready
Mar 20 14:55:34 FPP kernel: [  13.181126] omap_i2c 4819c000.i2c: timeout waiting for bus ready
Mar 20 14:55:34 FPP kernel: [  13.183275] at24 2-0056: supply vcc not found, using dummy regulator
Mar 20 14:55:34 FPP kernel: [  14.185133] omap_i2c 4819c000.i2c: timeout waiting for bus ready
Mar 20 14:55:34 FPP kernel: [  15.187127] omap_i2c 4819c000.i2c: timeout waiting for bus ready

dkulp

Something's definitely wrong with the i2c bus.   My first instinct would be to remove the BBB and then re-attach it to make sure the connections are clean and solid and see if that helps.   Also make sure the P9 header to the BBB is clean.  
Daniel Kulp - https://kulplights.com

TracyDockter

OK sure thing! I've removed the BBB several times.  When this issue first started I removed it to reload the SD card. I'll try again this evening and let you know.  Thanks for you help.

Support FPP

+- Recent Topics

Is it possible to restore via /boot partition? by EricD
October 02, 2022, 11:17:17 PM

new piCaps in the works? by Bwinter
October 02, 2022, 11:07:24 PM

Projector video for just one video source by Poporacer
October 02, 2022, 09:21:09 PM

PiCap w/Controller? by james-s
October 02, 2022, 05:06:52 PM

F16V4 port 5 Lights flicker by rudybuddy
October 02, 2022, 04:18:23 PM

Smartthings Integrations by james-s
October 02, 2022, 01:26:22 PM

Advatek Vortex 48 channel DC controller by CeP
October 02, 2022, 05:34:34 AM

Upgraded to FPP V6.1.1 - Network Settings do not have "Interface Routing" option by Poporacer
October 01, 2022, 10:24:15 PM

FS Kulp K-8B Controller, Complete by poolprousa
October 01, 2022, 08:31:43 PM

60+ Ray Wu Cables, Pigtails, misc by jnealand
October 01, 2022, 08:57:49 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod