News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15526
Latest: stooge
New This Month: 34
New This Week: 22
New Today: 2
Stats
Total Posts: 127390
Total Topics: 15638
Most Online Today: 111
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 6
Guests: 47
Total: 53

Cannot connect to my f16v3 behind my FPP

Started by cmutt78, August 27, 2022, 02:07:49 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

cmutt78

I re-imaged my FPP from v4 to v6 and and redoing all of my network connections. I have successfully gotten FPP on wifi and working properly as well as my f16v3 configured and wired up as I had last year, however, I can no longer connect to my f16v3.

My setup:
wlan0
  • ip - 192.168.86.200
  • netmask - 255.255.255.0
  • gateway - 192.168.86.1

eth0
  • ip - 192.168.1.200
  • netmask - 255.255.255.0
  • gateway - blank

ip forwarding - forwarding

DNS
  • 192.168.0.1

On my F16v3 my static ip is set to 192.168.1.201 and gateway set to 192.168.1.200

The command I have used to add my route prior to upgrading is sudo route -n add -net 192.168.1.201 192.168.86.200  

Please advise what I may be doing wrong.

Poporacer

Quote from: cmutt78 on August 27, 2022, 02:07:49 PMMy setup:
wlan0
  • ip - 192.168.86.200
  • netmask - 255.255.255.0
  • gateway - 192.168.86.1

eth0
  • ip - 192.168.1.200
  • netmask - 255.255.255.0
  • gateway - blank

ip forwarding - forwarding

DNS
  • 192.168.0.1
Not your Current issue, but one that will come up. Your DNS should be 192.168.86.1 for one of them and 8.8.8.8 for the other.

Quote from: cmutt78 on August 27, 2022, 02:07:49 PMThe command I have used to add my route prior to upgrading is sudo route -n add -net 192.168.1.201 192.168.86.200
So I assume that you are on a Mac? Are you entering this in the Terminal Window from the Mac?

Creating Static Routes in Macs are not really recommended because they are not persistent so if you power down or reboot the computer, you have to enter the route in again. The better options are to enter the route in your Router (if you have access and it supports it) or to use a Proxy Host (probably the easiest method)

Your route statement does not look correct, it should be something more like
sudo route add 192.168.1.0/24 192.168.86.200  

There are 3 basic ways to get the data routed, there is more information in the FPP Manual here
https://falconchristmas.github.io/FPP_Manual(6.0).pdf#page=205
If to err is human, I am more human than most people.

cmutt78

I fixed DNS and yes this is directly in terminal.  When I ssh into fpp.local I have verified via netcat that the f16v3 is visible on the ports I want.  Tried the route command provided below to no avail.  Checking out the manual to see if something missed.

cmutt78

This is certainly not the right answer but I can hit the f16v3 if I setup a tunnel

ssh -L 3336:192.168.1.201:80 fpp@fpp.local

darylc

why not use the fpp proxy functionality to access the f16v3?

Poporacer

Quote from: cmutt78 on August 27, 2022, 02:50:59 PMI have verified via netcat that the f16v3 is visible on the ports I want.
Ports you want? Are you using some sort of special configuration?
It sounds like you might have attempted some fixes on your own and without knowing those fixes, we have no clue.
If to err is human, I am more human than most people.

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod