News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15300
Latest: lstewartff
New This Month: 3
New This Week: 1
New Today: 1
Stats
Total Posts: 125129
Total Topics: 15247
Most Online Today: 86
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 4
Guests: 45
Total: 49

Volume control command to remote player via BigButtons

Started by greggsuter, August 27, 2022, 05:41:17 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

greggsuter

I seem to have an issue with remotely controlling the volume of my remote player through Big Buttons.  None of the volume adjust/set/decrease/increase commands seem to work when I launch them through Big Buttons, but do work if I run the FPP command from the bottom drop down list, or if I run it from a scheduler event.

This only seems to affect the command going from the main player to the remote.  Any volume command works from Big Buttons if it is controlling that local player (not multicast).

Both players are connected to the same wired network, and are able to talk to each other, and the remote player responds and plays when I load a playlist on the main player, so they are synching.

As of this post, both are running the latest version of FPP 6:
FPP v6.0.2-8-g8bc1f372                                                                                                                                              
Branch: v6.0

I also have a 3rd player I use for testing, and it is connected to the same WiFi network as the other two, and behaves the same...I can remotely control its volume if I run the fpp command from the drop down menu on the bottom of the page, but will not work with the same command through Big Buttons.

I also checked to see if the plugins I have installed are the latest version, and they are.

I would like to be able to manually control the volumes of the remote player, even though I can automate the volume levels during a playlist or scheduler event.

Attached is my apache2 error log (renamed to a .txt extension to allow upload), and I deleted all of the lines except the ones for today.  The error I seem to see regarding the Big Buttons issue says there's an issue with line 46 in the config.php file in the bigbuttons plugin directory.  I opened that file to see what line 46 says, which is:

<input type='text' class="buttonTitle" placeholder="Name Your Button" id='button_TPL_Title'maxlength='80'  value='<?=$description;?>'></input>

I also LOVE the brightness fade feature, and have successfully tested it through Big Buttons.  I have certain times of the day during a playlist where it is necessary to dim the lights without restarting the playlist or sequence, and before the fade feature was available, they just immediately dimmed to a lower level, rather than gradually dimming to that level, which will make it appear more attractive.

CaptainMurdoch

Are you on the latest version of the plugin and is the Multisync checkbox showing when you setup the command in the Big Buttons config page?  If it isn't showing, check for plugin updates, there was a bug fixed earlier this year which fixed and issue with the plugin allowing the commands to be sent to remote FPP instances.
-
Chris

greggsuter

Updated bigbuttons (then verified all updates are installed) and also updated to FPP version 6.0.2-9gf245c06d branch 6.0.  Both players are running the same version of FPP, and are connected to the same wired network.  I also tried different settings in the multisync setting page, but still the same issue.

When I have multisync checked in the big buttons command and using the ip address of the remote player, it only adjusts the volume of the main player, even though it's ip address isn't entered in the multisync host box.

I can adjust the volume using the FPP command, and running the same command as I would through big buttons.

I can also run the same command as a command preset (like when FPP starts), and it adjusts the volume to the value I specify, so it seems to be something to do with the bigbuttons plugin.

Poporacer

Quote from: greggsuter on September 08, 2022, 11:41:27 PMWhen I have multisync checked in the big buttons command and using the ip address of the remote player, it only adjusts the volume of the main player, even though it's ip address isn't entered in the multisync host box.
This is a bug and is being fixed
If to err is human, I am more human than most people.

Poporacer

It should be fixed now. Update the plugin and let us know if it is working.
If to err is human, I am more human than most people.

Support FPP

+- Recent Topics

Projector video for just one video source by Poporacer
Today at 09:21:09 PM

PiCap w/Controller? by james-s
Today at 05:06:52 PM

F16V4 port 5 Lights flicker by rudybuddy
Today at 04:18:23 PM

new piCaps in the works? by james-s
Today at 01:39:26 PM

Smartthings Integrations by james-s
Today at 01:26:22 PM

Advatek Vortex 48 channel DC controller by CeP
Today at 05:34:34 AM

Upgraded to FPP V6.1.1 - Network Settings do not have "Interface Routing" option by Poporacer
October 01, 2022, 10:24:15 PM

FS Kulp K-8B Controller, Complete by poolprousa
October 01, 2022, 08:31:43 PM

60+ Ray Wu Cables, Pigtails, misc by jnealand
October 01, 2022, 08:57:49 AM

Sequence issues from Rasberry pi by Poporacer
October 01, 2022, 07:49:10 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod