News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15646
Latest: Godfree2000
New This Month: 50
New This Week: 9
New Today: 0
Stats
Total Posts: 128288
Total Topics: 15776
Most Online Today: 78
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 4
Guests: 16
Total: 20

Audio issues

Started by jacksonho, November 29, 2022, 05:43:25 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

jacksonho

Hello all,

First year with xmas lights. When I am running my show I am getting a lot of slowdown in the audio, it starts to sound robotic at times.
Current setup is
A BBB with a HE123 cape.
~1200 12v pixel lights on 2 outputs 500/700 split
Cheap USB sound card from ebay

Once I plugged the USB sound card in the audio would play but I don't seem to be able to specifically select the card in the FPP Settings. All the items in General Audio / Video have a blank selection. 

Would this mean there is an issue detecting the sound card and playing correctly which might impact the performance, or is there a possible other issue I need to look through the logs for?

Thanks

breese


jacksonho

#2
I have done a bit more deep diving, it appears that my sound card is actually showing up in FPP because in the troubleshooting section in sound cards there is this

card 0: Device [USB PnP Sound Device], device 0: USB Audio [USB Audio]



However I think I have found a larger issue that a lot of my dropdowns in FPP settings have no option, for example
Audio and video output device
RTC and Timezone
Locale

Does anyone know why all these would be blank? Apache logs seem to indicate some issue populating the array

[Wed Nov 09 09:55:00.643592 2022] [php7:warn] [pid 1028] [client 192.168.0.195:61367] PHP Warning:  file_get_contents(http://127.0.0.1/api/settings/AudioOutput/options): failed to open stream: HTTP request failed! HTTP/1.1 401 Unauthorized\r\n in /opt/fpp/www/common.php on line 422, referer: http://192.168.0.198/settings.php
[Wed Nov 09 09:55:00.644032 2022] [php7:warn] [pid 1028] [client 192.168.0.195:61367] PHP Warning:  array_keys() expects parameter 1 to be array, null given in /opt/fpp/www/common.php on line 424, referer: http://192.168.0.198/settings.php
[Wed Nov 09 09:55:00.644116 2022] [php7:warn] [pid 1028] [client 192.168.0.195:61367] PHP Warning:  count(): Parameter must be an array or an object that implements Countable in /opt/fpp/www/common.php on line 424, referer: http://192.168.0.198/settings.php


dkulp

Make sure you upgrade to FPP 6.2.  
Daniel Kulp - https://kulplights.com

Support FPP

+- Recent Topics

Cannot Connect to F48V4-NS Through Rasberry Pi by k6ccc
Today at 12:48:06 PM

new piCaps in the works? by Bwinter
Today at 11:25:32 AM

DIY voucher request by CaptainMurdoch
Today at 11:14:38 AM

Which volume to grow during setup? by RickR
Today at 09:55:17 AM

help getting started, next step? by Poporacer
Today at 09:19:12 AM

F16v3 Won't boot or power on by chiefwarrant
Today at 06:56:34 AM

Simple single Channel DMX Output trigger by info@trans-mission.tv
Today at 05:33:54 AM

No network by JonD
January 25, 2023, 12:54:50 PM

F16v3 screen is dead by JonD
January 25, 2023, 12:49:31 PM

Trying to configure LOR CF50D Floods on FPP Pi Player with PiCap by JonD
January 25, 2023, 09:08:17 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod