News:

LATEST RELEASE:  FPP 6.3 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/6.3

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15650
Latest: Androom
New This Month: 0
New This Week: 1
New Today: 0
Stats
Total Posts: 128366
Total Topics: 15784
Most Online Today: 22
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 0
Guests: 21
Total: 21

Remote script issue

Started by mac1321, December 02, 2022, 08:08:02 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

mac1321

Running 6.2  with 1 master and two remotes.  All where fresh new installs this year.  Light show works and my projector on the remote run's videos no problem with my sequence.

The issue I am having is if I use the projector plugin scripts to power on and off the projector, I have no issue.

When I try to use run remote script and put the script name in and the IP address of the remote that has the scripts and the projector attached the script never runs.  So, I am stumped and stuck. 

Any ideas or suggestions?  Below is my lead in and my lead out is just the power off script being run the same way,



darylc

does the script work when you run it directly from the remote?

mac1321

Yea it works fine when run on the remote pi directly.  Just can't trigger it to run from the master now.

Aaron Maue

I know this thread is getting a little stale, but in case you're still checking, here's a possible workaround...

1.  On the remote, create a command preset that fires the script.
2.  Instead of trying to launch a remote script from the player, launch the remote command preset.

I'm not a dev, but I'm thinking it should work the way you're trying to do it.  In the meanwhile, however, maybe this will get you rolling.

jnealand

I had a similar problem trying to turn my static TuneTo on and off.  The scripts worked great if run from the remote, but not when triggered from the master in my leadin and leadout.  The problem is the the command needed a fully qualified script name.  ie.  I had to add .sh after the script name.  Once I changed StaticOn to StaticOn.sh  it worked just like I wanted it to.
Jim Nealand
Kennesaw, GA all Falcon controllers, all 12v Master Remote Multisync with Pi and BBB P10 and P5

Support FPP

+- Recent Topics

No network by Steve_63
January 31, 2023, 08:17:21 PM

F48V4-NS Pixel Controller using all 12 Differential SmartReceiver ports by BirdingPix
January 31, 2023, 02:26:30 PM

F48v4NS - Pi or No Pi? by rjhodgefamily
January 31, 2023, 09:25:20 AM

Trying to configure LOR CF50D Floods on FPP Pi Player with PiCap by JonD
January 31, 2023, 07:01:41 AM

Script/Plug-In Trigger on Data by darylc
January 30, 2023, 11:31:16 PM

Attempting to move to FPP 6.3 from 4.4 - Assigned IP is in different subnet. by Poporacer
January 30, 2023, 05:06:59 PM

Camera input for WS2811's by dkulp
January 30, 2023, 04:02:55 PM

F16v3 Won't boot or power on by rjhodgefamily
January 30, 2023, 02:22:05 PM

Set Time/Date by Rick
January 29, 2023, 10:09:08 PM

help getting started, next step? by Poporacer
January 28, 2023, 05:10:18 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod