News:

LATEST RELEASE:  FPP 6.1 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/6.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15461
Latest: kevuk77
New This Month: 84
New This Week: 38
New Today: 5
Stats
Total Posts: 126753
Total Topics: 15532
Most Online Today: 139
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 12
Guests: 99
Total: 111

Renard PX-1 and FPP

Started by beatlerat, September 05, 2015, 04:51:42 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

beatlerat

I an having a difficult time getting my FPP to play my Renard PX-1 through the USB port. 
For testing purposes I have everything set to 57,600 baud and am using 25 WS2811 pixels (pixabulbs).
I have tested straight from the USB through a USB/Serial dongle to the PX-1 with no problems.   X-Lights
and Vixen work fine.  Ultimately, I will have 300 pixels at 230,400 baud.
I have made a .fseq file and uploaded it, along with the Mp3 to the Pi.  My output on the USB will start at channel #900.
For most of this time, all I was getting was ttyUSB0, but I was getting output (and music) from the Pi, just no pixels.
I unplugged the USB, then plugged it back in, and finally got ttyUSB1, and I still have output, and the PX-1 is showing data
(solid green) on the receiving end.  I have tried with a powered USB hub (Plugable 4-port) and without.
The song is sequenced so that I will get output on channels 900-1199.  I wasn't sure if the output in X-Lights needed
to be matched to Renard or not.  Gil didn't think so.
What can I do to troubleshoot further.  Thanks

CaptainMurdoch

Is this the same USB you used on windows with xLights?
To be safe, you should reboot with the USB dongle in and then the dongle will show up as ttyUSB0 and you can set your channel output accordingly.  Unless you have two dongles plugged in, it only came up as tryUSB1 because you unplugged and re plugged too quickly.

We have several Renard users so the code should work as long as the dongle is wired up correctly.
-
Chris

beatlerat

I have rebooted many times.
I am getting lights on the test page now, but they are lagging way behind the 1 second speed they are set to.  This is a model B+ and it seems to make no difference whether or not I use the powered USB or not.  I will keep trying combinations until I get something.

CaptainMurdoch

Try playing a sequence instead.

The test page was a last-minute hack I added last November and is not that great when you try to run it faster than 2500ms or so.  I am currently working on a rewrite of it for FPP v1.6 which should allow changing lights multiple times per second.  The current minimum value I have set in the new code is 200ms but I need to do some more testing to see how low it can go.  Actual rate will vary based on the number of channels being tested.
-
Chris

beatlerat

I tried going simple.  I set the Renard start channel to 1, disabled the E1.31, re-programmed the chip for 115,200, disabled all of the scheduler settings and set the test page to 5 seconds.  It still lags behind very badly and sort of changes colors (not all colors are the same) randomly, not set time intervals.   I do have a Pi-B, but it is set to "master branch" and updates every boot (v1.5 now).  I think that is a remnant of the testing I did for Triks-C.
The PX-1 works perfect out of the USB/serial on the computer.   I unplug the USB cable, plug it in the Pi, reboot, and I get something, but it is not good.  I have to be missing something simple. 

CaptainMurdoch

How many channels are you trying to send out now and what is the sequence frame interval?  50ms, 25ms?
-
Chris

beatlerat

I had given up on the sequences and went back to the test portion of the FPP.     I run at 50ms on all my sequences and  I am still limiting my tests to 25 pixels.  I will make a small sequence for 25 pixels and send it out on channels 1-75, make an fseq, and load it in the Pi.

CaptainMurdoch

If it doesn't work, go to the logs tab of the FPP file manager screen and view the fppd.log file and see if there are any errors from when you played the sequence.
-
Chris

beatlerat

I went back and made a new everything of an arch with 25 pixels.   I also started the FPP at channel 1.  I did some straight colors, and then some random effects.  I wanted to see if the color changes were on the money.   It is working but the effects are lagging somewhere between two and three seconds behind the music.  I have attached the logs.

CaptainMurdoch

OK.  There is nothing in the logs regarding FPP itself that stands out.  Do you know if your MP3 is VBR or CBR?  If it is VBR, then I would suggest re-encoding it as CBR because we have seen some sync issues with VBR encoded files.

Your logs also show a lot of entries like the following occurring once per second:


Sep  6 21:34:08 FPP kernel: [ 7192.353176] rtc-pcf2127 1-0051: pcf2127_set_datetime: err=-5
Sep  6 21:34:08 FPP kernel: [ 7192.353379] rtc-pcf2127 1-0051: pcf2127_get_datetime: read error


I can't find anything on the net about those errors, but I also suggest removing the rasclock and seeing if the system syncs better.  If that fixes the sync issue then we can troubleshoot the rasclock issue itself.  This doesn't sound like the normal "dead battery" problem, it appears to be an i2c I/O error if I am looking at the source correctly.  Did you have a rasclock and remove it or perhaps you configured the rasclock when you don't actually have one?
-
Chris

beatlerat

#10
Chris, I have success!!
I went back and added a rasclock thinking maybe my clock was off, or maybe I might be getting a random internet connection causing the clock to mess up.  That was not it.
Last week I had ordered these because I knew I would need to bump the speed to 230,400.   I tried it and it works.
I guess the KEYSPAN USB/RS232 device I was using worked out of the computer, but not the Pi or the powered hub.
Wished I had seen this coming.
Thanks for hanging in there with me.   Man, banging my head on this for too long.

CaptainMurdoch

Lots of people use that FTDI (clone) adapter.  It will work for your Renard and DMX if you ever want to switch.

Glad you got it working.
-
Chris

beatlerat

Just one more question.  I notice that the e682 has a limitation of number of channels it outputs for Renard, just like a serial port has limitations.  A chart is attached.  Does the FPP have the same limitations for output of Renard channels?   Just wanted to be sure.

heldwhat christmas

The limit on number of channels is directly related to baud rate and the protocol.  It will be the same regardless of the device driving the output.

Support FPP

+- Recent Topics

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod