News:

LATEST RELEASE:  FPP 7.5 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/7.5

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 16476
Latest: jbhubert
New This Month: 8
New This Week: 5
New Today: 2
Stats
Total Posts: 132724
Total Topics: 16475
Most Online Today: 114
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 2
Guests: 66
Total: 68

PC to wifi to PFF to controller

Started by Babybear, November 03, 2016, 06:44:34 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Babybear

Ok finely got my Pi up and running.   Now I need to install a batch file so my PC can talk to my controller through the PFF  different subnets

      Router 192.168.1.1  to  wlan0 PFF 192.168.1.22   to  eth0 PFF 192.168.3.35  to  eth0 F16v2 192.168.3.36

my CMD starts with    c:\users\home>

is that where I enter the command and what should it say?
really did not understand the manual on this part
running windows 10
JimmyG
Rochester, New York

tbone321

The first thing that you need to do is see if your controllers have a default gateway address setting.  If not, then there is no easy way to connect with them across networks.  If they do, then you need to do the following.

1. Set their default gateway address on your show controllers to that of the PI's Ethernet address. 
2. Go into the network settings of the PI and check the Enable Routing Between Network Interfaces checkbox.
3. On your PC, open a command line and enter the following command:  route -p add 192.168.3.0 mask 255.255.255.0 192.168.1.22

This will allow your PC to communicate with the show network thru the PI

Babybear

#2
ok Ill give that a shot
I typed in


C:/>route -p add 192.168.3.0 mask 255.255.255.0 192.168.1.22
and got back

The required operation requires elevation.

and that means?

well I found out. what a bitch to get permission in windows 10 ((Administrative Privileges))
for some reason the command prompt icon is grayed out in my windows.
 
Worked like a champ thanks so much.
JimmyG
Rochester, New York

JonB256

Using the "route add -p 192.168.1.0 mask 255.255.255.0 192.168.0.13"  worked great on my 2 working computers.

If I add that to my Asus Router in the LAN settings, should that work for every PC or Smartphone that tries to use that route?

ps, in Win10, if you search for CMD, then right click on it, it will let you quickly use it in Administrator mode.
Long time Falcon, FPP and xLights user

jnealand

Even easier in win 10 is to right click on the start button and select "Command Prompt (admin)"
Jim Nealand
Kennesaw, GA all Falcon controllers, all 12v Master Remote Multisync with Pi and BBB P10 and P5

Support FPP

+- Recent Topics

FPP led Panel Troubleshooting. by jbhubert
Today at 05:49:15 AM

Looking for SRx2 V5... by darylc
July 11, 2024, 05:54:34 PM

FPP 8.0 by colonelcline
July 11, 2024, 04:05:15 PM

SMPTE timecode by k6ccc
July 11, 2024, 10:36:03 AM

Matrix panels go full while on every restart by k6ccc
July 11, 2024, 08:17:58 AM

output controller by MikeKrebs
July 10, 2024, 10:31:28 PM

Multiple text effects cause re-render by breese
July 09, 2024, 06:19:48 AM

Cannot change serial settings for Renard by jeff.ott
July 08, 2024, 09:11:47 PM

7.5 wlan ARP issue? by peterjp
July 05, 2024, 11:44:49 PM

FPPv7.5 octoscoller error by dkulp
July 05, 2024, 10:44:41 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod