News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15486
Latest: Cousin_Eddie
New This Month: 108
New This Week: 22
New Today: 6
Stats
Total Posts: 126958
Total Topics: 15571
Most Online Today: 108
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 6
Guests: 47
Total: 53

FPP USB485 Dongle

Started by JMHaro, July 22, 2017, 08:30:35 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

JMHaro

Is it possible to run a USB485 dongle on a Raspberry Pi3?  If so, hooking it up to one of the USB ports on the Pi, how do I setup the FPP to output the first universe to that Dongle?  And is there any other configuration/drivers needed to run it on the Pi?

I have this one:  http://store.lightorama.com/uscoad.html
So just wondering if I can use that instead of a controller board just to convert to the LOR-DMX network to go to a LOR controller.

Update:
I did finally find the Other setting in the channel input screen.  I plugged in the USB485 adapber into my Pi and in that screen I did find a ttyUSB get displayed in the selection.  So I set up a LOR with the ttyUSB selected and for now I just put in 1-16 channels and selected the default 19200 speed.  Selected and saved the settings.  Made sure the channels were not selected on the regular channel screen.

Restarted the FPPD.
But could not get any indication that the LOR controller was being accessed (the sync light kept blinking).  Tried going through the channel test screen trying different channels but still nothing.  So don't know if something else is needed here.

Bshaver

Are you running your LOR in LOR mode or DMX? I have 2 of the LOR dongles if you need a true LOR dongle. I do not use them any more and can be for sale.
Denver Colorado
45,000 blinky blinks mix of pixels and 130 AC Channels (powered by Minleon & Lynx) ALL Powered by FPP and Falcon!

JMHaro

From what I understood, the LOR controllers should take either type input without any changes (am I wrong)? 

From what I can tell in the manual for the USB485 adapters.  The only thing different between the one I have and the dongle boxes, is that the boxes are powered to supply voltage to the connected controller.  But I'm connecting to regular CTB16D board so I would think the dongle that I have should work for it.

I had them setup last year to take the output from a Pixcon16 board with the output port on the board was set to LOR (which as I believe just sets the pinouts needed for LOR controllers).  But I just started testing  my system to start getting ready for this upcomming year, and something isn't working correctly with that setup now.  The FPP when I was testing the LOR channels, no matter what channel I set as the start and stop channel (same channel # on both), all the channels below that start channel light up on my controller.  Nothing changed since last year when everything ran fine, except for updating the FPP to the latest 1.9 version.

Support FPP

+- Recent Topics

Christmas 2022 Lights by ShadowLight8
Today at 05:54:00 PM

FPP and projector by morrydavis
Today at 05:42:57 PM

Remote Relay Control by MGHaff007
Today at 05:42:01 PM

E1.31 data not getting to WLED controller by morrydavis
Today at 05:41:06 PM

Does FPP include an operating NTP server? by breese
Today at 05:11:29 PM

Wiring Diagram for the RJ45 port for DMX by dkulp
Today at 04:52:18 PM

GPIO by darylc
Today at 04:44:02 PM

FPP Settings dropdowns not populating by Poporacer
Today at 04:07:18 PM

USB Wifi Adapter by jem5136
Today at 02:15:45 PM

FPP 6.x Matrix Issues by cmndr brain
Today at 01:41:55 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod