News:

LATEST RELEASE:  FPP 6.1 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/6.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15500
Latest: baggiorobertson1
New This Month: 8
New This Week: 36
New Today: 2
Stats
Total Posts: 127144
Total Topics: 15597
Most Online Today: 68
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 7
Guests: 46
Total: 53

FPP on raspberry pi & alphapix4 controller

Started by ilikelights, November 24, 2018, 06:38:26 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

ilikelights

I am really new to FPP & pi's & controlers. I am trying to learn how to configure everything. I apologize if this has been asked before and if this is some stupid mistake I am making.


I have a Raspberry pi 3 with the Falcon Christmas v2.4 on the pi. I also have a holidaycoro Alphapix4. I am able to talk to the pi over wifi. I am able to talk to the Alphapix4 hardwired to my computer.  I do not need to talk to the alphapix4 through the pi. The Alphapix does not haxe a setting in it to set a gateway address so I know that talking to it thru the pi is not possible.


My problem is that i can not get the pi to talk to the alphapix4. I cannot get it to do a successful ping. wWhat am I doing wrong? What info do you need to hep me?

clutchgp

#1
Make sure your eth0 interface on the Pi and the AlphaPix 4 are on the same subnet.  For example, by default the AlphaPix 4 is going to be 192.168.0.50, so make sure your eth0 interface is something inside of 192.168.0.X.  Replace X with anything between 1-49 and 51-254.


It is possible to talk through the Pi to and from the AlphaPix.  Even though it doesn't have a route setting it assumes .1 of its subnet as the router.  I learned that this summer fighting with four of them.


In summary, try this:


Falcon Pi eth0 

IP Address:  192.168.0.1
Subnet:  255.255.255.0
Gateway:  192.168.0.1

AlphaPix 4       

IP Address:  192.168.0.50
Subnet:  255.255.255.0


This should allow the Pi to ping the AlphaPix, and if you turn on routing you will be able to ping through it as well.

ilikelights

THANK YOU , THANK YOU, THANK YOU. IT WORKS PERFECTLY NOW. I think my problem was I wasn't using the same ip & gateway number. I was just leaving that space blank. Either way your solution fixed it.

Support FPP

+- Recent Topics

FPP 6.2 Video Issue by ppanelli3
Today at 12:04:54 PM

Raspberry PI 4 won't connect to WIFI by rbarry1068
Today at 11:18:38 AM

Sequence freeze by Poporacer
Today at 11:04:54 AM

Beagle Bone Black for sale by ppanelli3
Today at 10:40:18 AM

Port 11 not working by rossg10
Today at 09:57:03 AM

Remote script issue by mac1321
Today at 06:43:26 AM

BRP Voting Plugin - Allow others to vote for your songs! by plaberge
December 02, 2022, 11:15:17 PM

Bacground sequence by darylc
December 02, 2022, 07:34:21 PM

Fpp 6.2 ui password by darylc
December 02, 2022, 07:30:33 PM

Updating from FPP Version 3.5.4 to the latest FPP 6.1 by Poporacer
December 02, 2022, 07:07:09 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod