LATEST RELEASE:  FPP 7.5 - Download from here -



Welcome, Guest.
Please login or register.
Forgot your password?

+-Site Stats

Total Members: 16480
Latest: tcooper
New This Month: 12
New This Week: 1
New Today: 0
Total Posts: 132748
Total Topics: 16480
Most Online Today: 99
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 1
Guests: 74
Total: 75

Stable version of FPP

Started by Ebuechner, November 30, 2023, 06:31:45 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Quote from: Ebuechner on December 01, 2023, 03:24:15 PMWhat really throws me is the sequence runs perfectly from xlights and will output just fine.
Hard to tell without the music, but it played for me on my test system without locking up, but it would kind of go dark in several places and the lights were kind of frozen at times.  Pretty sure it was glitching.

If it plays from the video, and from xlights direct output to lights, it would seem like an FPP issue to me, but Chris is the genius with this stuff.  You have an issue that others can recreate, which is always a good sign you that are not going crazy!  :)   So in theory, you could install 7.2 now and see if the problem exists in older versions.  It might be helpful to the developers to know exactly when it quit working as well.  I would be willing to help you reverse course if you can confirm the issue I am looking for.   Can you possibly share your xlights video export to compare to?


At this point with all the testing I've done, I'm fairly convinced that Xlights is creating corrupt FSEQ files.
I tried installing a stable version of Xlights from last year but when I want to do FPP connect it won't communicate with the newer FPP.

Of course, what I could possibly do is drop everything back to something that worked from last year.
I'm hoping that Chris will figure out what's going on and possibly create a patch or have a fix that will clear things up.


Lot of changes in FPP connect this year.  You should be able to use FPP File Manager and upload manually. 

I re-rendered on my end and got the same results as I did with your fseq file.  I am not locking up, but the lights are not clearing on your mini trees next to the mega-tree.  Running 2023.20 as well.

You cannot view this attachment.


If you're doing that from virtual display it shows different than it actually does on the show. 
The virtual display will have the lights just freeze at points and then catch up later where the actual show they'll just shut off for that same time.


Quote from: Ebuechner on December 01, 2023, 04:58:22 PMIf you're doing that from virtual display it shows different than it actually does on the show.
The virtual display will have the lights just freeze at points and then catch up later where the actual show they'll just shut off for that same time.
That is probably what I am seeing.  Seeing lights not shut off, and the next time the display plays over them it self corrects.

The other thing I am seeing is that the display will go dark at times, when there are house effects going.  I installed Xlights 2022.25 (oldest from last year) and it did the same thing.  My FPP virtual is not locking up and playing the sequence every single time.  I have played it at least 12 times and no lockups.

You cannot view this attachment. 
You cannot view this attachment.


I went back to 7.2 and that did not make any difference, so went back to FPP 6.3 and was still seeing the issue.  I mainly used the fseq file you posted to be consistent, but also used the fseq I rendered in xLights 2022.25.  I was still seeing the issue with all those versions.  The lights at certain points still go on and off.  I left it looping in a playlist all night long on version 7.3.5 and the FPP never locked up, or seemed unstable.  In fact... 6.3, 7.2, 7.3.5 my FPP player ran exactly as expected. (Other than the sequence was not displaying correctly at times)

It did seem to be glitching in the same spot a lot of the time.  2:35? minutes in you have several house spiral effects that are glitching pretty badly on my side.  Have you looked at the timestamp when the error appears and compared it to the effects?  Assuming this is a Ebuechner original and not something you downloaded?

Do you have a backup of the sequence fseq file and FPP virtualdisplaymap from a time when this was working?


I don't have any backups. Usually when the season is done I clear out the FSEQ files and render cache because they won't be used again. 
The sequence is not in my playlist and so far after installing 7.3.1 my show hasn't locked up for two nights now. But I also wasn't having trouble with my show before until it would just suddenly lock up. 


When looking at the sequence most of the problems were happening when the fan effect was on the house with matrix group.
When I move those to the house without matrix group and uploaded to FPP, it didn't glitch in those areas.
That behavior might indicate that it's in the FSEQ file.

But it's also a possibility that FPP can't handle all of those data changes when the effect is doing all of that work.


Quote from: Ebuechner on December 03, 2023, 08:39:35 AMThat behavior might indicate that it's in the FSEQ file.
I was just manually copying the FSEQ using FPP file manager.  I would think it was the same file xLights was using to output to lights, but just guessing.  Have you tried setting up an xSchedule job in xLights to see what you get when you bypass the FPP? 

The glitch should hopefully be fixed regardless of where it exists.  I just threw out that you might be able to find the effects that are causing this, and adjust as a workaround.  I am sure you did not spend all that time creating the sequence to dream about leaving it in the penalty box.  I do think you have two problems though.  One your is FPP locking up, and the other is this sequence not playing correctly. 


Before you even said that I already tried running it in Xscheduler. I found that even Xscheduler wouldn't run the sequence. Xlights gives absolutely no warnings when you run check sequence.
So I apologize for blaming FPP for this one.
I've tried a few different things but I really don't want to dumb down the sequence so that it'll work.
One of two things should happen here either, It should work, or I should get some errors in check sequence to tell me what won't work.


7.3.5 has been somewhat stable for me, but nothing I would consider super rock solid either.  They need to make some upgrades to support the Pi5, and I am sure it is due to progress.  Trying to troubleshoot the sequence you could be adding to the FPP lockup issues.  If I need to mess with my player, I reboot it after just for kicks.  I have not had too many issues lately that were not partially self-inflicted. 


Quote from: JonD on December 03, 2023, 11:03:19 AMThey need to make some upgrades to support the Pi5
It is definitely something they are going to work on, it just wasn't released in time....BUT I foresee a LOT of problems when this does roll out. 

1. You really won't get much in the way of a performance upgrade
2. Many people will just swap out their existing Pi for the Pi 5 without upgrading the power source (why take one more thing out of the box when it was working fine with the other Pi?) The Pi 5 takes a LOT more power than the previous versions. The Pi 4 only requires 3A but the 5 requires 5A, almost double....
If to err is human, I am more human than most people.


Quote from: Poporacer on December 03, 2023, 11:28:39 AMIt is definitely something they are going to work on, it just wasn't released in time.
I thought I read 7.3 was the new OS the Pi5 requires.  (one step of many to be able to support the new model)  Just meant they are working on supporting the Pi5, and the updates are causing a few more problems than normal. 

Support FPP

+- Recent Topics

Changing FPP firmware by Poporacer
Today at 06:34:41 AM

UDP error by Poporacer
July 17, 2024, 07:19:13 PM

do I need license for my picap New? by Poporacer
July 15, 2024, 03:35:02 PM

Audio Issue with Pi Zero 2 W by robbiet
July 14, 2024, 12:07:12 PM

USB (and other) issues on Pi Zero 2w by zaicik
July 14, 2024, 04:20:33 AM

Multiple text effects cause re-render by dkulp
July 13, 2024, 08:44:07 AM

FPP led Panel Troubleshooting. by Poporacer
July 12, 2024, 09:29:56 AM

output controller by JonD
July 12, 2024, 09:29:07 AM

Looking for SRx2 V5... by darylc
July 11, 2024, 05:54:34 PM

FPP 8.0 by colonelcline
July 11, 2024, 04:05:15 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod