News:

LATEST RELEASE:  FPP 6.3 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/6.3

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15646
Latest: Godfree2000
New This Month: 50
New This Week: 9
New Today: 0
Stats
Total Posts: 128288
Total Topics: 15776
Most Online Today: 78
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 6
Guests: 16
Total: 22

Remote script issue

Started by mac1321, December 02, 2022, 08:08:02 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

mac1321

Running 6.2  with 1 master and two remotes.  All where fresh new installs this year.  Light show works and my projector on the remote run's videos no problem with my sequence.

The issue I am having is if I use the projector plugin scripts to power on and off the projector, I have no issue.

When I try to use run remote script and put the script name in and the IP address of the remote that has the scripts and the projector attached the script never runs.  So, I am stumped and stuck. 

Any ideas or suggestions?  Below is my lead in and my lead out is just the power off script being run the same way,



darylc

does the script work when you run it directly from the remote?

mac1321

Yea it works fine when run on the remote pi directly.  Just can't trigger it to run from the master now.

Aaron Maue

I know this thread is getting a little stale, but in case you're still checking, here's a possible workaround...

1.  On the remote, create a command preset that fires the script.
2.  Instead of trying to launch a remote script from the player, launch the remote command preset.

I'm not a dev, but I'm thinking it should work the way you're trying to do it.  In the meanwhile, however, maybe this will get you rolling.

jnealand

I had a similar problem trying to turn my static TuneTo on and off.  The scripts worked great if run from the remote, but not when triggered from the master in my leadin and leadout.  The problem is the the command needed a fully qualified script name.  ie.  I had to add .sh after the script name.  Once I changed StaticOn to StaticOn.sh  it worked just like I wanted it to.
Jim Nealand
Kennesaw, GA all Falcon controllers, all 12v Master Remote Multisync with Pi and BBB P10 and P5

Support FPP

+- Recent Topics

Cannot Connect to F48V4-NS Through Rasberry Pi by k6ccc
Today at 12:48:06 PM

new piCaps in the works? by Bwinter
Today at 11:25:32 AM

DIY voucher request by CaptainMurdoch
Today at 11:14:38 AM

Which volume to grow during setup? by RickR
Today at 09:55:17 AM

help getting started, next step? by Poporacer
Today at 09:19:12 AM

F16v3 Won't boot or power on by chiefwarrant
Today at 06:56:34 AM

Simple single Channel DMX Output trigger by info@trans-mission.tv
Today at 05:33:54 AM

No network by JonD
January 25, 2023, 12:54:50 PM

F16v3 screen is dead by JonD
January 25, 2023, 12:49:31 PM

Trying to configure LOR CF50D Floods on FPP Pi Player with PiCap by JonD
January 25, 2023, 09:08:17 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod