News:

LATEST RELEASE:  FPP 6.1 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/6.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15292
Latest: Rroark
New This Month: 38
New This Week: 7
New Today: 1
Stats
Total Posts: 125049
Total Topics: 15234
Most Online Today: 74
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 4
Guests: 37
Total: 41

Artnet Sync

Started by rella_yrrah, June 17, 2021, 09:55:38 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

rella_yrrah

Howdy!

I'm trying to trigger the start of a playlist / sequence from a separate application (Pangolin Beyond).   Incorporating laser imagery in with a show.   Beyond will be the "master".   It supports timeline sync via Artnet.   I'm finding some references to that in the fpp forums, but not any detail on how to apply it.   Any thoughts are appreciated.   Thanks.

dkulp

So far, we haven't had anyone interested enough in it to help get it working.   Thus, it hasn't been implemented.  Most of the infrastructure is in place as the SMPTE plugin does allow syncing via the SMPTE timecodes which are very similar.   

I did just push some changes to master that can be used as a starting point if you'd like to help out.   You. would need to be using the master branch/5.0 codebase.   You would need to set the UI level to "Advanced" and then on the System tab there is an enable checkbox for the ArtNet Time Code Sync.    Right now, when it gets a timecode, it looks for a playlist named "artnet-sync-playlist" and will start that playlist and sync with it.   Eventually, I'd like to make the playlist that is used more selectable, but just seeing if anything will actually work would be great.   I don't really have anything that will generate the time code (kind of next on my list is to add ArtNet timecode OUT support) so it's untested.  It's based on the code from the SMPTE plugin.
Daniel Kulp - https://kulplights.com

rella_yrrah

That's awesome Daniel.   Thanks for the reply and pushing that through.   I'll give it a try this weekend.

Curious on the SMPTE sync.   The laser software does support SMPTE as well.   However, I was unsure how to implement it once adding the plugin.   It seemed to be more of a plugin to send SMPTE rather than receive.   I might of been wrong on that.

Thanks again!

dkulp

SMPTE plugin depends on what "mode" fppd is running in.  If it's running in Master or player mode, it will send SMPTE sync.   If fppd is running in remote mode, it will receive and process SMPTE timecodes.   Thus, you would need to set fppd into remote mode and then go back to the SMPTE config page to get the remote mode configuration.
Daniel Kulp - https://kulplights.com

dkulp

The main issue with the SMPTE plugin as a Remote, particularly on the Pi and BBB, is that it requires an audio INPUT device.  The onboard sound device on the Pi doesn't support an input.  Thus, you need to have a soundblaster or similar for the input.   If the ArtNet can work, that's definitely a better/easier option.
Daniel Kulp - https://kulplights.com

rella_yrrah

Gotcha.  Makes sense now.   I'll start down the ArtNet path first.   Can I still be in Master mode and use the ArtNet Sync?   Thanks again!

dkulp

Quote from: rella_yrrah on June 18, 2021, 03:11:32 PMGotcha.  Makes sense now.  I'll start down the ArtNet path first.  Can I still be in Master mode and use the ArtNet Sync?  Thanks again!
Yep.  It should sync with the ArtNet packets, but also send out the FPP multisync packets as well.
Daniel Kulp - https://kulplights.com

rella_yrrah

Got the 5.0 base installed.  First and foremost - WOW!  I love the new look and feel.  Amazing.

Unfortunately though, I'm not seeing the playlist get triggered.  I verified with another machine on the network that the artnet packets are being sent from Beyond.  Is FPP listening on a particular universe?  I tried 0, 1 and 2 with no luck.  Tried adding an artnet input thinking it might need to be there...  no change.  The playlist just sits idle.  Anything I might be missing or that I could debug/log in FPP?

Thanks Daniel!

dkulp

Did you flip the UI level to advanced and turn on the ArtNet Timecode Sync support?   By default, it won't be on.

Anyway, I just added a bunch of debug level logging into the ArtNet timecode stuff.   Thus, on the Logging settings, if you change the E131Bridge log level from Info to debug and re-start fppd, more information may be available in the fppd log to help try and figure out what's happening.   You'll need to update to the latest on master first.
Daniel Kulp - https://kulplights.com

rella_yrrah

Good morning.

I did change the UI and enable it.

I'll upgrade and grab some logs.

Thanks!

rella_yrrah

Upgraded and logging...

Here is an excerpt of the fppd.log.   When Beyond is not playing, FPP is showing "invalid artnet packets".   I started Beyond and see the incoming sync packets.   I'm guessing the invalid packets are confusing things.

Did a quick wireshark packet capture (screenshot attached).   The packets look okay.

Anything else I can look into? 

Thanks!

dkulp

Hmmm... not sure on the invalid packets.   I just added some more logging for those.   That said, those are irrelevant issues for this as I DO see that it's getting valid timestamp packets.  The timestamps look good as well (1 second from the timestamp is 1 second on the clock so parsing looks correct). 

I guess the next step is to turn on debug logging for the Playlist category and see if that shows anything strange.   I assume you checked to make sure the playlist can actually be played like normal.
Daniel Kulp - https://kulplights.com

rella_yrrah

Here's another run of it after doing an update and enabling the playlist debugging.

I started sync output from Beyond...   stopped it...   waited and then manually started the playlist from within fpp.  

It plays when manually starting.   I don't see a log entry referencing any playlists when sending the artnet sync packets.

Let me know if you'd like me to try something.   I'm super appreciative of your help!

dkulp

Looking through the code, I think FPPD needs to be running in remote mode for any of the sync things to process.    Can you try flipping over to Remote mode and seeing if it starts playing the items in the playlist?

It won't send out sync packets in that mode to other remotes though...  I'll need to think a bit.  The SMPTE plugin has another setting to allow FPPD running in Remote mode to also send the various sync packets.  Might need to do the same thing here.   Not really sure.  Either that or I'll need to figure out how to get standalone/master mode to also allow some level of timecode sync.  That would be much more complex though.   Hmmmmm....
Daniel Kulp - https://kulplights.com

rella_yrrah

Putting it in remote mode did work.

For this application, I think I can allow Beyond to be the "master" and just let the other FPP instances all run in remote mode...   they should all take the same cues from Beyond.

Support FPP

+- Recent Topics

K40 PB not transmitting music by Poporacer
Today at 07:31:17 PM

Using GPIO inputs for multiple uses? by Poporacer
Today at 07:27:10 PM

Micro-SD by Poporacer
Today at 09:46:41 AM

New K4-PB wifi problems by bossier17
Today at 08:38:32 AM

OrangePi 3 LTS wifi by ctmal
September 27, 2022, 04:57:48 PM

Pi Top on sale by JonB256
September 27, 2022, 04:44:05 PM

WiFi RGB Light Bulbs (Wiz or phillips) by smoothsa
September 27, 2022, 02:42:13 PM

Email Setup 6.1 by jem5136
September 27, 2022, 08:16:21 AM

Sequencing timing... by JonB256
September 27, 2022, 06:47:30 AM

K16a-b FPP setup by Dunkelzahn
September 26, 2022, 10:59:22 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod