News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15655
Latest: _composite_
New This Month: 5
New This Week: 2
New Today: 2
Stats
Total Posts: 128412
Total Topics: 15789
Most Online Today: 35
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 0
Guests: 20
Total: 20

Remote script issue

Started by mac1321, December 02, 2022, 08:08:02 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

mac1321

Running 6.2  with 1 master and two remotes.  All where fresh new installs this year.  Light show works and my projector on the remote run's videos no problem with my sequence.

The issue I am having is if I use the projector plugin scripts to power on and off the projector, I have no issue.

When I try to use run remote script and put the script name in and the IP address of the remote that has the scripts and the projector attached the script never runs.  So, I am stumped and stuck. 

Any ideas or suggestions?  Below is my lead in and my lead out is just the power off script being run the same way,



darylc

does the script work when you run it directly from the remote?

mac1321

Yea it works fine when run on the remote pi directly.  Just can't trigger it to run from the master now.

Aaron Maue

I know this thread is getting a little stale, but in case you're still checking, here's a possible workaround...

1.  On the remote, create a command preset that fires the script.
2.  Instead of trying to launch a remote script from the player, launch the remote command preset.

I'm not a dev, but I'm thinking it should work the way you're trying to do it.  In the meanwhile, however, maybe this will get you rolling.

jnealand

I had a similar problem trying to turn my static TuneTo on and off.  The scripts worked great if run from the remote, but not when triggered from the master in my leadin and leadout.  The problem is the the command needed a fully qualified script name.  ie.  I had to add .sh after the script name.  Once I changed StaticOn to StaticOn.sh  it worked just like I wanted it to.
Jim Nealand
Kennesaw, GA all Falcon controllers, all 12v Master Remote Multisync with Pi and BBB P10 and P5

Support FPP

+- Recent Topics

Unable to update RPi 5.5 to latest version by tbone321
February 04, 2023, 08:51:43 PM

help getting started, next step? by Poporacer
February 04, 2023, 06:42:08 PM

Huidu Controllers LED matrix by CaptainMurdoch
February 04, 2023, 10:18:47 AM

FPP6.2 universes by darylc
February 03, 2023, 08:48:57 PM

F16v4 Ports vs Universe Configuration Question by k6ccc
February 03, 2023, 09:32:48 AM

Need Expert Advise on F16v4 Ports vs Universe Configuration by Kairus
February 03, 2023, 09:32:33 AM

Set Time/Date by darylc
February 02, 2023, 06:09:40 PM

We moved and are and selling everything (in Boise, ID) by ybjr38@yahoo.com
February 02, 2023, 02:14:59 PM

K8-PB No network on first run by rharrington76
February 02, 2023, 01:39:47 PM

Help How I use Orange Pi with FPP by tbone321
February 01, 2023, 02:41:58 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod