News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15492
Latest: Robnation13
New This Month: 5
New This Week: 28
New Today: 5
Stats
Total Posts: 127035
Total Topics: 15585
Most Online Today: 67
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 4
Guests: 46
Total: 50

FPP USB485 Dongle

Started by JMHaro, July 22, 2017, 08:30:35 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

JMHaro

Is it possible to run a USB485 dongle on a Raspberry Pi3?  If so, hooking it up to one of the USB ports on the Pi, how do I setup the FPP to output the first universe to that Dongle?  And is there any other configuration/drivers needed to run it on the Pi?

I have this one:  http://store.lightorama.com/uscoad.html
So just wondering if I can use that instead of a controller board just to convert to the LOR-DMX network to go to a LOR controller.

Update:
I did finally find the Other setting in the channel input screen.  I plugged in the USB485 adapber into my Pi and in that screen I did find a ttyUSB get displayed in the selection.  So I set up a LOR with the ttyUSB selected and for now I just put in 1-16 channels and selected the default 19200 speed.  Selected and saved the settings.  Made sure the channels were not selected on the regular channel screen.

Restarted the FPPD.
But could not get any indication that the LOR controller was being accessed (the sync light kept blinking).  Tried going through the channel test screen trying different channels but still nothing.  So don't know if something else is needed here.

Bshaver

Are you running your LOR in LOR mode or DMX? I have 2 of the LOR dongles if you need a true LOR dongle. I do not use them any more and can be for sale.
Denver Colorado
45,000 blinky blinks mix of pixels and 130 AC Channels (powered by Minleon & Lynx) ALL Powered by FPP and Falcon!

JMHaro

From what I understood, the LOR controllers should take either type input without any changes (am I wrong)? 

From what I can tell in the manual for the USB485 adapters.  The only thing different between the one I have and the dongle boxes, is that the boxes are powered to supply voltage to the connected controller.  But I'm connecting to regular CTB16D board so I would think the dongle that I have should work for it.

I had them setup last year to take the output from a Pixcon16 board with the output port on the board was set to LOR (which as I believe just sets the pinouts needed for LOR controllers).  But I just started testing  my system to start getting ready for this upcomming year, and something isn't working correctly with that setup now.  The FPP when I was testing the LOR channels, no matter what channel I set as the start and stop channel (same channel # on both), all the channels below that start channel light up on my controller.  Nothing changed since last year when everything ran fine, except for updating the FPP to the latest 1.9 version.

Support FPP

+- Recent Topics

FS Kulp K-8B Controller, Complete by ybjr38@yahoo.com
Today at 06:28:08 AM

Fpp 6.2 ui password by Sawdust
Today at 06:19:14 AM

FPP RPi 4 GPIO Big Button question by tynmar
Today at 06:08:16 AM

FPP not releasing control to WLED when idle by dkulp
Today at 05:27:12 AM

Remote Relay Control by MGHaff007
Today at 05:03:25 AM

Unable to donate on PayPal by darylc
Today at 04:15:05 AM

Pi zero 2w by Sawdust
Today at 12:25:33 AM

I'm Stumped by saleencb
November 30, 2022, 11:49:40 PM

BRP Voting Plugin - Allow others to vote for your songs! by plaberge
November 30, 2022, 09:27:58 PM

Very unexpected error message by tirebytrlights
November 30, 2022, 09:23:37 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod