News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15733
Latest: aquila2heman
New This Month: 0
New This Week: 0
New Today: 0
Stats
Total Posts: 128984
Total Topics: 15886
Most Online Today: 147
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 5
Guests: 116
Total: 121

Libre SBC with oled

Started by mel4853, March 19, 2023, 12:24:34 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

mel4853

I had an oled on hand and thought I would give this a try. I have the oled working with FPP but can't get the navigation buttons to work. I went into the GPIO input section and set oled navigation buttons accordingly. Do I need to change something else somewhere? I've attached the screen shots of the GPIO inputs. On the one screen shot I have GPIO 92 and 94 pulled high. If I pull them low the script runs according to the GPIO pulled low and the led will turn on or off accordingly. So I know the GPIO's are working correctly. If I enable all the navigation bottons the oled screen does not even come on. Disable all the navigation bottons and the oled will come on again. I've also attached the pinout of the Libre SBC.

Edit-This is the Le Potato board with the Libre Raspbian Debian 11 image installed. Then installed FPP on this. Everything else I use on this install seems to be working.

mel4853

I've attached some screenshots of the i2c address as it changes when enabling the i2c-ao overlay and merging it with the overlay. You have to merge the overlay to make it permanent after reboot. I've also attached the SSD1306_OLED.h file showing where the oled should be.  Could this be the problem? If so any ideas how to make this work?

Mike

Support FPP

+- Recent Topics

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod