LATEST RELEASE:  FPP 7.5 - Download from here -



Welcome, Guest.
Please login or register.
Forgot your password?

+-Site Stats

Total Members: 16480
Latest: tcooper
New This Month: 12
New This Week: 1
New Today: 0
Total Posts: 132763
Total Topics: 16481
Most Online Today: 199
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 0
Guests: 155
Total: 155

Need help in getting Vixen 3 to control relays in FFP RPI4

Started by Rob W, October 21, 2021, 10:38:41 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Rob W

I first have FPP V5.3.1 running on a Pi 4.  I have an 8 channel relay board connected to five of the eight relays on the PI using GPIO 17 Pin 11 Channel 1, GPIO 27 Pin 13 Channel 2, GPIO 22 Pin 15 Channel 3, GPIO 24 Pin 18 Channel 4 and GPIO 26 Pin 37 for Channel 5.  This all works as validated by Running the manual FPP command to toggle each on and off.  See attached screen captures attached.

I am attempting to run these lights / relays through a Vixen 3.8 sequence where the sequence for the five lights / relays was built to simply turn each light / relay on or off.  The Elements are named Canon 1 through 4 and Drum.

Once the Vixen elements and controllers were setup and patched, the sequence fseq file was made and exported from Vixen then imported as a sequence in FPP.

When I go to run the fseq in the none of the relays show any activity.  The remain in their default state.  I have set the first to relays to be on at default and the remaining channels 3 - 5 to be off at default start.

Any help would be greatly appreciated!!


I'll start and say I don't run vixen.  However, I presume you set up the "other" tab with GPIO type other outputs in FPP.  Is that correct ?  I would expect that you have 5 outputs defined, one for each relay.  You will need to set a unique start channel and the number of channels will be 1 since they are relays.  Then in vixen, I would presume that you would somehow add this fpp instance as any other e1.31 type of controller and use the starting channels that you configured in the "other" tab.  Then when vixen would send channel data for those channels to that controller, I would expect it would activate the relay.  

I know that isn't an exact answer but hopefully points you in the right direction.
--Ron A.


It's hard to do these without screen shot, but here is some blind guidance.

First, work FPP using Output screen to assign relays, then test them with the test screen.  When this is working we can work Vixen/fseq file to control the outputs.

Rob W

Dear All: First let me thank you for your replies and insights.  

There is a screen shot of the FPP Output Channel page showing the configuration of each of the five GPIO relays.

I have attached a number of screen shots as requested. This is obviously my first time with Vixen and FPP. I have uploaded a screen capture of the Vixen 3 Sequence. Essentially what i have is a pirate halloween decoration for the kids. What this sequence is designed to do is "fire" qty 4 Cannons simulated with each having a Red On / Off LED light coupled with a electrically driven linear actuator to "move" the cannon barrels when fired. The sequence shows the four Cannons and a single "Drum" relay that activates a drum for cannon firing sound. The basic sequence is looping continuously and no tied to anything else going on. All actions are either On or Off. As you see in my earlier configuration in the FPP, the in the Output configuration in FPP the On is set = 255.
 What I believe my issue is I don't really have good guidance as to how to output the Vixen 3 to make the correct FSEQ file for FPP. I have tried most all variations including output to FPP including the Falcon Player Sequence, Falcon Player Sequence 2.6 and variations on the Controller type. Seems like the best forum guidance was to use the Generic Serial.
 The problem is there is very little documentation in the new FPP on discrete On/Off control using the PI GPIO channels. My belief is the FSEQ created from Vixen and imported to FPP is not correct, the FPP does not map the output1 to the correct GPIO outputs in the FPP configuration.
 I can manually turn on / off each GPIO using the FPP Command for each channel so I know the Pi / relay board are wired and configured correctly I believe.
 Anyway, since I ran into this road block, I actually downloaded and attempted the same sequencing using Xlights and the AC light menu selection. Again, after configuring the testing the sequence in Xlights, the export of the FSEQ file rendered exact same results.
 Finally, I am running a looping video simultaneous on the PI using FPP. What I note is all videos run and loop correctly with not FSEQ running in the playlist. When I upload any of the FSEQ files for testing in the PI, I note the videos will freeze after some amount of time, say 25 seconds. My belief is that the FSEQ being executed by the FPP has errors that stop the videos when unable to execute the FSEQ. The FPP player will indicate the video and FSEQ sequence show that they continue to run.
 Sorry to the long more detailed explaination.
 Any inputs all help the learning curve.


Rob, I reviewed all the screen shots and come up with a suggestion.  I can't say for sure, but I believe the FPP GPIO need to use e1.31 inputs not the serial.  Try to remove your controller and redo as a streaming e1.31.  Export the same and load to FPP and give it a shot.


Again I'm not that familiar with vixen unfortunately. but I agree with sawdust that the FPP instance will likely need to be setup just and any other bridge mode e1.131 type of controller.  In fact if you configure the FPP channel inputs to listen for e1.31 for a single universe, you can use the FPP as a bridge mode controller and test directly from vixen I would presume.  I'm not sure of your plans to "play the show" but you may not even need a fseq file on the FPP if you are using something else to play the show, it can just receive the e1.31 channel data over the network and fire the relays when it gets the proper data.

BTW, I like the concept of simulated canon fire :)
--Ron A.


Quote from: bloojoop on October 26, 2021, 12:30:54 PM. . . .  you can use the FPP as a bridge mode controller and test directly from vixen I would presume. 
I believe this is a player, not bridged.  Original post says exported and imported the sequence to FPP

Rob W

Dear All:  I will be getting back to this Vixen FPP project this evening.  I am on the left coast in San Diego so its still early.  I am going to reconfigure the Vixen to setup to Output to the five elements after configuring the Vixen with new controller and setting the new controller to the Streaming ACN (e.131) option with five outputs. 

Will upload the FSEQ file to FPP / PI and attempt to run it!  

My ultimate objective is to get this to work and submit final document to make available to others attempting to us the GPIO output through either Vixen or XLights.  I could not find anything in a forum that worked.


One thought....set color to single color and white to allow full output. 

Rob W

Dear All:  I took all the individual suggestions and attempted each solution.  See the screen shots attached of the Vixen setup for the sequence showing each Canon is setup as a single light with Set Level also at a single color = white.

The Vixen Sequence was previewed in Vixen prior to export to RPI4 and FPP version 5.3.8.

Export is shown in screen shot.

Again, validation within FPP of being able to turn on and off each relay using the FPP command on a manual basis was successful.

Ultimately after attempting all configurations, I obviously did something wrong where the pi would not boot up to the default FPP home page.  I had to start from scratch and reinstall FPP to the Micro SD Card and reconfigure.

I decided to work the video looping from the RPI4 with FPP that has worked day one right out-of-the-box first time.  I then took an old Allen Bradley MicroLogix PLC brick, programmed it up and have it working these Cannons / Drums, etc. for Halloween to allow the kids to enjoy and takes the pressure off me to "deliver".  

I am determined to figure this out and post the results for other to utilize without the learning curve.

I am not going to attempt future debug until next week after Halloween to thus totally eliminate the video and only attempt to import a FSEQ that will function correctly.

Any inputs and comments are welcome!  Again that all of those who have contributed.


Thoughts:  you have tested with FPP test and it works, and you are playing a fseq, so appears everything in FPP is working.  Therefore something is wrong with fseq data/file.

Your Time Line Colors may be creating an issue.  Since your Sequence Editor is using red and white, your output of full white may not match, so no output is generated during Export.  Suggest you change all Time Line Inputs to full white, matching that set during color management.

You should be able to bulk edit and change easily

I think I read in another post that you should use "Falcon Player Sequence 2.6+  This is correct, and I would suggest you use 25ms timing too

You may want to start a new sequence file as your TEST, therefore any changes to the original don't need to be reverser later.  In this test file, make your close/open time longer.  your current sequence may just be too short for your relays to change state.

Rob W

I have setup / configured and tested the GPIO channels over.  I have even setup the GPIO to alternate to 255 bit count output at ON condition and 1 output at On condition.  Of course the Off condition is set by default to 0.

Using the FPP Command, I select the GPIO channel by Pin number and toggle it manually either On with the check box unchecked or Off with the On Check box checked.  

I have created a new vixen sequence where each of the five relays has been setup for White color and each has been setup to alternate On for 30 seconds and Off for 30 seconds each starting 5 second apart.  I figure that alternating on to off to on, etc for 30 seconds should provide enough duration and time to confirm relay operation.  It should not matter if the On is triggering an off for the relay in FPP or vice versa so long as the communication formatting is correct and understood between Vixen and the FPP.

My belief all along in this is there is FPP documentation or Vixen documentation to rely on to setup this senario, no easy way to confirm the FSEQ and the elements created in Vixen and Patched to the controller outputs are actually being understood by the FPP.  I obviously have not found the right combination of output configuration for the controller to patch the Vixen elements.

Also, the sequence was exactly matched overall time to the videos.

I did find in my search that someone has indicated that if you use the Generic Serial output selection for the controller that it would work the relays correctly.  This may have been accurate for a previous verson of Vixen / FPP but clearly following the steps from that posting it does not work in the current versions of Vixen and FPP I am using.

I will pursue this after Halloween to make this work with your help and others.  If there is a Linux programmer that contributed or wrote / compiled the FPP version 5.3.8, they would be able to look into the code behind the GUI to track down the miss match in output from Vixen to Input to FPP.

Thanks again for your inputs.


Since you're exporting the data to fseq file, it doesn't matter if you creates a serial controller or a sACN controller.  Exporting only looks at the channel count.  However, it would be better to have it as a sACN controller so you can test sending the data directly from Vixen to FPP.   FPP now can now receive "bridge" data while still in Remote mode.  In fact, there is no more 'bridge mode'. It lets you Enable Input in any mode now.

I'm pretty sure you want to remove those color filters from your patching.  This is an on/off element with no color component. 
Or, you could try changing your effects to ON effects with pure white as the color.  That should pass through the color filter.
Show a picture of your effect details

Also it might be how you are exporting the fseq file.  Show a picture of your Exporting screen.


I was having this exact same problem. I got mine working by deactivating the channels setup in output processes.

Because the output processes and the channel outputs had the same channel numbers the output processes overrode the output channels that drove the GPIO pins.

Once I deactivated the output processes every relay fired as it should on my test sequence.

Hope this helps!

Support FPP

+- Recent Topics

Changing FPP firmware by dkulp
Today at 06:20:26 PM

Intro to the Octoscroller by dkulp
Today at 04:41:13 AM

xCapture Playback Issues by dkulp
Today at 04:38:54 AM

UDP error by Poporacer
July 17, 2024, 07:19:13 PM

do I need license for my picap New? by Poporacer
July 15, 2024, 03:35:02 PM

Audio Issue with Pi Zero 2 W by robbiet
July 14, 2024, 12:07:12 PM

USB (and other) issues on Pi Zero 2w by zaicik
July 14, 2024, 04:20:33 AM

Multiple text effects cause re-render by dkulp
July 13, 2024, 08:44:07 AM

FPP led Panel Troubleshooting. by Poporacer
July 12, 2024, 09:29:56 AM

output controller by JonD
July 12, 2024, 09:29:07 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod