News:

LATEST RELEASE:  FPP 6.1 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/6.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15299
Latest: Psonic
New This Month: 2
New This Week: 1
New Today: 1
Stats
Total Posts: 125123
Total Topics: 15247
Most Online Today: 78
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 1
Guests: 43
Total: 44

Ethernet issue

Started by ostberg77, December 12, 2021, 06:48:30 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

ostberg77

My F16V3 will not communicate to my computer the ethernet. It has in the past, just recently even, but now my computer just says identified Network. And running a network troubleshooter says there's an IP address issue. But it's the default IP.... A little help please

tbone321

We are going to need a little help from you.  What is the IP address of the F16 and what is the IP address of your PC.  Actually, we need the IP address, subnet mask and gateway address of both units to see what is happening.  It could be that the F16 has gone back to DHCP which would cause it to get a different address from your router or went to a default address if directly connected to your computer and there is no DHCP server to assign it one

Scouser10231

To back up tbone if you have an ip on your pc of 169.254.xxx.xxx then windows is most likely setting it and not your router. Bad things happen when you see that IP address. To find this type in  cmd into the run menu and type ipconfig into the command window and press enter.  It's typical to have what's called a class c network at home so the subnet mask is probably 254.255.255.0 this does not matter to much just as long as all your devices have the same subnet number.
The most typical way you get the error you describe if everything is pulling an IP address from your router is if you have 2 IP addressed the same on the network. This normally happens when your router is handing out IP addressed in a range say 192.168.1.1-255 and you manually set an IP address on a device in this range. So it's a matter of time till the router gives a device through dhcp (dynamic) the same ip as the one set manually (static).  If this is the case change the range on the router to something that makes sense. If you have 20 devices then 1-50 for example. And set your static devices to 51-255.  You can also make your router assign a static IP address to a device by using a MAC address.  This way everything is listed and maintained in your router.

Tbone I am in Charlotte. Spent some time at wake forest visiting the university.  Cool town.

ostberg77

I reset the network settings on my computer, and factory reset the controller. I put the default IP on the controller (192.168.1.50) and plugged it in the computer. I've tried several different cables. My computer just says "ETHERNET has incomplete IP address". I'm sure it's a hardware issue.
 Not how I was picturing my first Holiday season using pixels, and I have too many LEDs to throw it all out. So i'll have to try a different brand of controllers for next year and see how it goes.

tbone321

Are you directly connecting your computer to the F16?  Does your computer have a static address set on its Ethernet card along with a valid subnet mask.  Did you set the IP address and subnet mask correctly on the F16?

ostberg77

I also tried it by setting the ip on the computer to static at 192.168.2.10 with the subnet mask 255.255.255.0 and the controller to static at 192.168.2.50, with the same mask. It still says unknown network and I can't access the controller.

JonD

Does your computer connect to the internet and other things okay?  The following info would be very helpful....

The IP/Subnet/Gateway of the Falcon controller and if you are trying to connect via copper ethernet wire or Wifi.  Is the Falcon getting a DHCP IP address or did you manually assign a static address to it.

The IP/Subnet/Gateway of the computer and if you are trying to connect via copper ethernet wire or Wifi.  Is the computer getting a DHCP IP address or did you manually assign a static address to it.

ostberg77

I GOT IT!!! Its a hardware issue....on my computer. I don't know what it in fact is, but I can get to everything using wifi on my PC with the controller plugged into the router. The Ethernet on my PC won't communicate with anything else anymore either. So....yea.
 Thank you all for your comments though!!!
 It's my first year, so i'll be back soon I imagine. Lol
steve

Scouser10231

I have seen that happen before on other devices. One thing that maybe happening is 2 devices that are directory connected need a crossover cable if they do not autodetect. The board may not autodetect.  If you put a switch between the two it solves that potential issue.
I have also seen routers block traffic if the IPs are assigned manually yet the exact same thing through dhcp works.
I did a lot of research on the boards and the falcon seems about the best.  So keep chugging away and I am sure I will see you in here over the next year lol.

Support FPP

+- Recent Topics

new piCaps in the works? by james-s
Today at 01:39:26 PM

Smartthings Integrations by james-s
Today at 01:26:22 PM

PiCap w/Controller? by james-s
Today at 01:13:37 PM

F16V4 port 5 Lights flicker by Martin Lamers
Today at 10:59:19 AM

Advatek Vortex 48 channel DC controller by CeP
Today at 05:34:34 AM

Upgraded to FPP V6.1.1 - Network Settings do not have "Interface Routing" option by Poporacer
October 01, 2022, 10:24:15 PM

FS Kulp K-8B Controller, Complete by poolprousa
October 01, 2022, 08:31:43 PM

60+ Ray Wu Cables, Pigtails, misc by jnealand
October 01, 2022, 08:57:49 AM

Sequence issues from Rasberry pi by Poporacer
October 01, 2022, 07:49:10 AM

New K4-PB wifi problems by fauxton
September 30, 2022, 07:19:15 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod