News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15305
Latest: PBAH89
New This Month: 8
New This Week: 6
New Today: 2
Stats
Total Posts: 125207
Total Topics: 15261
Most Online Today: 54
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 1
Guests: 34
Total: 35

Odd MultiSync behavior on FPP v6.0.2

Started by cscott126, August 06, 2022, 05:45:02 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

cscott126

Did a clean install of FPP v6 on a Kulp K40D-PB and Kulp K16A-B.  The K40-PB is the master and the K16A-B is the remote.  Both were upgraded to FPP v6.0.2.  Whenever I run a sequence on the master, there is noticeable slowdown or hesitation at times even in the audio while things sync up.  This occurs if I sync via WiFi or wired connection.  I'm in unicast mode.  Is this behavior inherent to unicast?  Am I going to be forced to use broadcast?  I've got a Ubiquiti router and access points.  I've created an SSID just for my show and limited it to a single AP, but it's still on the same subnet as the rest of my home network.  I thought by forcing the syncs across a wired connection between the two devices, there wouldn't be any chance of latency, but the behavior was identical.

Any ideas or comments related to this are welcome.

Thank you.

darylc

Best practice is to run audio from the master rather than from a remote to avoid such challenges.  Even better practice is to run your master from something faster than a beaglebone as the hardware is fairly slow compared to newer PI's etc.

cscott126

All audio is on the master.  I can hear the audio slow and stutter while visibly seeing the lights stutter too.

CaptainMurdoch

Are you running off the EMMC or the SD card.  Have you tried a different SD card or is this the same one you were using for FPP v5.x?

What happens if you play a sequence-only playlist?  Do the lights stutter when there isn't any audio playing?  How about an audio-only playlist?  Does the audio stutter?  When playing lights synced to music, the music is the base time and the sequence playback speed is adjusted to play in sync with the audio, so if the audio is having a problem playing, it could cause the lights to stutter.
-
Chris

cscott126

Quote from: CaptainMurdoch on August 06, 2022, 08:59:25 PMAre you running off the EMMC or the SD card.  Have you tried a different SD card or is this the same one you were using for FPP v5.x?

What happens if you play a sequence-only playlist?  Do the lights stutter when there isn't any audio playing?  How about an audio-only playlist?  Does the audio stutter?  When playing lights synced to music, the music is the base time and the sequence playback speed is adjusted to play in sync with the audio, so if the audio is having a problem playing, it could cause the lights to stutter.
I'm running on the SD cards.  Now that you mention it, these are different SD cards from what I was running for FPP v5.  I'll grab those original cards and install FPP v6 on them tomorrow and see if that makes a difference.  Thanks.

cscott126

In addition to the odd MultiSync behavior I was seeing, I was also witnessing weak wifi.  So I clean installed FPP v5.5 on the original SD cards, and now everything is perfect again.  No stuttering audio or sequence, and the wifi signal is showing full green bars instead of barely a single orange dot.

bloojoop

The metric used to display the wifi signal is reported differently by different wifi adapter drivers.  There is a series of adapters that used a metric that made it show full strength in 5.5 but that very same metric shows low strength in fpp 6.x... this has been discussed with the Devs and a better metric will be used that more accurately reports proper wifi link quality.  It should be released in a future update.
--Ron A.

Support FPP

+- Recent Topics

DIY voucher request by tfmacz
October 05, 2022, 11:51:31 PM

Pi Hat EEPROM by tfmacz
October 05, 2022, 10:11:44 PM

Sensor does not appear in status bar by JonD
October 05, 2022, 08:59:52 PM

Unable to reconnect to BBB after network config by Stoshx
October 05, 2022, 08:52:22 PM

For Sale - 1.0x 4-String Differential SmartReceiver Boards by JonD
October 05, 2022, 05:57:47 PM

New K4-PB wifi problems by ybjr38@yahoo.com
October 05, 2022, 05:19:28 PM

f4v2 and diff expansion board by JonD
October 05, 2022, 05:16:06 PM

Trigger media or playlist from incoming artnet/sACN by info@trans-mission.tv
October 05, 2022, 12:39:02 PM

FPP Advanced Features Key has been used. by tfmacz
October 05, 2022, 12:17:47 PM

Written documentation for Differential Receivers v2.01 by JonD
October 05, 2022, 09:04:50 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod