News:

LATEST RELEASE:  FPP 6.1 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/6.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15504
Latest: Nicolarockarola
New This Month: 12
New This Week: 4
New Today: 4
Stats
Total Posts: 127157
Total Topics: 15599
Most Online Today: 50
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 1
Guests: 42
Total: 43

PiCap Slow DMX output?

Started by robj2022, August 13, 2022, 11:42:27 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

robj2022


Falcon PiCap to DMX is very slow output. 

Testing with a Falcon V4 works great. PiCap doesn't.  I'm using the same cables in both setups, no wifi involved.

xlights on PC, Output to Lights -> Falcon V4->DMX pixel changes instantly
xlights on PC, Output to Lights -> Falcon PiCap->DMX pixel changes after about 2-3 seconds.

PiCap running on a Raspberry Pi3, FPP version 6.0.2-8-g8bc1f372FPP in Player mode
Channel input enabled, 1 input active, E131, unicast, FPP Channel start 1, end 510, universe 1, universe count 1, universe size 510
Channel outputs: other, active DMX-Open, start channel 1, Chanel count 16, Desc blank, Port ttyAMA0

PiCap works, sending the right pixel color, it just is tremendously slow to update, and rapid changes are lost in the time lag.Am I in a wrong mode or missing an important step?

CaptainMurdoch

Do the DMX pixels change properly when you run a sequence?  I believe that xLights changes some settings in FPP when you turn on (or off) Output to Lights, so that could be what is causing the delay. 

Are you saying pixels are always delayed when xLights is sending through FPP out the DMX port?  There should not be any delay.  I would also use the Channel Tester page in FPP to see how quickly the DMX pixels respond when you change the settings on the test page.  There will be a slight lag as the new test data is setup, but it isn't anywhere near 2-3 seconds.
-
Chris

JerryPlak

something to try..
on the FPP setting add the check mark to the "Always transmit channel data"
to see if helps
Jerry Plak

bloojoop

If it is just when you start the test, make sure "Auto upload configuration" is NOT checked.  That is the setting that Chris was referring to just above.  It is generally recommended not to have that setting checked. 
--Ron A.

Support FPP

+- Recent Topics

BRP Voting Plugin - Allow others to vote for your songs! by Barkers Random Projects
December 03, 2022, 11:55:24 PM

loading playlist by rangerdan
December 03, 2022, 11:54:31 PM

BBB running 3-4 seconds ahead by MATTS
December 03, 2022, 09:41:41 PM

Remote Pi connection issues by JonD
December 03, 2022, 08:51:55 PM

FPP not releasing control to WLED when idle by cabrio
December 03, 2022, 08:24:43 PM

Setting up new Falcon f16v4 noob question by Scouser10231
December 03, 2022, 03:45:54 PM

Sequence freeze by jnealand
December 03, 2022, 02:51:04 PM

Raspberry PI 4 won't connect to WIFI by jnealand
December 03, 2022, 02:46:23 PM

new piCaps in the works? by jnealand
December 03, 2022, 02:38:26 PM

FPP 6.2 Video Issue by ppanelli3
December 03, 2022, 12:04:54 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod