News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15484
Latest: MrCreed
New This Month: 106
New This Week: 20
New Today: 6
Stats
Total Posts: 126948
Total Topics: 15568
Most Online Today: 108
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 8
Guests: 59
Total: 67

PiCap Slow DMX output?

Started by robj2022, August 13, 2022, 11:42:27 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

robj2022


Falcon PiCap to DMX is very slow output. 

Testing with a Falcon V4 works great. PiCap doesn't.  I'm using the same cables in both setups, no wifi involved.

xlights on PC, Output to Lights -> Falcon V4->DMX pixel changes instantly
xlights on PC, Output to Lights -> Falcon PiCap->DMX pixel changes after about 2-3 seconds.

PiCap running on a Raspberry Pi3, FPP version 6.0.2-8-g8bc1f372FPP in Player mode
Channel input enabled, 1 input active, E131, unicast, FPP Channel start 1, end 510, universe 1, universe count 1, universe size 510
Channel outputs: other, active DMX-Open, start channel 1, Chanel count 16, Desc blank, Port ttyAMA0

PiCap works, sending the right pixel color, it just is tremendously slow to update, and rapid changes are lost in the time lag.Am I in a wrong mode or missing an important step?

CaptainMurdoch

Do the DMX pixels change properly when you run a sequence?  I believe that xLights changes some settings in FPP when you turn on (or off) Output to Lights, so that could be what is causing the delay. 

Are you saying pixels are always delayed when xLights is sending through FPP out the DMX port?  There should not be any delay.  I would also use the Channel Tester page in FPP to see how quickly the DMX pixels respond when you change the settings on the test page.  There will be a slight lag as the new test data is setup, but it isn't anywhere near 2-3 seconds.
-
Chris

JerryPlak

something to try..
on the FPP setting add the check mark to the "Always transmit channel data"
to see if helps
Jerry Plak

bloojoop

If it is just when you start the test, make sure "Auto upload configuration" is NOT checked.  That is the setting that Chris was referring to just above.  It is generally recommended not to have that setting checked. 
--Ron A.

Support FPP

+- Recent Topics

FPP Settings dropdowns not populating by jacksonho
Today at 03:20:26 PM

USB Wifi Adapter by jem5136
Today at 02:15:45 PM

FPP 6.x Matrix Issues by cmndr brain
Today at 01:41:55 PM

String ports question by Santacarl
Today at 12:42:38 PM

new piCaps in the works? by Bwinter
Today at 11:19:14 AM

Does FPP include an operating NTP server? by Aaron Maue
Today at 11:10:03 AM

Audio Stalls on 8th music sequence by clark
Today at 10:59:04 AM

Warning in Check Sequence about render caching by JonB256
Today at 09:09:47 AM

Uploading Models to FPP Remote by jnealand
Today at 07:46:08 AM

Audio issues by dkulp
Today at 07:29:34 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod