News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15512
Latest: bfrisan
New This Month: 20
New This Week: 8
New Today: 8
Stats
Total Posts: 127205
Total Topics: 15614
Most Online Today: 71
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 5
Guests: 17
Total: 22

Falcon 4 String Smart Differential Receiver not working as expected

Started by MitchellRGB, October 06, 2022, 11:13:25 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

MitchellRGB

Hello.  I am hoping someone might have an idea of what I can try next to solve my issue. I have a K8-PB running FPP v5.3.1 and 2 Falcon 4 String Smart Differential Receiver Boards v2.01 Black. I am not sure if I have the smart receivers configured correctly or if perhaps something else in FPP is not configured correctly. If I press the Test button on both Smart Receivers, all pixels respond and work as expected. When I send commands from FPP to the smart receivers, only 9A and 12A work correctly. The pixels on 10A, 11A, 9B, 10B, and 11B flash and flicker or do not receive commands (they stay white). At first, I thought it was bad wiring or a voltage issue. To test this I plugged the pixels that were not working correctly (10A, 11A, 9B, 10B, and 11B) into the ports that were working correctly (9A and 12A) one at a time, and all the strings worked as expected when plugged into 9A or 12A when receiving commands through FPP. This leads me to believe I have something configured wrong. Maybe in FPP or the smart receivers? Any help is appreciated, I am not sure where to go from here.

Smart Receivers
You cannot view this attachment.
FPP Channel Outputs for Smart Receivers
You cannot view this attachment.

darylc

Try replacing the network cables, each port on the receivers corresponds to a pair in the cable.

bloojoop

The new black v2.01 receivers have a different processor on them and responds to the timing signals differently when daisy chaining boards... Specifically any board other than A boards likely will not respond as expected.  I noted that you said you had flickering on the A board too but that may be different issue??? anyway, to use the new v2.01 black boards, you will need to be on an up to date version of fpp where the timing signals were adjusted to account for the new boards.  I recommend 6.1.1 at this time. 
--Ron A.

MitchellRGB

Quote from: bloojoop on October 07, 2022, 01:37:51 AMThe new black v2.01 receivers have a different processor on them and responds to the timing signals differently when daisy chaining boards... Specifically any board other than A boards likely will not respond as expected.  I noted that you said you had flickering on the A board too but that may be different issue??? anyway, to use the new v2.01 black boards, you will need to be on an up to date version of fpp where the timing signals were adjusted to account for the new boards.  I recommend 6.1.1 at this time.
Thanks, I didn't update FPP because the lights were not working, but I will do that now. Is A board the first board in the chain or just which board is set to A?

JonD

With the Falcon's it does not matter which order they are in.  You can chain them ABCDEF or FEDCBA, It only matters that you do not have two boards in the same chain set to the same letter.  Only the last one in the chain should be terminated, regardless of what letter it is set to.  Any SR located behind the first termination will not get any data.  Suspect it would be the same with the black ones, but don't know that for certain.

MitchellRGB

Quote from: darylc on October 07, 2022, 12:54:35 AMTry replacing the network cables, each port on the receivers corresponds to a pair in the cable.
This fixed it. I goofed on one end of a patch cable I made.

Support FPP

+- Recent Topics

INK1003 strips not playing nice with F16V4 by battle79
Today at 03:13:41 AM

FPP Playlist by LedMutt
Today at 02:29:01 AM

FPP install script on Ubuntu, no video by darylc
Today at 01:37:05 AM

f16v4 wont play in Player or Master Mode by Oxytousc
December 04, 2022, 10:33:43 PM

K8-PB Network Issue by Kensington Graves
December 04, 2022, 10:21:18 PM

New to FPP6.2 - Interface issue, I think? by Poporacer
December 04, 2022, 09:54:45 PM

FPP not releasing control to WLED when idle by cwr89
December 04, 2022, 09:20:43 PM

K8-B-Scroller needs updated EEPROM Signature? by jdbeavers
December 04, 2022, 06:32:25 PM

BBB running 3-4 seconds ahead by MATTS
December 04, 2022, 05:56:59 PM

FPP 6.2 ColorLight Issues by dennismccreery
December 04, 2022, 05:52:32 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod