Server migration complete, Welcome to version 2.1.1



Welcome, Guest.
Please login or register.
Forgot your password?

+-Site Stats

Total Members: 16482
Latest: nfalzone81
New This Month: 14
New This Week: 2
New Today: 1
Total Posts: 132768
Total Topics: 16481
Most Online Today: 120
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 0
Guests: 74
Total: 74

K8-PB Network Issue

Started by Kensington Graves, December 04, 2022, 10:21:18 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Kensington Graves

Yesterday one of my K8-PBs was working just fine.  This K8 is a couple years old--not the newer version Dan mentioned in another thread.  Today I got an "abnormal conditions" and something about strings not being able to be initiated.  Since we had a lot of rain last night, I figured it had something to do with that.  But after a couple reboots it did not resolve.  Since it was running v5.4.1, I decided that I might as well upgrade it.  At this point, I had WiFi access to the K8-PB with no problems.

I re-imaged and rebooted into v6.2 while tethered through USB.  I completed the setup as usual and rebooted.  When I went to modify the network settings, no interface populated the dropdown box--neither wlan0 nor eth0 showed up.  My working WiFi dongle was plugged into the USB port on the cape.  No problem, I thought.  Just add a boot delay.  I added a 15 second delay and rebooted.  Still no wlan0 interface.  So I tried it with an ethernet dongle attached to the cape.  No eth0 interface showed up.

I also activated WiFi tethering but did not find the FPP network.  I have tried all the above steps with the K8-PB powered only by the USB port, and I've tried it with the cape separately powered.  No matter what I do, neither network interface appears.

Both the WiFi and Ethernet dongles are "known-good".  The are recognized and work when I plug them into another computer.  And the WiFi dongle was working just fine before I upgraded--that's what's really puzzling.  I had no issues with the WiFi before the upgrade.

I've attached a screenshot of the Network Setup page.  Any ideas on where I'm going wrong?

Kensington Graves


I downgraded to v5.5.  No change.

I also got into the shell and looked for USB devices.  lsusb does not show the WiFi dongle or the ethernet dongle.  Both normally show up on bus 002 device 002.  lshw -C network returns two devices, but they are obviously the tethering interfaces as the IP addresses are and

I'm wondering if the USB IC for the on-cape USB port is blown or the voltage regulator is blown.  Next step is the multimeter, I suppose.


How did you downgrade? If you did it via FPP I do not believe that it downgrades the OS, it leaves the new version of the OS which some of the drivers do not support some of the old WIFI or ethernet dongles. Also try changing the WIFI driver from external to internal on the WIFI page.
Using K8-B, Rpi 3b w/PiHat, Rpi 3b+ w/ PiHat, K4-PB

Kensington Graves

I reformatted the card and re-imaged with v5.5.  I'll try the kernel drivers, too.

Kensington Graves

Changed to kernel drivers and I still have no network.  I also swapped it out for another known-good, but newer, WiFi dongle to no effect.


Do you have an FM Transmitter nearby? What are you using for your power source? USB Devices are the first thing to get throttled when there is a lack of power.
If to err is human, I am more human than most people.

Kensington Graves

The FM transmitter is in the garage about 50 feet away.  The controller is powered by a fused connection to a 12v Meanwell in the same CG-1500 enclosure.  The cape is set to 12v power.   When tethered, the cape is powered only by the USB from my computer.  I'm running fewer than 800 pixels off the box.

I have a USB multimeter showing us today so that I can test the USB port.  I wasn't having much success using probes on my regular multimeter.

I suppose I could also use a powered USB hub while tethered and see if that has any effect.  I could also change out the uSD card for a new one.  I'll post the results of the multimeter test.  Until that possibility is eliminated, it doesn't make sense to try to run down more exotic issues.

As I recall, though, the cape's USB port was bent a little on arrival, but the solder joints were all in good shape.  I don't think it's mechanical.  Really odd that it just started happening after the upgrade.

Kensington Graves

I tested the cape's USB port with a USB multimeter.  When tethered, I get 4.91v and 0amps.  When the cape is not tethered, there no power to the cape's USB port at all (USB multimeter doesn't even power up), but the PocketBeagle powers up and runs FPP.  Also, when not tethered, the PocketBeagle's micro USB port does not have power (don't know if this is intended, but it would make sense that there's a diode so where preventing backflow from that port).

So it would appear that I have a hardware problem.  Any disagreement with that conclusion?

Support FPP

+- Recent Topics

Sequences with audio crashing FPP at random by robbiet
July 23, 2024, 08:10:05 PM

Audio Issue with Pi Zero 2 W by robbiet
July 23, 2024, 08:45:43 AM

Changing FPP firmware by dkulp
July 19, 2024, 06:20:26 PM

Intro to the Octoscroller by dkulp
July 19, 2024, 04:41:13 AM

xCapture Playback Issues by dkulp
July 19, 2024, 04:38:54 AM

UDP error by Poporacer
July 17, 2024, 07:19:13 PM

do I need license for my picap New? by Poporacer
July 15, 2024, 03:35:02 PM

USB (and other) issues on Pi Zero 2w by zaicik
July 14, 2024, 04:20:33 AM

Multiple text effects cause re-render by dkulp
July 13, 2024, 08:44:07 AM

FPP led Panel Troubleshooting. by Poporacer
July 12, 2024, 09:29:56 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod