News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 16426
Latest: Amishman
New This Month: 20
New This Week: 1
New Today: 0
Stats
Total Posts: 132332
Total Topics: 16404
Most Online Today: 97
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 2
Guests: 55
Total: 57

BBB and new K8B - lack of pixel lighting

Started by pyro2k, November 23, 2023, 09:16:02 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

pyro2k

Hello I have been running a beagle bone black with a sandevices controller for several years and I decided to add in a kulp k8b this year for more capacity. I have upgraded to the latest version of falcon player and the k8b shows up as an output device in falcon player and powers up fine with the power lines directly going into the k8b. All in all everything works as expected from a connectivity standpoint.

The only issue that I am running into is that I cannot get pixels attached to the k8b to light up in test mode. I have tried the test mode through falcon player and the test mode through the k8b controller page. I also tried to the test button on the board and that didn't work either. I have a string of 10 5v bullet pixels hooked up and 1 strip 5v pixel hooked up. Neither of these will light up in either test mode. I also tried to run a sample sequence through xlights and that didn't work either.

I Have also swapped the pixels with an espixelstick and they work fine. Once I put the pixels on the k8b nothing lights up.

If I go into test mode on the falcon player UI then the sandevices pixels and the espixelstick pixels both light up fine with the same pixels attached.

I feel like I am missing something trivial or this board is defective by the process of elimination.

JonD

It sounds like you do not have the Channel outputs setup correctly.  There are lots of ways to configure the lights.  You should attach print screens of the xlights controller settings, FPP\Input/Output Setup\Channel Inputs and FPP\Input/Output Setup\Channel Outputs screens, so we can see how you have it setup.

Are letting xlights configure the controllers or doing it manually?  Are you using multisync or player mode?  You might just need to use the xlights "FPP connect" feature in xlights, and make sure "UDP Outputs" is set to "All" to upload the correct channel information to the FPP.

pyro2k

I adjusted my channel settings so that there are no overlaps and I am now able to get pixels to light up in test mode through the kulp controller and the other 2 controllers which is good progress. I am seeing a time gap in color changes across the 3 controllers so I may need to do some more adjustments.

Thanks so much for getting me to step #1 out of 10! If I can get things to light up off the controller then I can make significantly more progress.

Support FPP

+- Recent Topics

MQTT with Home Assistant, model control only lights up some pixels. by CaptainMurdoch
Today at 01:30:45 PM

F32v5 Release Date by JonD
Today at 12:51:23 PM

Looking for a way to "fast forward" a video playlist by Jayl
April 18, 2024, 03:20:31 PM

P9-28 and P9-29 not work by windaube
April 15, 2024, 03:40:34 PM

Resetting or Removing FPP Password (with Windows) by greenreader9
April 14, 2024, 06:21:46 PM

Enclosure for Video Projectors by Scott
April 14, 2024, 12:00:50 PM

Born in the USA by Xmas!
April 13, 2024, 03:25:16 PM

1200w HP Power Supplies by MikeKrebs
April 12, 2024, 08:53:19 PM

Colorlight card not responding to FPP by CaptainMurdoch
April 12, 2024, 09:21:54 AM

FPP and WS2812b not work, but work with python script by CaptainMurdoch
April 11, 2024, 03:34:17 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod