News:

LATEST RELEASE:  FPP 6.1 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/6.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15290
Latest: eatumup
New This Month: 36
New This Week: 5
New Today: 3
Stats
Total Posts: 125007
Total Topics: 15226
Most Online Today: 89
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 7
Guests: 54
Total: 61

FPP 6.0 Released!

Started by dkulp, July 26, 2022, 05:53:40 PM

Previous topic - Next topic

amtrak115 and 1 Guest are viewing this topic.

rmorgan62

Thank you Jim!
I would agree except I would think the drop down should show the default audio device selection regardless of if the soundblaster is good or bad?
But to make sure I explored this as a possibility, I had a brand-new USB Sound Blaster that I tried, same result.
I tried all of the USB ports, same result.
I tried without a sound blaster at all, same results (I would have thought the default device would show up)
I should mention that I shutdown and rebooted for each test.

Sawdust

#16
I lean with Jim....the Sound Blaster seems to be driving a conflict.  Have you tried a clean new image without any accessories attached?  This should give you the PI 4 audio as default.  I reimaged a Pi2, 3 & 4 last night.  All showed the drop down for Pi BMC Device as expected.

Note: do not boot with any accessories (except ethernet rj45) until you view settings
 

Poporacer

Do you have an FM Transmitter nearby? Many are known to cause interference. If so, unplug the Transmitter from power, unplug the SoundBlaster then reboot the Pi. Post a Screenshot of your Audio Page again and also the results of the Help>Troubleshooting commands Sound Card section.
If to err is human, I am more human than most people.

rmorgan62

Follow up post: Yes, I have an FM transmitter near the player and remotes.  I moved it, turned it off and unplugged it.  No change.
I did a fresh, re-image using 6.0 and did not plug up anything except the power.  No Change (The default sound device does not show)
I upgraded that to 6.1 - No change
I pulled my 6.1 cards out and put them on a shelf.
I took 3 new cards and installed 5.5.  I hooked up the sound blaster, turned on the transmitter and put it back in its original location.
All sound options show up just fine on 5.5-24
I am going to set the show up to run on 5.5-24 and then once it is ready, I am going back to continue troubleshooting 6.1.
I feel like there is some issue with the 6.0 image I downloaded so I am going to download a later image once they are released and see if the issue is fixed.

JonB256

From the "new features" list:

Other updates/changes
Crash Reporting - HOPEFULLY you won't experience this. However, if FPP crashes, it should produce a crash report on a new "Crash Reports" tab in the file manager. If you see these, please let us know.

I do have a crash report but it isn't clear "where" to send it. It clearly shows a Download button but should it have a "Send" button? I did the "Drag and Drop" as shown but it isn't clear what happened when I did that. (i.e., Did it go to the right place?)

I have a 3B+ that has generated two Crash Reports now. It was updated using PPOS, not a full wipe/install.
Long time Falcon, FPP and xLights user

Poporacer

Quote from: JonB256 on August 01, 2022, 06:16:15 AMI do have a crash report but it isn't clear "where" to send it.
When you first installed FPP, you had an initial setup page and there was an option to automatically send the reports and what portion of the reports you wanted to send.

Quote from: JonB256 on August 01, 2022, 06:16:15 AMIt clearly shows a Download button but should it have a "Send" button?
The Download Button will download the Crash log to your local computer. There is no "Send" button because if you didn't elect to send automatically, then you will need to post your problem in a forum or in a GitHub issue with the Log. If there were a "Send" button, I am sure there would be some people that would send the log repeatedly and only create more work for the developers.

Quote from: JonB256 on August 01, 2022, 06:16:15 AMI did the "Drag and Drop" as shown but it isn't clear what happened when I did that.
The "Drag and Drop" is on every tab of the File Manager and is used as a portal to upload files from your local computer to your FPP Device so it probably did nothing.

Quote from: JonB256 on August 01, 2022, 06:16:15 AMDid it go to the right place?
Only if you wanted it to stay on your FPP.

Quote from: JonB256 on August 01, 2022, 06:16:15 AMI have a 3B+ that has generated two Crash Reports now. It was updated using PPOS, not a full wipe/install.
Can you attach the logs to your reply along with an explanation of what you were doing when the crash happened?
Thanks
If to err is human, I am more human than most people.

JonB256

When you first installed FPP, you had an initial setup page and there was an option to automatically send the reports and what portion of the reports you wanted to send.

This FPP is set to share crash reports, so having a large red bar telling me it has created a Crash Report and "click here" to Send It makes me think it didn't actually send it.

As far as what it was doing to provide with the crash report? It occurred overnight and was doing nothing. No schedules, no playlist.
Long time Falcon, FPP and xLights user

Poporacer

Quote from: JonB256 on August 01, 2022, 10:29:04 AMso having a large red bar telling me it has created a Crash Report and "click here" to Send It makes me think it didn't actually send it.
I didn't know that it would give you a Message banner, So maybe it doesn't automatically send the report???

Quote from: JonB256 on August 01, 2022, 10:29:04 AMAs far as what it was doing to provide with the crash report? It occurred overnight and was doing nothing. No schedules, no playlist.
Attach your report(s) and maybe someone here can look through it.
If to err is human, I am more human than most people.

JonB256

This is from a RasPi 3B+ v6.0.1. I use it as my show master with a SB3 connected to an EDM FM transmitter. It literally does nothing except sent Sync packets and audio. No outputs.You cannot see attachments on this board.
Long time Falcon, FPP and xLights user

FireInst12

Did you set the FPPD Start delay under system on the Status/Control menu? If I remember correctly, I had the same problem last year. A 30 sec delay fixed the problem.

Tim 

JonB256

Had another crash report. Since it had the same exact time (8:00 pm) as the last one, I checked my Schedule.
In my scheduler, had an event (Brightness) set for 8:01pm.  I have deleted it and will see if it recurs.
The Brightness plugin was/is up to date.
This schedule event has been running for over a month (under Master Branch updates) but didn't start causing errors until I did the PPOS update to 6.0 and 6.0.1

Here is the report:
You cannot see attachments on this board.
Long time Falcon, FPP and xLights user

dkulp

Quote from: JonB256 on August 02, 2022, 07:34:20 AMHad another crash report. Since it had the same exact time (8:00 pm) as the last one, I checked my Schedule.
In my scheduler, had an event (Brightness) set for 8:01pm.  I have deleted it and will see if it recurs.
The Brightness plugin was/is up to date.
This schedule event has been running for over a month (under Master Branch updates) but didn't start causing errors until I did the PPOS update to 6.0 and 6.0.1

Can you try updating to 6.0.2 now?  The crash log is "strange" and not entirely useful, but a couple things have been fixed in a related area from other crash logs so it might be working now.

That said, can I ask why you put the brightness commands in playlists and scheduled the playlists instead of just scheduling the FPP commands directly?   Playlist would interrupt other playlists when they trigger, but FPP commands would not.   Just a curiosity question.  
Daniel Kulp - https://kulplights.com

JonB256

Quote from: dkulp on August 03, 2022, 09:17:49 AMThat said, can I ask why you put the brightness commands in playlists and scheduled the playlists instead of just scheduling the FPP commands directly?   Playlist would interrupt other playlists when they trigger, but FPP commands would not.   Just a curiosity question. 

It was an experiment in different ways. Didn't seem to work, though, since as you noticed, it would interrupt other playlists. I just forgot to kill it and then forgot it was still running.

I'm just now updated to 6.0.2 and will let you know.
Long time Falcon, FPP and xLights user

virgil1

I am having the same problem. Tried 6.  Tried 6.02.  Tried with my backup config, tried without it.  It doesn't see the USB Soundblaster.  Went back to my old SD card with v4.6.1, works fine.  Raspberry Pi 3B+.
Paul

virgil1

Quote from: virgil1 on August 16, 2022, 03:41:15 PMI am having the same problem. Tried 6.  Tried 6.02.  Tried with my backup config, tried without it.  It doesn't see the USB Soundblaster.  Went back to my old SD card with v4.6.1, works fine.  Raspberry Pi 3B+.
Paul

Trying 5.5 now.  Will post updates.  Forgot to mention I have a piCap, and a Soundblaster 3 USB.

Support FPP

+- Recent Topics

K16a-b FPP setup by dkulp
Today at 06:15:18 AM

OrangePi 3 LTS wifi by ctmal
September 25, 2022, 05:27:37 PM

Pi Top on sale by CeP
September 25, 2022, 04:26:29 PM

no Lights by Poporacer
September 24, 2022, 06:47:12 PM

exceding 24000 starting channels by Poporacer
September 24, 2022, 05:53:25 PM

No signs of life, help by JonD
September 24, 2022, 02:44:30 PM

Sequencing timing... by Atljim965
September 24, 2022, 10:22:25 AM

OLED Screen Not Coming On by jja0607
September 23, 2022, 06:34:51 PM

How to connect a button (via GPIO) to a K16A-B by pierlux
September 23, 2022, 05:44:49 PM

Background Image (House) Not Visible In XLights by dkulp
September 23, 2022, 12:41:52 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod