LATEST RELEASE:  FPP 7.5 - Download from here -



Welcome, Guest.
Please login or register.
Forgot your password?

+-Site Stats

Total Members: 16465
Latest: Mikeyg505
New This Month: 15
New This Week: 2
New Today: 2
Total Posts: 132627
Total Topics: 16452
Most Online Today: 185
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 3
Guests: 127
Total: 130

Warning/Error: Network incomplete frames hit 250.

Started by nmbgeek, November 26, 2022, 03:39:44 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Receiving this on the web interface:  
QuoteNetwork incomplete frames hit 250. Network or configuration issue is likely.
My network setup is as follows: PFSense Firewall > Cisco 48 Port Gigabit PoE Switch > Falcon F16v4 > FPP on RaspberryPi.  Everything is wired with CAT6 and all devices have statically assigned DHCP addresses (devices are set to DHCP and router hands out the static IP) and they are working as expected.

I also have an ESP32-POE connected to the Gigabit switch for permanently installed roof outline.  It is also receiving data from FPP and working as expected. Lights seem to be functioning as desired but I do notice some 'jumps' in my show.  Never saw this message last year but I did update firmware when I pulled everything out this year.  The message does stop when a show is not playing.

Any advice or troubleshooting suggestions?


I had that problem on firmware version 21.  Downgraded to version 20 and it fixed it.


Thanks for that info. I may try downgrading tomorrow then. 


I just logged into the controller and it is still getting the error... just not as bad.   Noticed some lag on fast sequences when on 21, but have not noticed anything since downgrading.  I may have the same issue as you though.



Newbie here.  I'm having the same issue and I am only running two props.  I don't see it affecting the show, does anyone know if will damage the controller?

Another question and I apologize, my computer skills are lacking.  But when you say you downgrade the firmware, are you talking about the firmware for the FPP?

Thanks for any help in advance.


Same problem here. I have been running build 21 on my Falcon F48V4 since Dec 4th without this error. The error started showing up yesterday (Dec 30th). It comes and goes, but does not appear to affect my displays.


To me that is just a warning that your show is having some issues getting all the data out.  And it has happened 250 times or more.  I would be checking all my connections for being loose or for corrosion as a place to start.  Just dmy 2 cents.
Jim Nealand
Kennesaw, GA all Falcon controllers, all 12v Master Remote Multisync with Pi and BBB P10 and P5


Thanks Jim. It really helps me if I know what the error means. I think I found the problem.

All of my equipment (network and pixel controllers) is in my garage and located within a few feet of each other.

I had another issue which I never was able to figure out with my Falcon Pi Player. It would only work when plugged into the Falcon Controller's ethernet pass-thru port, not my switch (tried different cables). The guys on the Xlights Zoom Room reviewed my configuration, but I still couldn't get it to work. Not a big problem so I left it connected to the F48V4.

While trying to fix the  "Network incomplete frames hit 250" I discovered that one of my ethernet switches was a hub, not a switch, and my show ethernet switch was being fed by a ethernet hub instead of a switch. I switched the hub out to a switch and both problems have gone away.

Thanks for your help. Happy new year!


I am having this same issue, but with the new F48v4NS controller.  The build on the controller is Build 23, which is not available from GitHub, so I am reluctant to downgrade my firmware version since, if it doesn't work, I can't restore it to its original condition.  I have checked all my cabling, replaced my router with a switch and all the things mentioned in this post, but to no avail.  Any other folks have ideas on how to correct the error?

Thanks in advance.



If I recall correctly 23 was removed because of problems.  I would go back to 22 if you can.
Jim Nealand
Kennesaw, GA all Falcon controllers, all 12v Master Remote Multisync with Pi and BBB P10 and P5


Quote from: jnealand on February 05, 2023, 02:19:10 PMIf I recall correctly 23 was removed because of problems
That was for the regular F48V4, the NS one needs 23
If to err is human, I am more human than most people.


Build 23 is the first version to support the F48v4-NS, I don't it will let you downgrade.


Version 22 is the one you should delete and never use.  I still have the issue with my Mega tree controller having this error.  I can tell it is lagging on occasion, but it was really cold out when I noticed it and told my wife she can just refund anyone that complains about it. (We don't charge for people to watch the display ;))


Keith has suggested the above error is almost always when more than one device tries to send data to the F16v4 controller.  At least in my situation that is not the case.   I know others have had this same issue as well.  It does seem to happen when I have fast moving data on the mega tree.  It does not make the show unwatchable, but does seem to lag.  I had considered putting an SD card in the controller, but ended up just living with it.


I continue to have this issue on the F48v4NS controller.  I am trying to use ELM to pixel map content for an upcoming production of Frozen the Musical for my wife's High School.  I tried sACN and ArtNet as protocols and both yielded the error.  I tried to simplify the issue by only sending to a single 50 pixel strand on 1 universe and no other configured setup.  I removed multicast and only sent to the controller's hard coded IP.  However, I still get the error messages.  I don't see any noticeable issues right now, however, I also haven't had the chance to setup all my pixels and send full content, so I am concerned there may be issues in future.  Is there a way I can get deeper debugging information that may tell me why the error is occurring?  Any help would be appreciated.



Powered by EzPortal
Powered by SMFPacks Menu Editor Mod