Server migration complete, Welcome to version 2.1.1



Welcome, Guest.
Please login or register.
Forgot your password?

+-Site Stats

Total Members: 16480
Latest: tcooper
New This Month: 12
New This Week: 1
New Today: 0
Total Posts: 132747
Total Topics: 16480
Most Online Today: 86
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 2
Guests: 63
Total: 65

F4v3 Smart Recievers

Started by twooly, January 18, 2021, 09:43:07 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Ok getting back to this now that things are down and settled away.  Was trying to get this working for the season but never could so just fell back to a dumb receivers and ran an extra long line.

  • Running F4v3 in firmware 2.59
  • Smart Receivers are plugged into port 5-8 on the expansion
  • Smart Receivers are v1.00 with the jumpers for terminators and the ones that had the terminating issue David sent the extra board out for.

Strings all work, I've tested them on test mode in the 1-4 ports on the F4v3 itself and they work on the test mode on the smart receivers also when pushing the button into the various test modes on those.  When I enter test mode through the web interface to test each port by themselves to see if its working is where I get my issue.  Strings are all on port 1 on the receivers.

So here is board A.  Terminator jumpers are off and the switch is with 2 in the On. 
You cannot view this attachment.

here is board B.  Terminators jumpers are all 4 on switch is with the 1 in the On position and the extra terminator board is connected also.
You cannot view this attachment.
You cannot view this attachment.

You cannot view this attachment.

Test Mode.  Now with I select port 5 string 1 nothing happens.  I would expect board a port 1 to light but it doesn't.  Now if I select port 5 string 2.....board a string 1 lights and flickers bad when it lights.  I would have expected board b port 1 to light but it doesn't.  and just for giggles I select all....board b does nothing and a still has its bad flickering. 
You cannot view this attachment.

Any help would be appreciated on what I'm doing wrong.  Planning things out and would like to actually use these finally :)

Thanks in advance.


You only need to terminate with one device.  As version 1 had resistors too big for proper termination, I'd remove the jumpers on the second board and use only the add-on that David sent out.
Sequencers: Vixen3 and xLights
Players: FPP and xSchedule Controllers:  Renards - SS24/SS16; E1.31 - San Devices E682 - Falcon F16, F4, F48 - J1Sys - DIYLEDExpress E1.31 Bridges.  Much more!


Ok so no jumpers exist on either board and only the extra little terminator board is connected to Board b

Now Board A responds when on port 5 string 1.....but its still flashing pretty bad.  See the link for video.
Board B still does not respond.

For testing I tried new cables also, didn't help.


Ok little more testing and seems to happen no matter the direction I do it, meaning swapping boards a/b position just to see if it was maybe a board issue.  Seems to me like dirty data/board not passing information somewhere.  Dirty because board a doesn't know what do with the extra info and get lost/does the odd flashing and not passing because if 5a/5b are both configured it doesn't allow the data downstream to work.

So no matter what board/port board A will always do that crazy flashing and all ports will respond in the testing based on port I select.

Board b.  I can get working as long as that same port is not configured on board a.  For example from my screen shot.

7a....will flash like crazy if I enable test on that port.
5b....will work as expected
7b....will not respond/light up.
You cannot view this attachment.

7a....will flash like crazy if I enable test on that port.
6b....will work as expected
7b....will work as expected
You cannot view this attachment.


Sorry more to add, just trying to give as much information as possible.

The above testing was all done with all jumpers off both boards and just using the little extra terminator board on the b board.

Using them as "dumb" boards they all work ok as expected.


and more data.  Looking at on board one of the leds is off, don't remember it being this way when I first started this adventure.

You cannot view this attachment.
Its the third led from the top in the picture or second led closer to the power input.

Now why I think bad data is happening.  If i test on ports on board b (again ports are not configured on board a) even though I only have 5 pixels configured for each port, pixel 6 is halfway doing something.  In video its doing a colorwash on the first 5 pixels and pixel 6 is the one red.


Tried new cable still has that led off.  Looked at pins and they all look ok.  Ran a test they all responded still minus their flashing issue and extra pixel going on. 

After test now the top two leds are off (bottom two by the power input is on)


Ok just kept testing with the led off.  When I put the board as a single dumb board the leds all come on.  So I put it as board A and other as board b and now the led off is on the other board (third led).  Tried the other port on the expansion and still get the same thing led off.  Think the hardware is ok and leaning towards there is a data issue somewhere causing the issues I'm seeing.


I pulled out my f16v3 and gave it a run, same results using that also.  Flashing on board a...b fine and swapping around same for all, including the board b having a led out.


More to add.  Pulled out my Kulp K8-B.  Configured Board A and B......and it works perfect from that.  So its something from the F4v3 or F16v3 thats wrong and not sure what else to do/test.


Thought I would circle back around with this one.  I talked to David about the issue, even sent the boards to him.  He was thinking it was maybe just the pixels and their timing.  Turns out, there is a small issue that 99.9% of us will never see......if you set to 5 or less pixels it will do exactly what I was seeing.  As soon as I went about 5 all is good.  I was only using 5 because I was just testing and that was just spare pixels laying around......

Thanks David for the help.


Just had a similar issue myself. However all the LED's on the Differential Receiver boards are lighting as they should, it was just a problem with the actual pixels on the board outputs for me.

I changed over to Differential Receivers so I could add an extra (different voltage) PSU in an enclosure and run them both off one expansion port.

The 12v PSU runs a few WS2811 floodlights so I would only have one or two connected to each output. The board running the floodlights was set to 'b' and was last in the chain. There were pixels also connected to the 'a' board that worked as they should. Firmware is V2.59 on the F4V3.

Whatever I tried, the last flood in the chain was not showing the correct colours, mostly only the red lighting up. I checked all the settings in Xlights, the uploads to the F4V3, tested the CAT6 cables, voltage to the boards (5V PSU was set to 5.3V), and even the setting of the dip switches on the boards but nothing was sorting it out.

As it was always the last floodlight in a chain that had the problem I decided to try to add a ghost pixel in the Output Strings set up tab for the controller, so for two actual pixels (floodlights) I set the pixel count to three on that string output tab. And as if by magic, it works as expected now! I'm going to build a some single pixel ghost models into Xlights to add to the end of each set of floodlights so it uploads to the controller and keeps my channel numbers as they should be.

Funny enough I do not have to add any ghost pixels when using the same configuration of floodlights on my F48, it just seems to affect the F4V3.

I found your post after I had spent a couple of hours trying to resolve this, so thought I would post just in case this information is of help to anyone else having a similar problem. The common cause seems to be a low number of pixels on the output.

Support FPP

+- Recent Topics

Changing FPP firmware by CUC
Today at 04:20:33 AM

UDP error by Poporacer
July 17, 2024, 07:19:13 PM

do I need license for my picap New? by Poporacer
July 15, 2024, 03:35:02 PM

Audio Issue with Pi Zero 2 W by robbiet
July 14, 2024, 12:07:12 PM

USB (and other) issues on Pi Zero 2w by zaicik
July 14, 2024, 04:20:33 AM

Multiple text effects cause re-render by dkulp
July 13, 2024, 08:44:07 AM

FPP led Panel Troubleshooting. by Poporacer
July 12, 2024, 09:29:56 AM

output controller by JonD
July 12, 2024, 09:29:07 AM

Looking for SRx2 V5... by darylc
July 11, 2024, 05:54:34 PM

FPP 8.0 by colonelcline
July 11, 2024, 04:05:15 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod