News:

LATEST RELEASE:  FPP 7.5 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/7.5

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 16461
Latest: bredbk
New This Month: 11
New This Week: 2
New Today: 0
Stats
Total Posts: 132611
Total Topics: 16446
Most Online Today: 153
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 1
Guests: 129
Total: 130

FPP install script on Ubuntu, no video

Started by ee351, December 04, 2022, 09:20:31 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

ee351

Hi all,

I'm trying to get the HDMI port working on a dell wyse 3040 sbc with FPP.  I installed ubuntu server 22.04.1 LTS, followed by the FPP install script.  The fpp webserver comes up fine, with FPPD running.  However, I cannot get the video to output when playing an mp4 file.  All I see is a flicker on the screen with the terminal running.  

Is there something I can try to get video to work?  Another OS perhaps?

Thanks in advanced.

darylc

FPP is designed to be run on the supported platforms - pi/beaglebone etc.

If you run it on a PC under a linux install you're unknown territory, likely no-one has ever tested or written the support for virtual matrixes on PC's.

We would welcome a pull request to fix the issue to the fpp github repository.

dkulp

If you upgrade it to the latest master code that was committed to the repo yesterday, there is a better chance you could get it to work, but it may require some trial and error on the command line to find the right combination of flags for vlc.

If you turn on the Advanced UI, on the Video tab, and "Extra VLC Arguments"field would appear.   I would start by adding:

--kms-drm-chroma XR24

and see if that helps.   On a couple of devices I have, that's all that was needed.   Beyond that, try figuring out the dri card number and connector.   For one of my devices, I need:

--kms-device /dev/dri/card1 --kms-connector HDMI-A-1 --kms-drm-chroma XR24

to specify card1 (check the /dev/dri/ directory for cards) and the appropriate HDMI port.  
Daniel Kulp - https://kulplights.com

ee351

I added --kms-drm-chroma XR24 and now the screen goes black only when playing the video.  After the video is done, the terminal comes up.  The other settings had no effect, and this was after I changed the card1 to card0 (verified from the directory you provided).  Anything else I can try?  I feel like I'm close.

ee351

#4
Success!  I was able to get the video to play after I encoded the video file to match the native resolution of the HDMI port (1366 X 768 for this SBC).  No audio, but I'll keep playing with the settings to see if I can figure it out.

Also, is there any way to force the native resolution to 1080P?  This device is supposedly capable of 4k@30fps.  I tried force hdmi resolution under settings but this had no effect.

I'm also happy to report that a virtual matrix works with this setup, which was my end goal.  Trying different effects/videos and playback is smooth.

AlexanderMedia

The issue I had with the audio not working had to do with FPP not controlling the audio of the underlying OS.
I was able to easily set the volume in the CLI by running:
amixer sset 'Master' 100%
However, this was not kept through a reboot, so I setup the crontab to do this at boot.
I made a file in the media/scripts directory called set_volume.sh with the following:
#!/bin/bash
amixer sset 'Master' 100%

I set it to executable by running:
chmod u+x set_volume.sh

Then to get to crontab:
sudo crontab -e

I added a line at the bottom like this:
@reboot sh media/scripts/set_volume.sh

This sets the volume to 100% at start up.
It works for my testing, but I may see if I can get FPP to control the volume later.

Thanks

(Running FPP on Debian 11 on a cheap ASUS laptop)

Support FPP

+- Recent Topics

FPP 7.5 Virtual Matrix Overlay Sub Model State by wjenkins364
June 14, 2024, 11:04:59 PM

Did the the latest upgrade tonight and it failed. by k6ccc
June 14, 2024, 02:43:27 PM

Looking for specs on F4V2 (Red) by algerdes
June 13, 2024, 08:14:31 PM

F16v3 & Differential Cntrl Pwr Question by jeff.ott
June 13, 2024, 07:55:31 PM

No Audio by Steve
June 07, 2024, 02:10:47 PM

Video IP Capture -> sound by MikeKrebs
June 06, 2024, 09:00:17 PM

Control Channel Output by zj023
June 03, 2024, 06:23:35 AM

Compatibility question by John_82
June 02, 2024, 04:23:25 PM

Virtual Display not working? by colonelcline
June 01, 2024, 04:55:41 PM

Help for my LED Pit board project by Octonath
May 31, 2024, 06:15:17 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod