News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15290
Latest: eatumup
New This Month: 36
New This Week: 5
New Today: 4
Stats
Total Posts: 125007
Total Topics: 15226
Most Online Today: 89
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 7
Guests: 30
Total: 37

PiCap Slow DMX output?

Started by robj2022, August 13, 2022, 11:42:27 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

robj2022


Falcon PiCap to DMX is very slow output. 

Testing with a Falcon V4 works great. PiCap doesn't.  I'm using the same cables in both setups, no wifi involved.

xlights on PC, Output to Lights -> Falcon V4->DMX pixel changes instantly
xlights on PC, Output to Lights -> Falcon PiCap->DMX pixel changes after about 2-3 seconds.

PiCap running on a Raspberry Pi3, FPP version 6.0.2-8-g8bc1f372FPP in Player mode
Channel input enabled, 1 input active, E131, unicast, FPP Channel start 1, end 510, universe 1, universe count 1, universe size 510
Channel outputs: other, active DMX-Open, start channel 1, Chanel count 16, Desc blank, Port ttyAMA0

PiCap works, sending the right pixel color, it just is tremendously slow to update, and rapid changes are lost in the time lag.Am I in a wrong mode or missing an important step?

CaptainMurdoch

Do the DMX pixels change properly when you run a sequence?  I believe that xLights changes some settings in FPP when you turn on (or off) Output to Lights, so that could be what is causing the delay. 

Are you saying pixels are always delayed when xLights is sending through FPP out the DMX port?  There should not be any delay.  I would also use the Channel Tester page in FPP to see how quickly the DMX pixels respond when you change the settings on the test page.  There will be a slight lag as the new test data is setup, but it isn't anywhere near 2-3 seconds.
-
Chris

JerryPlak

something to try..
on the FPP setting add the check mark to the "Always transmit channel data"
to see if helps
Jerry Plak

bloojoop

If it is just when you start the test, make sure "Auto upload configuration" is NOT checked.  That is the setting that Chris was referring to just above.  It is generally recommended not to have that setting checked. 
--Ron A.

Support FPP

+- Recent Topics

K16a-b FPP setup by dkulp
Today at 06:15:18 AM

OrangePi 3 LTS wifi by ctmal
September 25, 2022, 05:27:37 PM

Pi Top on sale by CeP
September 25, 2022, 04:26:29 PM

no Lights by Poporacer
September 24, 2022, 06:47:12 PM

exceding 24000 starting channels by Poporacer
September 24, 2022, 05:53:25 PM

No signs of life, help by JonD
September 24, 2022, 02:44:30 PM

Sequencing timing... by Atljim965
September 24, 2022, 10:22:25 AM

OLED Screen Not Coming On by jja0607
September 23, 2022, 06:34:51 PM

How to connect a button (via GPIO) to a K16A-B by pierlux
September 23, 2022, 05:44:49 PM

Background Image (House) Not Visible In XLights by dkulp
September 23, 2022, 12:41:52 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod