News:

LATEST RELEASE:  FPP 6.3 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/6.3

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15647
Latest: Linwood Walker
New This Month: 52
New This Week: 11
New Today: 2
Stats
Total Posts: 128296
Total Topics: 15777
Most Online Today: 29
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 3
Guests: 34
Total: 37

Remote script issue

Started by mac1321, December 02, 2022, 08:08:02 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

mac1321

Running 6.2  with 1 master and two remotes.  All where fresh new installs this year.  Light show works and my projector on the remote run's videos no problem with my sequence.

The issue I am having is if I use the projector plugin scripts to power on and off the projector, I have no issue.

When I try to use run remote script and put the script name in and the IP address of the remote that has the scripts and the projector attached the script never runs.  So, I am stumped and stuck. 

Any ideas or suggestions?  Below is my lead in and my lead out is just the power off script being run the same way,



darylc

does the script work when you run it directly from the remote?

mac1321

Yea it works fine when run on the remote pi directly.  Just can't trigger it to run from the master now.

Aaron Maue

I know this thread is getting a little stale, but in case you're still checking, here's a possible workaround...

1.  On the remote, create a command preset that fires the script.
2.  Instead of trying to launch a remote script from the player, launch the remote command preset.

I'm not a dev, but I'm thinking it should work the way you're trying to do it.  In the meanwhile, however, maybe this will get you rolling.

jnealand

I had a similar problem trying to turn my static TuneTo on and off.  The scripts worked great if run from the remote, but not when triggered from the master in my leadin and leadout.  The problem is the the command needed a fully qualified script name.  ie.  I had to add .sh after the script name.  Once I changed StaticOn to StaticOn.sh  it worked just like I wanted it to.
Jim Nealand
Kennesaw, GA all Falcon controllers, all 12v Master Remote Multisync with Pi and BBB P10 and P5

Support FPP

+- Recent Topics

help getting started, next step? by jnealand
January 26, 2023, 08:25:27 PM

Bug in newest release by tbone321
January 26, 2023, 06:14:26 PM

Cannot Connect to F48V4-NS Through Rasberry Pi by Poporacer
January 26, 2023, 03:13:43 PM

new piCaps in the works? by Bwinter
January 26, 2023, 11:25:32 AM

DIY voucher request by CaptainMurdoch
January 26, 2023, 11:14:38 AM

Which volume to grow during setup? by RickR
January 26, 2023, 09:55:17 AM

F16v3 Won't boot or power on by chiefwarrant
January 26, 2023, 06:56:34 AM

Simple single Channel DMX Output trigger by info@trans-mission.tv
January 26, 2023, 05:33:54 AM

No network by JonD
January 25, 2023, 12:54:50 PM

F16v3 screen is dead by JonD
January 25, 2023, 12:49:31 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod