LATEST RELEASE:  FPP 6.1 - Download from here -



Welcome, Guest.
Please login or register.
Forgot your password?

+-Site Stats

Total Members: 15523
Latest: Stoneyman22
New This Month: 31
New This Week: 19
New Today: 5
Total Posts: 127319
Total Topics: 15628
Most Online Today: 86
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 7
Guests: 39
Total: 46

Incorrect Pixel Count and Device type listing under Pixel Ports.

Started by MrChristmas2000, August 29, 2013, 06:13:51 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I am running Falcon Controller Software v1.0.0

I enterd a Pixel count of 150.
The Pixel count showed up as 450 which is correct.

Then I changed the Device type to 2811 Strips and the Pixel count changed to 1804 String and the Device type stayed the same.

If I went back and changed the Pixel count the Pixel count would update to the correct value but the Device Type value never changed in the column.

Now if I chose the next channel (number 2) the 'Pixel port Settings' Device Type would change to the Default '1804 string'.

Then if I reselected channel number 1 the 'Pixel port Settings' would display the correct Device Type but the Device type in the Pixel Ports column never changed value.


It has been that way since the beginning.  I had that same issue.  It does keep your changes correct in the 'Pixel Port Settings' section even though it doesn't look right in the 'Pixel Ports' main section and will program your Falcon board correctly. 

I program my board with a mix of 2811 strips and 1804 strings and the output is correct for the RGB order on both. 
The only difference the board is making between 2811 and 1804 is the order of RGB.  David correct me if I'm wrong here.


David Pitts

PixelController, LLC

David Pitts

OK. I believe it is fixed now.  Your software should ask you to update it next time you run it when connected to internet. If not manually install it by downloading file here.;sa=view;down=4
PixelController, LLC


Thanks a bunch.

That was fast . . . . WooHoo.  :)

I just let it update it's self and it seems to have worked just fine.


Glad to see it fixed along with the other updates you made.   


After seeing Dave's post about a fix and auto update, I started up my pi. It said 22 files changed, 479 insertions, 333 deletions. So I assume mine updated o.K.? I ask because you mentioned the software should "ask" and I didn't get asked in the browser screen on my PC or on the Pi boot screen.
   Also how is the RasClock update coming?



He wasn't talking about the Pi player. He was talking about the Falcon 16 setup software.

Galaxy Note II

Long time Falcon, FPP and xLights user


Ooops ...  I guess I didn't read the forum title. Sorry.


Thank you David! 

Updated and tried it out, everything looks good.


Powered by EzPortal
Powered by SMFPacks Menu Editor Mod