News:

LATEST RELEASE:  FPP 6.1 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/6.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15290
Latest: eatumup
New This Month: 36
New This Week: 5
New Today: 4
Stats
Total Posts: 125007
Total Topics: 15226
Most Online Today: 89
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 7
Guests: 42
Total: 49

v1.2.3 controller software not working with FPD

Started by drlucas, October 26, 2015, 05:34:20 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

drlucas

I'm trying to program via FPD over wireless. When I hit the program button nothing happens with my counters over on the FPP status screen. They all sit at 0s so it doesn't look like the FPD address is taking at all.

When I hit output to lights in xlights I can see the counters going up so I know the computer is able to communicate with the FPD.

Not sure what's happening (or not happening in this case). Has anyone else been able to program with the latest controller software over FPD?
Ryan

David Pitts

I have and it has been tested by several others. Make sure your controller and FPD have the latest firmware loaded.
PixelController, LLC
PixelController.com


David Pitts

It most likely was incorrect version of fpd and controller

Sent from my LGLS990 using Tapatalk

PixelController, LLC
PixelController.com

twooly

I'm not using a fpd myself, all through an etherdongle and the f16 has the latest firmware.

David Pitts

Oh. You were using ether dongle. Ok. Maybe i will bust mine out to test that. But Ryan is using fpd.

Sent from my LGLS990 using Tapatalk

PixelController, LLC
PixelController.com

twooly


Quote from: David Pitts on October 26, 2015, 06:18:40 PM
Oh. You were using ether dongle. Ok. Maybe i will bust mine out to test that. But Ryan is using fpd.

Sent from my LGLS990 using Tapatalk

Yep sorry for the confusion, just wanted to note something wasn't right, who knows maybe it's related.  I'm good right now since I have an older install on another machine so no rush. I'll be glad to test things out for you.

drlucas

Quote from: David Pitts on October 26, 2015, 05:47:30 PM
I have and it has been tested by several others. Make sure your controller and FPD have the latest firmware loaded.

Hmmmmm....It has been a while since I touched the FPD.... I'm going to grab my etherdongle first before I try to validate things with the FPD. Is there an easy way with the pic to read the pic and verify a checksum? 
Ryan

drlucas

Confirmed it works via etherdongle. Just not FPD right now. 
Ryan

twooly


Quote from: drlucas on October 26, 2015, 07:04:38 PM
Confirmed it works via etherdongle. Just not FPD right now.

Do you happen to see what I was seeing with playing xlights to etd to f16 slow output

Roger DeBolt

Ryan have you tried switching the ports on the FPD?


Roger

drlucas

Quote from: twooly on October 26, 2015, 07:10:46 PM
Do you happen to see what I was seeing with playing xlights to etd to f16 slow output

I didn't run any test sequences, but that was strange behaviour. I know for sure with xlights --> FPP -->  FPD --> F16 and in test mode (simple RGB cycle) it was just as fast as with xlights --> etherdongle --> F16

For my channel output screen I set the FPD to be first two ports all 8 are pixel net starting at channel 1 then the last port is all 4 dmx starting at channel 1. I tried port 1 and 2 and same.

What I did notice is sometimes I have to hit the program button a few times on my laptop to get it to program with the etherdongle. I figure that is probably normal with other multicast traffic on the network?? Anyways it's strange the FPP doesn't even report the traffic on the status screen. I thought that the FPP would increase counters if the traffic went to it....and that is not even incrementing when I hit the program button. I haven't loaded up wireshark on this machine yet, but might, but wanted to see if anyone else had the same issue first.
Ryan

CaptainMurdoch

The control software doesn't use E1.31 packets to program the FPD, it sends a special packet over anothert port to FPP to program the FPD.  When FPP receives this program packet, it stops sending channel data to the FPD, sends the program packet, then resumes sending channel data if it was previously sending.  This allows the FPD to be programmed while you are actually using it.  This is also why you need to make sure you are on the latest FPD firmware.
-
Chris

drlucas

OK thanks for the info Chris (and all of course!!).

Tomorrow I'll error on the side of caution and pull the pickit out and upgrade(???) the FPD and report back. If this doesn't work according to plan is there anything troubleshooting wise (excessive log?) to look at?

FPD Alpha 0.0.10 in the download section is the version I want to use correct?
Ryan

CaptainMurdoch

yes, the download section was recently updated to show the correct latest version.

I think we have some debugging entries in the fppd.log when the control software sends the FPD config packets, so you could turn on debug level logging and see if you see anything in fppd.log when you click the program button in the software.
-
Chris

Support FPP

+- Recent Topics

K16a-b FPP setup by dkulp
Today at 06:15:18 AM

OrangePi 3 LTS wifi by ctmal
September 25, 2022, 05:27:37 PM

Pi Top on sale by CeP
September 25, 2022, 04:26:29 PM

no Lights by Poporacer
September 24, 2022, 06:47:12 PM

exceding 24000 starting channels by Poporacer
September 24, 2022, 05:53:25 PM

No signs of life, help by JonD
September 24, 2022, 02:44:30 PM

Sequencing timing... by Atljim965
September 24, 2022, 10:22:25 AM

OLED Screen Not Coming On by jja0607
September 23, 2022, 06:34:51 PM

How to connect a button (via GPIO) to a K16A-B by pierlux
September 23, 2022, 05:44:49 PM

Background Image (House) Not Visible In XLights by dkulp
September 23, 2022, 12:41:52 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod