News:

LATEST RELEASE:  FPP 7.5 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/7.5

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 16460
Latest: tripleblack
New This Month: 10
New This Week: 1
New Today: 0
Stats
Total Posts: 132601
Total Topics: 16445
Most Online Today: 193
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 2
Guests: 133
Total: 135

K8-Pi - Random Pixels on

Started by Gilmax, March 09, 2023, 12:22:04 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Gilmax

I just received my Kulp Lights K8-PI, and I'm not sure where is the best place to discuss issues I am having with it, but figured this was as good as any.  This is a fresh clean install of the most recent FPPOS.  It detects the Cape just fine.  The issue I am having is that when I plug in a string of lights (tested with multiple strings and multiple ports) some (3) of the pixels light up blue.  If I go into any test mode the pixels respond correctly, and as soon as I stop the test, they return to being blue.  I tested the strings on a previous Falcon PiCap, and have no issues with them their, so the problem only exists while using the K8-PI.  What details/information do I need to provide to help with this issue?

(The pixels are 12v from DIYLEDExpress.com purchased in early December of 2022).

RS

dkulp

It's on a Pi 4, correct?

As mentioned on the product page, it MUST be using master branch FPP code.   FPP 6.3 will not work, particularly on a Pi4. The DPI code was pretty much developed on a Pi3 so the timings work ok there with FPP 6.3, but on the Pi4, you definitely need the master branch updates.  

Daniel Kulp - https://kulplights.com

Gilmax

Yes this is on a Pi4.  I will get updated to Master and retest.  Thank you.

cybercop23

Using Pi-4 on Master and all was okay until last night when I upgraded Master. Now FPPD keeps on crashing. I detached to an earlier commit (not sure if it was the one that I was using) and still have the same issue. Based on fppd log... last successful load was on FPP 7.x-master-24-g5a1aedf6; will try to go back to that.

Crash reports are configured to be sent.

cybercop23

Quote from: cybercop23 on March 24, 2023, 08:51:49 AMUsing Pi-4 on Master and all was okay until last night when I upgraded Master. Now FPPD keeps on crashing. I detached to an earlier commit (not sure if it was the one that I was using) and still have the same issue. Based on fppd log... last successful load was on FPP 7.x-master-24-g5a1aedf6; will try to go back to that.

Crash reports are configured to be sent.

Yup... this version works... lots of commits after.. will try to ID which one breaks
FPP Version:7.x-master-24-g5a1aedf6

cybercop23

Quote from: cybercop23 on March 24, 2023, 09:16:14 AM
Quote from: cybercop23 on March 24, 2023, 08:51:49 AMUsing Pi-4 on Master and all was okay until last night when I upgraded Master. Now FPPD keeps on crashing. I detached to an earlier commit (not sure if it was the one that I was using) and still have the same issue. Based on fppd log... last successful load was on FPP 7.x-master-24-g5a1aedf6; will try to go back to that.

Crash reports are configured to be sent.

Yup... this version works... lots of commits after.. will try to ID which one breaks
FPP Version:7.x-master-24-g5a1aedf6

@dkulp looks like 44272e26 that deals with e-fuses

dkulp

Can you go to the Cape info page and the EEPROM Upgrade tab and update to the latest firmware for the K8-Pi?   I think you may have the original firmware which tried to use the eFuse stuff to work around issues in the DPI code.  That is all now fixed so it's not necessary.
Daniel Kulp - https://kulplights.com

cybercop23

Quote from: dkulp on March 24, 2023, 09:53:06 AMCan you go to the Cape info page and the EEPROM Upgrade tab and update to the latest firmware for the K8-Pi?  I think you may have the original firmware which tried to use the eFuse stuff to work around issues in the DPI code.  That is all now fixed so it's not necessary.
Thanks. That seems to make it work. It did originally say ver 1.0 and the upgrade was still 1.0, but after the upgrade the above branch worked and moved it back to head and still working. Thanks again.

Support FPP

+- Recent Topics

F16v3 & Differential Cntrl Pwr Question by JonD
Today at 09:13:48 AM

Looking for specs on F4V2 (Red) by algerdes
Today at 07:47:02 AM

Did the the latest upgrade tonight and it failed. by MikeKrebs
June 10, 2024, 09:19:42 PM

No Audio by Steve
June 07, 2024, 02:10:47 PM

Video IP Capture -> sound by MikeKrebs
June 06, 2024, 09:00:17 PM

Control Channel Output by zj023
June 03, 2024, 06:23:35 AM

Compatibility question by John_82
June 02, 2024, 04:23:25 PM

Virtual Display not working? by colonelcline
June 01, 2024, 04:55:41 PM

Help for my LED Pit board project by Octonath
May 31, 2024, 06:15:17 PM

Help, can't get PCA9685 working with xLights and FPP by dkulp
May 30, 2024, 08:54:53 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod