News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15187
Latest: 3636lightshow
New This Month: 4
New This Week: 0
New Today: 0
Stats
Total Posts: 123961
Total Topics: 15067
Most Online Today: 49
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 0
Guests: 21
Total: 21

How to compile/install v4l2loopback?

Started by merp, June 22, 2022, 05:14:46 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

merp

I'd like to be able to project the video from my phone camera to a FPP instance. On my phone I'm running DroidCam, on FPP I have the DroidCam client, and I was going to set it up to make the video stream available via /dev/video0 which I'd use as the video source for the FPP Video Capture plugin.

To set up /dev/video0 I wanted to install v4l2loopback, and always get this error: "Your kernel headers for kernel 5.10.63-v7+ cannot be found at /lib/modules/5.10.63-v7+/build or /lib/modules/5.10.63-v7+/source." A new install of raspberrypi-kernel-headers only downloads the headers for the latest kernel, not 5.10.63-v7+. I'm having trouble finding 5.10.63-v7+ headers anywhere.

I understand that upgrading the kernel is not recommended; is there another way to install this?

CaptainMurdoch

What SD image are you running, is this the v6 beta image?

The following installation instructions work for me on a v6 beta SD image.

https://gist.github.com/brutella/a71e8d7aa90af2c53ab500c4125bc178

# Download source and install
git clone https://github.com/umlaeute/v4l2loopback
cd v4l2loopback
make
sudo make install
-
Chris

merp

Version 5.5

I assumed v6 wasn't yet ready to be used for live shows?

CaptainMurdoch

I have one system still running FPP v5.x and was able to test.  You should be able to run the following commands:

wget http://archive.raspberrypi.org/debian/pool/main/r/raspberrypi-firmware/raspberrypi-kernel-headers_1.20211007-2_armhf.deb
sudo dpkg -i raspberrypi-kernel-headers_1.20211007-2_armhf.deb

After that, the make command for v4l2loopback should complete successfully.
-
Chris

merp


Support FPP

+- Recent Topics

Bridging networks so show network can access internet by bloojoop
July 04, 2022, 03:08:03 PM

Looking for FPP Initial Setup screen by Poporacer
July 04, 2022, 11:51:56 AM

FPP 5.4 Released! by Poporacer
July 04, 2022, 08:42:52 AM

Falcon player dynamic tempo from some kind of input. How would I go about it? by JonD
July 03, 2022, 03:20:37 AM

FPP Startup - Newbee by Poporacer
July 02, 2022, 08:51:24 AM

EDM Audio FPP Plugin - RDS Expectations? by JonD
July 02, 2022, 06:12:35 AM

The Blenders - Rudolph by breese
July 01, 2022, 08:21:41 AM

fpp error when writing to emmc on BBB by neilric99
June 30, 2022, 11:28:59 PM

Any idea when more will be available by Poporacer
June 30, 2022, 09:39:31 PM

Trouble with wifi tethering/ initial setup by Poporacer
June 29, 2022, 09:14:53 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod