News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15649
Latest: Androom
New This Month: 0
New This Week: 1
New Today: 0
Stats
Total Posts: 128374
Total Topics: 15784
Most Online Today: 27
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 0
Guests: 31
Total: 31

Audio issues

Started by jacksonho, November 29, 2022, 05:43:25 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

jacksonho

Hello all,

First year with xmas lights. When I am running my show I am getting a lot of slowdown in the audio, it starts to sound robotic at times.
Current setup is
A BBB with a HE123 cape.
~1200 12v pixel lights on 2 outputs 500/700 split
Cheap USB sound card from ebay

Once I plugged the USB sound card in the audio would play but I don't seem to be able to specifically select the card in the FPP Settings. All the items in General Audio / Video have a blank selection. 

Would this mean there is an issue detecting the sound card and playing correctly which might impact the performance, or is there a possible other issue I need to look through the logs for?

Thanks

breese


jacksonho

#2
I have done a bit more deep diving, it appears that my sound card is actually showing up in FPP because in the troubleshooting section in sound cards there is this

card 0: Device [USB PnP Sound Device], device 0: USB Audio [USB Audio]



However I think I have found a larger issue that a lot of my dropdowns in FPP settings have no option, for example
Audio and video output device
RTC and Timezone
Locale

Does anyone know why all these would be blank? Apache logs seem to indicate some issue populating the array

[Wed Nov 09 09:55:00.643592 2022] [php7:warn] [pid 1028] [client 192.168.0.195:61367] PHP Warning:  file_get_contents(http://127.0.0.1/api/settings/AudioOutput/options): failed to open stream: HTTP request failed! HTTP/1.1 401 Unauthorized\r\n in /opt/fpp/www/common.php on line 422, referer: http://192.168.0.198/settings.php
[Wed Nov 09 09:55:00.644032 2022] [php7:warn] [pid 1028] [client 192.168.0.195:61367] PHP Warning:  array_keys() expects parameter 1 to be array, null given in /opt/fpp/www/common.php on line 424, referer: http://192.168.0.198/settings.php
[Wed Nov 09 09:55:00.644116 2022] [php7:warn] [pid 1028] [client 192.168.0.195:61367] PHP Warning:  count(): Parameter must be an array or an object that implements Countable in /opt/fpp/www/common.php on line 424, referer: http://192.168.0.198/settings.php


dkulp

Make sure you upgrade to FPP 6.2.  
Daniel Kulp - https://kulplights.com

Support FPP

+- Recent Topics

Set Time/Date by breese
February 01, 2023, 05:03:33 PM

Help How I use Orange Pi with FPP by tbone321
February 01, 2023, 02:41:58 PM

No network by Steve_63
January 31, 2023, 08:17:21 PM

F48V4-NS Pixel Controller using all 12 Differential SmartReceiver ports by BirdingPix
January 31, 2023, 02:26:30 PM

F48v4NS - Pi or No Pi? by rjhodgefamily
January 31, 2023, 09:25:20 AM

Trying to configure LOR CF50D Floods on FPP Pi Player with PiCap by JonD
January 31, 2023, 07:01:41 AM

Script/Plug-In Trigger on Data by darylc
January 30, 2023, 11:31:16 PM

Attempting to move to FPP 6.3 from 4.4 - Assigned IP is in different subnet. by Poporacer
January 30, 2023, 05:06:59 PM

Camera input for WS2811's by dkulp
January 30, 2023, 04:02:55 PM

F16v3 Won't boot or power on by rjhodgefamily
January 30, 2023, 02:22:05 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod