News:

LATEST RELEASE:  FPP 6.1 - Download from here - https://github.com/FalconChristmas/fpp/releases/tag/6.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15524
Latest: fighteriris
New This Month: 32
New This Week: 20
New Today: 3
Stats
Total Posts: 127343
Total Topics: 15630
Most Online Today: 135
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 10
Guests: 43
Total: 53

Unable to reconnect to BBB after network config

Started by Stoshx, October 03, 2022, 06:27:18 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Stoshx

Hello,

new to the hobby, setting up my first controller.  searched the forum to see if anyone else made a similarly stupid mistake and as far as I can find I'm the first.

I have a Beaglebone Black and was following the FPP manual to set it up for the first time by connecting to 192.168.7.2.  FPP 6.1 was already preloaded from the vendor.  Got down to the networking configuration and in hindsight I think I know where I went wrong but now I don't know how to fix it.

I followed the recomended setting of a static IP for the wlan0.  set the IP address to 192.168.10.1, subnet to 255.255.255.0 and left the gateway blank as per the directions.  Updated the interface

didn't restart the network but clicked over to the Host & DNS settings tab.  gave it a meaningful name of FPPMaster.  Restarted the network.

Now I can't get back into the BBB.  Everything i have runs off my home network gateway of 192.168.1.1, so I think I set it off my network?

How do I get back in or reset the configuration back to default 192.168.7.2?

Thank you,

Josh

Kensington Graves

Plug a network cable into the BBB from the home router and reboot.  As I recall, eth0 defaults to DHCP, so you should be able to find the BBB on your list of attached devices on the router.  That is, assuming you did not mess with the eth0 settings.  You can have different interfaces on different subnets, and it is even necessary for some configurations.

The 192,168.7.2 IP address is the address that is used when the BBB is tethered to a PC, so you should also be able to get in that way, too, by connecting the BBB to your PC with a USB data cable.

Stoshx

Ok, wired network cable worked (thank you!).  I was able to clear out the settings and changed it to DHCP from my router.  I entered my network ID and password, updated interface, restarted network, unplugged LAN cable, watied a couple minutes.  Fully powered off and back on. 

However, it didn't connect to my WiFI network and again appears to be on its own network.

K16 display says:
Host: FPPMaster
wlan0: 192.168.8.1
Player: idle

While powered on I again plugged my LAN cable in, it accepted and then displayed both wlan0 and eth0 addresses.  I launched the eth0 address and confirmed all of my settings were still correct for the wlan0.

what am I doing wrong for getting it on wireless?

rudybuddy


Stoshx

Here is the wlan0 setup:

You cannot view this attachment.

rudybuddy

See if setting your wifi driver from external to internal helps.

Poporacer

Quote from: Stoshx on October 03, 2022, 07:32:35 PMwhat am I doing wrong for getting it on wireless?
There have been a few of the Kulp boards that have had a problem with the USB port, I would reach out to Dan or Wired Watts, whenever you got it from.
If to err is human, I am more human than most people.

Stoshx

Quote from: rudybuddy on October 03, 2022, 08:35:14 PMSee if setting your wifi driver from external to internal helps.
I changed the driver from external to Linux Kernel (only other option).  It still lists the wlan0 as 192.168.8.1.  Strangely on my phone's WiFi I can see "FPP" listed as a wifi connection but it's password protected and I can't join it.  tried all the usual passwords of christmas and falcon but none work.  I never set a FPP or OS password either, so I have no idea what it could be.  Whatever it is it's 8 digits long as that's when the "join" button lights up.

Quote from: Poporacer on October 03, 2022, 11:05:37 PMThere have been a few of the Kulp boards that have had a problem with the USB port, I would reach out to Dan or Wired Watts, whenever you got it from.

If there is a problem with the USB port would it still power the wifi adapter and broadcast at 192.168.8.1 or just be a dead port?  I've ordered a different wifi adapter to try and eliminate the Edimax Nano as the issue.  It works when I plug the nano into other devices though.

Poporacer

Quote from: Stoshx on October 04, 2022, 03:31:22 PMtried all the usual passwords of christmas and falcon but none work.
Did you try Christmas (capital C)

If to err is human, I am more human than most people.

Stoshx

Quote from: Poporacer on October 04, 2022, 05:28:56 PM
Quote from: Stoshx on October 04, 2022, 03:31:22 PMtried all the usual passwords of christmas and falcon but none work.
Did you try Christmas (capital C)


Yes, I did. It did not work.

steve123

Do you have tethering enabled?

Network Config -> Tethering

It defaults to wlan0 if it is enabled.  At the bottom of the tethering tab:

QuoteWarning:
Turning on tethering may make FPP unavailable. The WIFI adapter will be used for tethering and will thus not be usable for normal network operations. The WIFI tether IP address will be 192.168.8.1 for Hostapd tethering, but unpredictable for ConnMan (although likely 192.168.0.1).

Stoshx

#11
Quote from: steve123 on October 05, 2022, 02:58:25 PMDo you have tethering enabled?

Network Config -> Tethering

It defaults to wlan0 if it is enabled.  At the bottom of the tethering tab:

QuoteWarning:
Turning on tethering may make FPP unavailable. The WIFI adapter will be used for tethering and will thus not be usable for normal network operations. The WIFI tether IP address will be 192.168.8.1 for Hostapd tethering, but unpredictable for ConnMan (although likely 192.168.0.1).

I disabled teathering which got it unstuck from 192.168.8.1.  Thanks for pointing that out!


Stoshx

You cannot view this attachment.
Even though there isn't a drop-down arrow, I noticed if I type in one letter and click on the white space for text it will display a drop-down menu of available wifi routers.

This eliminates the USB port from being bad as these are all active wifi around my house.

I think the issue is my nano adapter which is an 802.11 A/C that doesn't see what I'm broadcasting (802.11 B/G/N/AX).

What I was reading when I bought the BeagleBone is that it's compatability is only with certain wifi adapters.  If that's true, I'm stuck and will have to use wired.  If it can accept a wider array of adapters that match what I'm broadcasting, I should be all set.  Either way it's the adapter and not a bad BeagleBone or some setting.

Thank you to everyone that helped troubleshoot my first controller, I greatly appreciate it.

rayster

Have you tried changing the Driver setting to Linux?
Ray
Using K8-B, Rpi 3b w/PiHat, Rpi 3b+ w/ PiHat, K4-PB

bloojoop

I don't see Tardis in the list of available SSID's which is what you had it configured for.  Is Tardis being broadcast?  all discovered SSID's should be in that list, then just select the correct one.  If it is a hidden SSID, you likely need to check mark the hidden check mark.
--Ron A.

Support FPP

+- Recent Topics

What am I doing wrong? FPP I’m ZCCP? by rudybuddy
Today at 09:01:26 AM

FPP Playlist by dkulp
Today at 07:14:42 AM

Setting up LOR to serial of F16v3 and configure in xLights by brmeadows
Today at 05:46:42 AM

FPP not releasing control to WLED when idle by Poporacer
December 06, 2022, 10:39:18 PM

1 player/2 remote by Poporacer
December 06, 2022, 08:07:48 PM

K8-PB Network Issue by Kensington Graves
December 06, 2022, 07:40:50 PM

Failed V1.03 diff receiver boards by bud29
December 06, 2022, 07:13:38 PM

XLights Variant by Poporacer
December 06, 2022, 06:56:52 PM

FPP Oddness. Remote not remoting, schedule not scheduling??? by Poporacer
December 06, 2022, 06:27:33 PM

Text inverted by dreiman
December 06, 2022, 06:12:17 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod