News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15509
Latest: DarkwinX
New This Month: 17
New This Week: 8
New Today: 8
Stats
Total Posts: 127176
Total Topics: 15605
Most Online Today: 85
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 4
Guests: 37
Total: 41

FPP 5.4 Released!

Started by dkulp, November 23, 2021, 06:15:11 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

dkulp

FPP 5.4 Released!
This is mostly a bug fix release to fix issues encountered with Halloween shows, but it also contains some other enhancements (like preliminary support for the new Pi Zero W2).
Full release notes and downloads are available from: https://github.com/FalconChristmas/fpp/releases/tag/5.4

ENHANCEMENTS
  • Updated rpi_ws281x and rpi-led-panels libraries to detect and support the new Raspberry Pi Zero W2
  • Reduce some padding on Multisync page to display more information
  • Compress Mulisync stats by showing duration instead of time
  • Enhance the pop-up FPP Command Editor to allow chosing Command Presets and saving a command as a preset.
  • Added pruning of old locally stored JSON setting backup files greater than 90 days if there are more than 14 files
  • Schedule out 5 weeks to provide better preview of future actions
  • Add Boxing Day to USA holiday list
  • Additional MQTT Commands to stop/restart FPPD, shutdown/restart the OS
  • Increase the max size of an SMTP email password

BUG FIXES
  • Allow directories to be used for Image Playlist Entry type
  • On non-Pi/BBB devices, tons of sensors may display in the header causing menus to be unavailable
  • Fix problems with scheduler when daylight savings time starts/ends
  • Sort Pixel Overlay Effects names so they are sorted in the API and UI
  • F1/Help on settings pages not returning the proper help page
  • Fix problems of wlan0/wifi not working if ethernet connected (BBB only)
  • Fix UI error message in GetFiles
  • Make sure jquery is loaded via relative url to work behind proxies
  • Fix spixels output not properly mapping pixel protocols
  • Make sure playlist names are urldecoded to decode spaces and such. Fixes playlist uploads from xLights
  • Fix volume Slider in remote mode
  • remoteOffset was not doing anything for sequences, make sure the timestamp is used if provided in sync packet
  • Fix the ipaddress validator code to better handle hostnames
  • Add timeout to Audio Device Warnings

INSTALLATION INSTRUCTIONS
If you have a system running 5.x, you can go to the FPP about page (about.php) and click on the "Manual Update" button. At that point, a big green "Upgrade" bar should appear on the main status page. Click on that to start the update process. It may take a long time to upgrade. Likely 5-10 minutes. You will need to reboot after the upgrade is complete to finish the upgrade process.
For users of FPP 4.x or older, it is strongly recommended to do a full "OS Level" upgrade or re-image instead of attempting to upgrade directly from any older FPP version. There are several new features that will not work if an OS level upgrade is not done. There are two ways to do so:
  • Re-image - you can backup your 4.x configuration, create a new image, and restore the configuration.
  • In-place upgrade - this is new and requires you to have FPP 3.6.2 (or 4.0-alpha2) or newer already running on the device. Download the appropriate "fppos" file to your computer. Make sure the file extension is still fppos (some browsers will rename it). Upload it to the "File Manager" on the FPP instance. Then go to the about page. Under the normal "Manual Upgrade", a new Upgrade OS button should appear. Click it and wait a LONG time. When done, it should reboot into 5.0. At that point, go to the Uploads tab of the FPP File Manager and delete the fppos file. Note: In SOME cases, the reboot will fail due to library replacement. In that case, a power cycle may be required to get it back up and running.

SELECTING AN IMAGE
For Raspberry Pi series including Pi B, Pi B+, Pi 3, Pi 3+, Pi 4 and Pi Zero use this image
https://github.com/FalconChristmas/fpp/releases/download/5.4/FPP-v5.4-Pi.img.zip
For Beaglebone Black, Beaglebone Green, PocketBeagle, and Beaglebone Green Gateway use this image
https://github.com/FalconChristmas/fpp/releases/download/5.4/FPP-v5.4-BBB.img.zip
Daniel Kulp - https://kulplights.com

rayster

Thanks to the team for making this a great hobby with all the work you do!
Ray
Using K8-B, Rpi 3b w/PiHat, Rpi 3b+ w/ PiHat, K4-PB

thekameleon

There may be an issue with the MultiSync on 5.4. My first sequence synced without an issue between all of my remotes. The second sequence though was all over the place. The player was elapsing fine, but all of the other remotes were on different elapsed times and the sequence would pause or stutter. All my Remotes are BBB with Kulp Boards, My Player is Raspberry PI 4.0. I rolled everything back to 5.3 and I don't have any issues. Let me know if you want all of my log files or if this is enough to go on.

aknflyer

Another bug, when uploading a 3 meg file, it shows as 30,000mb. Taking forever to upload. 20 mins in now and prob wont finish till morning.

Sawdust

I'm having multiple issues.  First BBB upgrade crashed-lost all data.  5.4 Multisync only see other 5.4 on BBB and Pi4. Also see imageYou cannot view this attachment.

dkulp

Quote from: thekameleon on November 23, 2021, 04:15:24 PMThere may be an issue with the MultiSync on 5.4. My first sequence synced without an issue between all of my remotes. The second sequence though was all over the place. The player was elapsing fine, but all of the other remotes were on different elapsed times and the sequence would pause or stutter. All my Remotes are BBB with Kulp Boards, My Player is Raspberry PI 4.0. I rolled everything back to 5.3 and I don't have any issues. Let me know if you want all of my log files or if this is enough to go on.
Was the first sequence a media/fseq item and the second sequence a "fseq only"?  If so, I saw something similar last night with my own show.  I'm testing a fix now which I hope to push to a 5.4.1 later today.
Daniel Kulp - https://kulplights.com

thekameleon

Yes sir. That is exactly what I had in the play list.  So after my media/fseq would play.  All the remotes freezed at the end time of the media/fseq while the other fseq only played.  Then in time they would go all over the place when it came to timing as well as freeze/pause then jump to another part.

thekameleon

Quote from: dkulp on November 24, 2021, 06:08:25 AM
Quote from: thekameleon on November 23, 2021, 04:15:24 PMThere may be an issue with the MultiSync on 5.4. My first sequence synced without an issue between all of my remotes. The second sequence though was all over the place. The player was elapsing fine, but all of the other remotes were on different elapsed times and the sequence would pause or stutter. All my Remotes are BBB with Kulp Boards, My Player is Raspberry PI 4.0. I rolled everything back to 5.3 and I don't have any issues. Let me know if you want all of my log files or if this is enough to go on.
Was the first sequence a media/fseq item and the second sequence a "fseq only"?  If so, I saw something similar last night with my own show.  I'm testing a fix now which I hope to push to a 5.4.1 later today.
I saw the 5.4.1 push earlier today so I put it on one of my test controllers.  And it is still wonky.  What seems to be happening is when the next "fseq only" playlist item is started the controller with 5.4.1 on it, starts 23 seconds in advance.  That happens to be the exact time of my first item in my playlist which is a "fseq with media" sequence. After that the 5.4.1 controller jumps around in elapsed time.

pixelpuppy

Quote from: thekameleon on November 24, 2021, 08:47:57 PMI saw the 5.4.1 push earlier today so I put it on one of my test controllers.  And it is still wonky.  What seems to be happening is when the next "fseq only" playlist item is started the controller with 5.4.1 on it, starts 23 seconds in advance
I'm assuming your 'test' controller is a Remote and I'm pretty sure you need to update the master Player (the one with the schedule and telling all the remotes what to do) in order to get the benefit  of the 5.4.1 fix
-Mark

Sawdust

#9
Fixed . . . Processed upgrade via Pi-5.4.1.fppos and it corrected. 

Strange....all the BBB's show FPP Version as 5.4.1, but all the Pi's show 5.4-7-ga4ea8d39.  Is this intended or a glitch?

5.4.1 loaded on all Pi's & BBB's...seems to be running fine.
You cannot view this attachment.You cannot view this attachment.

algerdes

#10
FYI - Just updated all my RPi and they show 5.4.1 (v5.4 branch).
Additional - I've also updated all my BBB and they show 5.4.1 as well.
Sequencers: Vixen3 and xLights
Players: FPP and xSchedule Controllers:  Renards - SS24/SS16; E1.31 - San Devices E682 - Falcon F16, F4, F48 - J1Sys - DIYLEDExpress E1.31 Bridges.  Much more!

thekameleon

#11
Quote from: pixelpuppy on November 25, 2021, 05:53:46 AM
Quote from: thekameleon on November 24, 2021, 08:47:57 PMI saw the 5.4.1 push earlier today so I put it on one of my test controllers.  And it is still wonky.  What seems to be happening is when the next "fseq only" playlist item is started the controller with 5.4.1 on it, starts 23 seconds in advance
I'm assuming your 'test' controller is a Remote and I'm pretty sure you need to update the master Player (the one with the schedule and telling all the remotes what to do) in order to get the benefit  of the 5.4.1 fix

Hi Mark, yeah you are 100% correct. I updated the master player and my test remote is running the sequence as expected.  Thanks for nudging me in the right direction. I did get a red warning banner that said FSEQ block not available. Likely slow storage on two remotes.  It cleared up on the following sequence... Maybe too much IO on the disk.

steve123

I think I am having the problem too.  The master and remote are both running 5.4.1 but the remote begins to stutter when a new playlist starts.  I have two play lists.  An "idle" playlist with a single animation sequence (no audio) that runs when the main playlist is idle.  The main playlist runs once an hour.  When the main playlist is done, the idle playlist starts.  The FPP master appears to sequence all the pixels connected to it.  However, the remote stalls and stutters.  Restarting FPP on the master fixes the problem until the idle playlist runs again after the show playlist.  For reference, if the idle playlist starts first, it runs fine.  The show playlist runs fine next.  But when the idle playlist is started again at the completion of the show, it stutters and stall.

Both master and remote are BBB (Kulp K8 and Kulp K16) boards.

steve123

Quote from: dkulp on November 24, 2021, 06:08:25 AM
Quote from: thekameleon on November 23, 2021, 04:15:24 PMThere may be an issue with the MultiSync on 5.4. My first sequence synced without an issue between all of my remotes. The second sequence though was all over the place. The player was elapsing fine, but all of the other remotes were on different elapsed times and the sequence would pause or stutter. All my Remotes are BBB with Kulp Boards, My Player is Raspberry PI 4.0. I rolled everything back to 5.3 and I don't have any issues. Let me know if you want all of my log files or if this is enough to go on.
Was the first sequence a media/fseq item and the second sequence a "fseq only"?  If so, I saw something similar last night with my own show.  I'm testing a fix now which I hope to push to a 5.4.1 later today.
In my case this is what appears to be happening.  When the "fseq only" sequence runs, the remote stutters and stalls.  Both master and remote are running 5.4.1

steve123

For anyone else having this problem, I think the resolution is the ensure that FPP is rebooted after the upgrade to 5.4.1.  I rebooted the Master but I think I recall the remote just restarted FPP.  Both the master and remote reported 5.4.1.  After rebooting the remote the problem does appear to go away.  Release notes should be amended to indicate a reboot is necessary.

Support FPP

+- Recent Topics

Linking FPP Run Command to a Button by tynmar
Today at 02:34:43 PM

Written documentation for Differential Receivers v2.01 by DarkwinX
Today at 02:29:36 PM

Falcon V4 Player by jduncc
Today at 01:34:44 PM

loading playlist by rangerdan
Today at 12:28:34 PM

BBB running 3-4 seconds ahead by Poporacer
Today at 12:16:19 PM

Moving cross country entire show for sale by solix
Today at 12:02:55 PM

Effects by rudybuddy
Today at 11:58:36 AM

RPI PICO AND WS2812B by tjkaminski
Today at 10:54:04 AM

Change playlist based on weather by stre1026
Today at 10:03:02 AM

Needs Repair by boostedmopars
Today at 08:38:27 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod