LATEST RELEASE:  FPP 7.5 - Download from here -



Welcome, Guest.
Please login or register.
Forgot your password?

+-Site Stats

Total Members: 16476
Latest: jbhubert
New This Month: 8
New This Week: 5
New Today: 2
Total Posts: 132724
Total Topics: 16475
Most Online Today: 114
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 1
Guests: 81
Total: 82

Random blinking and flashing issue

Started by TheMinionHouse, December 12, 2023, 01:10:48 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hey Guys,  I have a New F48-V4-NS and I am running 5 4 Channel Smart LRs and 2 8 Channel ones.  
And both my 8 Channel ones, from time to time they will start glitching and the whole set of pixels on both, over 2k each, will flash or drop out randomly and continuously when the display signal is very bright. 
I was thinking power, but both boxes have 4 350watt 12V power supplies, 4 Distribution cards, and the 8 Channel board, channel brightness set to 50%.   5 Channels have 400pix each, with PI every 100pix.   
If I restart the F48 the glitching stops for about 20 to 30 minutes, it doesn't stop if I restart only the Smart Receiver. 
Doesn't matter the sequence I am running either. 
If I put the F48 in Test mode the glitching stops too. 
My sequences are running 40fps and it only started doing this in the last few days, been running 2 weeks. 
The 4 channel on my 2 matrixes are running fine, no glitches or lags at all. But the 2 on my arches and the 1 on my front matrix is Lagging glitch, not flashing, but just lagging or stopping the effects.  The matrixs are plugged into Port 1-4 and 5-8, the Megas in port 9-12 and -13-16. The front Matrix in power 33-36, the arches are plugged into 37-40, and 41-44.
I am running the F48 in 32 channel 8+8 mode due to the 8 Channel cards, xlights would not let me configure it in for 48 channel with the 400pix I have on each strand of the mega trees. 
My other 2 controllers, F16V3 are all working properly. 
Whole show is run by FPP on a Pi4b with 8gb. 
network is enterprise class.
I updated the Firmware with no improvement, I have swapped Cat6A cables, I just don't know right now. 
I am at a loss. 


I have never seen lagging caused by power, unless the CPU was not getting enough power.  Termination absorbs the remaining energy in the line and prevents it from reflecting backwards causing ghosting effects.  Are the last SRs in the chain set to termination on?  The fact that it runs fine for 20-30 minutes makes termination issue less likely. 

There have been some issues with Falcon firmware 27, and would certainly make sure you are upgraded to build 30.  There are some known FPP memory leak issues resolved in FPP 7.4.  What is the firmware version of the Falcon, FPP version, xLights version?

Update:  It does seem like maybe I remember seeing some issues resolved by forcing some of the newer SRs to use V2 mode instead of letting them auto-detect.   Instead of using settings A,B,C, use 4,5,6 or something like that. 


I have updated it to 30 but it still persists.   
If I look at the output on the status, the last few universes, which cover the lights that are glitching, are Red.  Which means there is an issue, but I have no idea what. 


Quote from: TheMinionHouse on December 15, 2023, 04:49:31 PMIf I look at the output on the status, the last few universes, which cover the lights that are glitching, are Red.
Can you post a screenshot of this so that we know exactly what you are seeing?
If to err is human, I am more human than most people.


Here is that status screen, those universes Red are the ones I am having problems with.


Quote from: TheMinionHouse on December 12, 2023, 01:10:48 PMI am running the F48 in 32 channel 8+8 mode due to the 8 Channel cards
I am not sure what or where you are setting this mode and it doesn't matter on the SRx type. Just to clarify some terminology, the SRx2 isn't an 8 channel card (controllers don't use channels for pixel connections, they use ports), it isn't even an 8 port card. It is a 4 port card where the 4 ports are split. 
And if you are using the 4+4 setting in xLights which is the same as the 8 smart receiver chains in the F48, then you cannot use any of the middle row RJ45 ports (17-32)

Quote from: TheMinionHouse on December 12, 2023, 01:10:48 PMxlights would not let me configure it in for 48 channel with the 400pix I have on each strand of the mega trees.
Then you were probably configuring something incorrectly and xLights won't let you create "illegal" configurations. Can you explain your mega tree design and how you were trying to assign it to ports (they are not channels)

How about a screenshot of your Pixel ports in your F48 and the Visualizer page in xLights?

If to err is human, I am more human than most people.


So here are the screen shots from today.  
I had to move my arches to my old F16V3, which are working fine now, as well as my front Matrix. 

Also here is a video of what it was doing, with the freezing and glitching on the arches before I moved them and then my mega trees and 2 main matrix panels.  The Mega trees are still acting up, even with the additional load removed from the F48V4.   
I am almost thinking I have a faulty unit because even in test mode it acts up now. 

I have also changed my show from 40FPS to 20FPS, still the same issues before I moved the output to the Arches and Front Matrix. 
Gonna have to move the Mega Trees and other Matrix panels tomorrow.

Let me know what else I can provide.  Really frustrated at this point.  
It could be my fault or maybe a missed a setup thing or something, but I am not sure at all anymore.


Follow up, I found it.  Seems when I setup FPP this year it defaulted to Multicast. Which is not good for 32k pixels.
I changed it to Unicast and all the problems are solved.
Still don't know why the F48 glitches in Test mode though.

Support FPP

+- Recent Topics

FPP led Panel Troubleshooting. by jbhubert
Today at 05:49:15 AM

Looking for SRx2 V5... by darylc
July 11, 2024, 05:54:34 PM

FPP 8.0 by colonelcline
July 11, 2024, 04:05:15 PM

SMPTE timecode by k6ccc
July 11, 2024, 10:36:03 AM

Matrix panels go full while on every restart by k6ccc
July 11, 2024, 08:17:58 AM

output controller by MikeKrebs
July 10, 2024, 10:31:28 PM

Multiple text effects cause re-render by breese
July 09, 2024, 06:19:48 AM

Cannot change serial settings for Renard by
July 08, 2024, 09:11:47 PM

7.5 wlan ARP issue? by peterjp
July 05, 2024, 11:44:49 PM

FPPv7.5 octoscoller error by dkulp
July 05, 2024, 10:44:41 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod