Falcon Christmas

The Lab (Technical Talk) => Designer Troubleshooting and Help => Topic started by: Chris48 on November 26, 2021, 06:41:30 PM

Title: led colors are not right!
Post by: Chris48 on November 26, 2021, 06:41:30 PM
rasberry pi3, rpi-28d+, ws2811 12v......the colors i sequence in xlights are not the colors that are shown in the leds...if i do solid red on the sequence when i play it the leds light up blue....need help please!
Title: Re: led colors are not right!
Post by: tbone321 on November 26, 2021, 07:54:13 PM
There are two things that can cause this, incorrect port definitions and pixel color order.  For the first one, look at your port definitions and make sure that they are set to RGB and that the starting channel number is correct.  If the color order setting of the port does not match the color order of the pixel, you will not get the color that you are expecting.  The colors of the pixels are determined by the LED combination that is being lit and each channel controls a specific color LED.  If the starting channel is incorrect, the wrong LED's in the pixels will be lit up.

The second issue is pixel color order.  Not all pixels follow the same color order.  You need to set the controller ports with the correct color order for your pixels.  There are two ways to determine what it is.  The easiest way if your controller supports it and most do is to put it into test mode and set each color on one at a time in Red, Green, Blue color order and see what color the nodes turn for each one and write them down.  That will be the color order of your pixels and in the port definition section of your controller, you can change it to match your nodes.  If your controller does not have a good test mode, you can create a small sequence that just uses 3 on commands of about 5 seconds each.  Set the first one to Red, the Second to Green, and the third to Blue and just like the test mode method, the colors they light up in is the color order of your nodes.  Make sure that when you are testing the color order that the controllers port definition is set to RGB  which tells it not to make any changes to what is coming in and then change them to the color order you observed after the test and run it again.  The colors should then be correct.
Title: Re: led colors are not right!
Post by: Chris48 on November 27, 2021, 03:36:03 AM
Hey thank you for your advice I really appreciate it. I'm going to look at both of those things and see if it works, I'll let you know what I find out.... thanks again!
Title: Re: led colors are not right!
Post by: Chris48 on November 27, 2021, 04:16:53 AM
update! my output settings in FPP under pixels was set to RGB and i needed BRG. this fixed the problem! thanks again!
Powered by SMFPacks Menu Editor Mod