Server migration complete, Welcome to version 2.1.1



Welcome, Guest.
Please login or register.
Forgot your password?

+-Site Stats

Total Members: 15512
Latest: bfrisan
New This Month: 20
New This Week: 8
New Today: 8
Total Posts: 127208
Total Topics: 15614
Most Online Today: 72
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 3
Guests: 40
Total: 43

xLights not uploading configs to FPP

Started by perigalacticon, August 04, 2022, 04:26:41 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Since upgrading to FPP 6.0 on my RPI0s I haven't been able to get xLights to upload controller configurations to any of my RPI0s (xLights is v2022.13).  Upon choosing "Upload Output" in xLights I get the response: "FPP Output Upload Complete".  However this causes the FPP Channel Outputs PiHat page to be cleared and the channels are not transferred.  I have to type them in manually each time.  I've tried Auto Upload Configuration but the outputs remain blank.  I have rebooted and power cycled the FPPs, the PC, and the show router.  Any ideas?


Try using fpp connect with udp outputs set in xlights rather than upload output?


Quote from: perigalacticon on August 04, 2022, 04:26:41 PMHowever this causes the FPP Channel Outputs PiHat page to be cleared and the channels are not transferred.
How about a screenshot of your Controller tab in xLights and the visualizer page for that controller?
And the Outputs page in the PiHat

Quote from: perigalacticon on August 04, 2022, 04:26:41 PMI've tried Auto Upload Configuration but the outputs remain blank. 
This is usually not a recommended setting...if you are not careful it can mess things up (It only uploads when you output to Lights)
If to err is human, I am more human than most people.


I tried using "UDP all" on fppconnect for the remote fpps, but still no entries on the PiHat outputs tab for the remote fpps.  PiHat outputs are now listed on the E131 tabs of the remotes with the channel numbers, but not listed on the PiHat outputs tabs for the remotes.  I am now getting 2 PiHat entries on my show player FPP ("FPP1" controller) that don't exist in xLights at all ("String #0" and "String #1"); there are no PiHat outputs defined in xLights for FPP1 just E1.31 outputs.  FPP1 is my show player, a RPI4.  I have 4x RPI0s running FPP as remotes, they only have PiHat outputs no E131.  FPP5 should have 1 PiHat output line for each model "front_roof" and "nPillar".   E1.31 output is shown checked in the picture for remote FPP5 but this is a mistake normally it's not.

I also tried the "Full xLights Control" option in xLights for the remote FPP controllers but no luck when playing from xLights or the FPP1 player.  If I type in the channel numbers to the remote FPP PiHat tabs then they work correctly from the FPP1 player or xLights with or without the "Full xLights Control" option.

Picture "xLights_front_roof_model_config_8_5_22.PNG" shows the config in xLights Layout tab for one of the models on remote FPP5.

Player FPP1 config:
You cannot view this attachment. You cannot view this attachment.

Remote FPP5 config:
You cannot view this attachment. You cannot view this attachment.

xLights config:
You cannot view this attachment. You cannot view this attachment.

xLights layout:
You cannot view this attachment.


There are many things I see from your screenshots.  I'll do my best to address what I see here: 
1) looks like you have both fpp and esp based controllers with many of them set to inactive. If you are truly not using controllers, I would suggest removing them from the controllers tab. 
2) looks like you are manually configuring start channels using the universe addressing method and NOT using the auto layout and auto size methods.  Without auto layout, visualizer really does nothing for you.  If using auto layout (and with autosize), visualize will automatically configure the start channels for you. 
3) I don't see that you set the controller port under controller connection properties.  Without this, upload output will NOT configure anything on your controllers.  Again, the auto layout, auto size, visualize method will configure this automatically for you if you use that method. 
4) if you are using fpp based controllers (you are), and if you intend them to be "remotes", the "active" property on the controllers tab needs to be set to "xlights only" and NOT active. This is also true if your "player" is configured as a controller.
5) when using FPP connect, the "UDP Out" option should ONLY be configured on the FPP instance that would be required to send network data to your other (non-fpp remote) controllers such as your ESP based controllers.  This option configures the E1.31/DDP channel output tab and should ONLY be configured on 1 device and normally that would be the show player.  Do NOT set UPD out on the remote fpp devices.  You will need to remove those outputs on the remote devices.  
This is just what I can see on the surface with your screenshots.  If you want to continue to use the manual universe address method, that is fine you would just need to manually configure the channel output pages and NOT use "upload output" .   
--Ron A.

Support FPP

+- Recent Topics

K8-PB Network Issue by Kensington Graves
Today at 06:29:36 AM

Falcon V4 Player by K-State Fan
Today at 06:13:19 AM

RPI PICO AND WS2812B by tjkaminski
Today at 05:17:42 AM

INK1003 strips not playing nice with F16V4 by battle79
Today at 03:13:41 AM

FPP Playlist by LedMutt
Today at 02:29:01 AM

FPP install script on Ubuntu, no video by darylc
Today at 01:37:05 AM

f16v4 wont play in Player or Master Mode by Oxytousc
December 04, 2022, 10:33:43 PM

New to FPP6.2 - Interface issue, I think? by Poporacer
December 04, 2022, 09:54:45 PM

FPP not releasing control to WLED when idle by cwr89
December 04, 2022, 09:20:43 PM

K8-B-Scroller needs updated EEPROM Signature? by jdbeavers
December 04, 2022, 06:32:25 PM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod