News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 15650
Latest: Androom
New This Month: 54
New This Week: 1
New Today: 1
Stats
Total Posts: 128349
Total Topics: 15783
Most Online Today: 57
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 1
Guests: 12
Total: 13

FPP 6.2 ColorLight Issues

Started by dennismccreery, December 04, 2022, 05:52:32 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

dennismccreery

I'm running a Raspberry Pi 4B with a ColorLight 5A-75B card on ETH1 to drive a 4 X 4 P5 matrix display with FPP 6.2.  ETH0 goes to the master instance of FPP, also 6.2.  After configuring it, it runs just fine.  However, intermittently when starting up the ColorLight card stops working and I get the message below.  Restarting FTTPD doesn't help, but after rebooting the system it starts working again and seems to run fine the rest of the evening until shutdown.  Seems to occur only when starting up the system.  Any ideas?  Thanks.

You cannot view this attachment.

dennismccreery

#1
I see from the top of the screenshot that the system only seems to have ETH0.  The additional Ethernet adapter hooked to the ColorLight card should be ETH1.  So it's possible, I surmise, that the system simply didn't recognize the ETH1 USB Ethernet adapter (maybe intermittent boot issue?).  If this is the case, where might I find the error message in the logs?

Regards,

Dennis the Menace

dennismccreery

#2
I see a "Create Persistent Names" setting on the Network settings page in FPP.  From the manual:

QuoteIf you are using more than one Ethernet interface (common for users with a Color-Light board) and you need the Ethernet adapter to keep the configuration order, then you can create a Persistent Name. The best practice would be:
  • Power down the FPP device.
  • Make sure that only the primary Ethernet interface is installed.
  • Power up the FPP device.
  • Plug in the USB Ethernet adapter.
  • Configure the eth0 and eth1 devices
  • Click on Update Interface
  • Click on Create Persistent Name
This will save your eth0 and eth1 configurations so that they will load up in the correct order..
I think I'll try that, perhaps on boot up the system is assigning the wrong names (or out of order names) to the ETH0 and ETH1 interfaces.  I'll get a working configuration and then press "Create Persistent Names" and reboot to see if that fixes it.

Regards,

Dennis the Menace

dennismccreery

#3
Looks like this seems to have fixed it.  No error in the past 2-3 days.

Regards,

Dennis the Menace

dennismccreery

Nope, apparently that wasn't it.  Came up today from power-on with the same error.
Rebooting fixed it.

Not sure where to turn now.

Dennis the Menace

dennismccreery

When I create a Persistent Name, does it only create it for the device I have highlighted?  Or for all network devices?

Dennis the Menace

breese

I have not found a need for Persistent name with the colorlight controller.
That controller does not communicate through IP protocol.
It does require a 1Gig connection directly from the Pi to the Colorlight.
Make sure ETH1 is set for dhcp. Power on the panel first then the Pi.

Here are screenshots of my working setuo....
No issues to date.

You cannot view this attachment. You cannot view this attachment. You cannot view this attachment. You cannot view this attachment.


dkulp

eth1 would be on the USB bus.  You MAY need a 5s or 10s boot delay so the USB bus can be fully scanned and enumerated before fppd starts.   
Daniel Kulp - https://kulplights.com

JonB256

Quote from: dkulp on December 09, 2022, 05:47:10 AMeth1 would be on the USB bus.  You MAY need a 5s or 10s boot delay so the USB bus can be fully scanned and enumerated before fppd starts.   

I elected to put my ColorLight on ETH0 and system communication on my ETH1 (USB) to avoid this. It has been very steady. You should be able to swap those (a cable swap and config change) easily to test.

ps - I don't shutdown or reboot that Pi4. It stays on 24/7
Long time Falcon, FPP and xLights user

dennismccreery

Quote from: dkulp on December 09, 2022, 05:47:10 AMeth1 would be on the USB bus.  You MAY need a 5s or 10s boot delay so the USB bus can be fully scanned and enumerated before fppd starts. 
Thanks Dan.  How can I configure a boot delay?

Regards,

Dennis the Menace

dennismccreery

NM, found it.  Thanks!

Regards,

Dennis the Menace

dennismccreery

Adding the boot delay seems to have solved the problem completely, thanks Dan!

Regards,

Dennis the Menace

dennismccreery

Spoke too soon, fixed it for a good long while but last night the same message recurred.  Booting fixed it.
I'll try setting the startup delay to 20 seconds.

Regards,

Dennis the Menace

dennismccreery

No joy.  However, now I'm seeing a different error message:

Quote
2022-12-22 15:30:56.439 (1686) [ChannelOut] /opt/fpp/src/channeloutput/ColorLight-5a-75.cpp:280: Error getting index of eth1 interface: No such device

2022-12-22 15:30:56.479 (1686) [ChannelOut] /opt/fpp/src/channeloutput/ChannelOutputSetup.cpp:351: Determined range needed 0 - 7


Not sure where to go from here.  Rebooting fixes it.

Regards,

Dennis the Menace

LedMutt

I also had issues running in multisync and remote, could not get anything to work, then I went wired separated show network, multiple controllers and a network switch, also for the FPP I used this  https://www.amazon.com/gp/product/B09HBRG59N/ref=ox_sc_act_title_1?smid=AOP0CH6UTUPHT&psc=1, its a CM4 carrier board designed for a router, but can be used with any OS, it has dual Ethernet ports, used one for the player and one to drive P5 Led Matrix, no need for USB dongle, for the P5 panels, the WiFi is disabled, when I was trying using remotes over WiFi, used WiFi extender to boost signal, did not worked for me, after xmas will configure player with a wired network instead of wireless...so far all is working ...

Support FPP

+- Recent Topics

Script/Plug-In Trigger on Data by darylc
Today at 05:15:35 PM

Attempting to move to FPP 6.3 from 4.4 - Assigned IP is in different subnet. by Poporacer
Today at 05:06:59 PM

F48v4NS - Pi or No Pi? by tbone321
Today at 04:49:25 PM

Camera input for WS2811's by dkulp
Today at 04:02:55 PM

F16v3 Won't boot or power on by rjhodgefamily
Today at 02:22:05 PM

Set Time/Date by Rick
January 29, 2023, 10:09:08 PM

help getting started, next step? by Poporacer
January 28, 2023, 05:10:18 PM

Trying to configure LOR CF50D Floods on FPP Pi Player with PiCap by half.fast
January 28, 2023, 03:19:37 PM

wifi issues on BBB running fpp v6.3 by k6ccc
January 28, 2023, 02:04:23 PM

BBB / FPP sending data to ESP32 WLED by srwmemphis
January 28, 2023, 04:39:02 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod