News:

Server migration complete, Welcome to version 2.1.1

+-+-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Site Stats

Members
Total Members: 16398
Latest: rafelog927
New This Month: 0
New This Week: 0
New Today: 0
Stats
Total Posts: 132035
Total Topics: 16363
Most Online Today: 95
Most Online Ever: 7634
(January 21, 2020, 02:14:03 AM)
Users Online
Members: 1
Guests: 42
Total: 43

FPP 7.3.1 sending mixed colors?

Started by plaethos75, December 06, 2023, 12:08:21 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

plaethos75

Apologies ahead of time for this one.  I'll try to explain.  I have several ports that run a hue of blue, for an effect.  When I run my sequence, it comes on as red?  When I test directly through xlights, it works as it should.  When I run the sequence directly from FPP (Rasp Pi 3 B+), the blue shows red.  

Testing FPP, color sequence in a test cycle pattern of R-G-B [ALL-none] displays G-B-R
When running test ramps or color wash on F16v3, colors are correct.

Through x-lights I have uploaded the models via FPP connect; validated my ports/colors are correct for my pixels (every single one is RGB).

Now to be fair - I was running a previous code train from last year and I did the download/upgrade FPPOS through the about option...so could this be in part of my upgrade method?

FPP ABOUT:

Version Info 
FPP Version:7.3.1
Platform:Raspberry Pi (Pi 3 Model B)
FPP OS Build:v2023-11
OS Version:Raspbian GNU/Linux 11 (bullseye)
Hardware Serial Number:00000000071ad81b
Kernel Version:6.1.21-v7+
System Boot Time:2023-12-05 23:19:14
fppd Uptime:16:42



tbone321

7.3.1 has a lot of issues.  Go into HELP/ABOUT and run the upgrade to get to 7.3.5 and see if it improves.

plaethos75


CaptainMurdoch

The channel tester in FPP will only show correct colors if the channel numbers are aligned properly based on the start channel set on the test page.  You can try turning on only a single model or manually setting the start/end channels for the model in the channel tester and it might work.  The channel tester sets RGB starting at channel 1 (or whatever the start channel is set to) so if your model starts on channel 5 and FPP channel tester thinks that is green then your colors will be off.  That won't affect playing a sequence.
-
Chris

Poporacer

Quote from: plaethos75 on December 06, 2023, 12:08:21 AMWhen I test directly through xlights, it works as it should. 
How do you have the color order defined in xLights? There are 2 possible places. Can you describe or post a screenshot of those?
If to err is human, I am more human than most people.

plaethos75

#5
Not sure 100% exactly what info you're looking for.  For each model, where you specify the ports, channels/universe etc, I do NOT have the specifc color specs set.  As for the testing in X-Lights, I honestly, just click the light bulb and click on play - I don't recall ever setting specific settings other than defining the color to be used from the color palette.

Also -- I did a downgrade to 7.2 - no change.
I know in the past when I had issues, the flash card/SD card was wonky -- it seems everything else works fine...so I'm guessing this isn't the issue...but figured I'd ask.  Is there a built-in diag you can run to check the card to ensure it's operating correctly?  If so, what is that command?  It would be something to add to the GUI if it's something missing.  Just my $.02 

Lastly; I did notice in the recent version of xlights, or perhaps it was prior to the one I'm using (which is the latest), Originally the PI option, you could specific GPIOs as channels.  I did this to run dumb/analog lights to incorporate or use as after hour effects.  I don't see that option anymore.  I know this isn't a forum on xlights, but any suggestions on that?  I just have channels 1-8 for my analog; 9-22448 for my F16 board (split between universes of course).


plaethos75

Adding Screenshots of my xlights configs in case it helps

Support FPP

+- Recent Topics

Kiosk mode touchscreen by Poporacer
February 19, 2024, 08:57:25 AM

reviving a bbb on an octoscroller by Poporacer
February 18, 2024, 11:25:33 AM

FPP After Hours Music Plugin has been updated by Poporacer
February 16, 2024, 03:40:05 PM

External WiFi Adapter and Antenna by JonB256
February 16, 2024, 08:25:13 AM

troubles getting UCS2904/TM1814 to work properly by ocupmoc
February 12, 2024, 11:15:53 AM

F16v4s keep freezing up by Zcarpenter
February 12, 2024, 08:02:46 AM

xLights in Ubuntu 22.04 by LedMutt
February 07, 2024, 08:48:43 PM

FPP 8 early alpha pre-release feedback by LedMutt
February 07, 2024, 08:39:23 PM

Why a custom/minimized bootstrap implementation in fpp? by jcross
February 07, 2024, 12:03:14 PM

AfterHours Plugin status from API or MQTT? by jcross
February 07, 2024, 10:12:32 AM

Powered by EzPortal
Powered by SMFPacks Menu Editor Mod